The officially official Devuan Forum!

You are not logged in.

#1 2022-01-04 16:06:00

penguin
Member
Registered: 2019-05-05
Posts: 21  

[SOLVED] Android OS in qemu's virtual machine fails to in graphics mode.

Hi,

I followed the instruction on the link.

https://linuxhint.com/android_qemu_play_3d_games_linux/

I added my account 'penguin' to kvm and libvirt groups. And I installed all packages related to qemu.

$ group
penguin cdrom floppy audio dip video plugdev netdev lpadmin scanner kvm libvirt

When the  gl=on, the qemu window went blank. So I had to turn off the gl flag.

qemu-system-x86_64 -enable-kvm -m 2048 -smp 2 -cpu host -soundhw es1370 -device virtio-mouse-pci -device virtio-keyboard-pci -serial mon:stdio -boot menu=on -net nic -net user,hostfwd=tcp::5555-:22 -device virtio-vga,virgl=on -display gtk,gl=off -hda androidx86_hda.img -cdrom android-x86-8.1-r6.iso

The qemu showed the window and the installation of Android OS went smoothly.
1-32.png

Booting Android OS in the virtual machine of qemu ends up text mode as super user.
Booting Android OS from Live CD mode ends up text mode as super user too.

I wonder what I have missed for qemu setting.

Thanks in advance.

Last edited by penguin (2022-01-04 16:11:26)

Offline

#2 2022-01-04 19:30:22

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 710  

Re: [SOLVED] Android OS in qemu's virtual machine fails to in graphics mode.

I'm far from expert on this, but as implied from this "random" blog, maybe one should use virtio-vga-gl instead of virtio-vga,virgl=on and then gl=on.

Offline

#3 2022-01-05 00:02:56

penguin
Member
Registered: 2019-05-05
Posts: 21  

Re: [SOLVED] Android OS in qemu's virtual machine fails to in graphics mode.

@ralph

The qemu version is 5.2.0.

 $ qemu-system-x86_64 --version
QEMU emulator version 5.2.0 (Debian 1:5.2+dfsg-11+deb11u1)
Copyright (c) 2003-2020 Fabrice Bellard and the QEMU Project developers
 $ qemu-system-x86_64 -enable-kvm -m 2048 -smp 2 -cpu host -soundhw es1370 -device virtio-mouse-pci -device virtio-keyboard-pci -serial mon:stdio -boot menu=on -net nic -net user,hostfwd=tcp::5555-:22 -device virtio-vga-gl -display gtk -hda androidx86_hda.img -cdrom android-x86-8.1-r6.iso
qemu-system-x86_64: warning: '-soundhw es1370' is deprecated, please use '-device ES1370' instead
qemu-system-x86_64: -device virtio-vga-gl: 'virtio-vga-gl' is not a valid device model name

I suspect the qemu package on chimaera repository do not support virtio-vga-gl.

Offline

#4 2022-01-05 15:51:07

penguin
Member
Registered: 2019-05-05
Posts: 21  

Re: [SOLVED] Android OS in qemu's virtual machine fails to in graphics mode.

I manage to install Android-x86 9.0.
The installation steps I did:

Start libvirtd daemon

$ sudo /etc/init.d/libvirtd start 

$ sudo virt-manager 

I followed the Android installation instruction on https://www.tecmint.com/install-and-con … -in-linux/

Offline

Board footer