The officially official Devuan Forum!

You are not logged in.

#1 2021-10-03 12:31:26

alexkemp
Member
Registered: 2018-05-14
Posts: 43  

Updating to Chimaera - Marginally Painless

…or at least, it would be if I hadn't made a small mistake & someone in some mirror hadn't made a bigger mistake.

Reason for Upgrade:

I was backing up all my DVDs to a USB hard-disk as ISOs & then extracting as mp4 using Handbrake. There were far too many errors in the latest version supplied with Beowulf, and Chimaera offered a much later version. That proved to be fully correct after update.

Before Upgrade:

Pages consulted:

Since Chimaera was reported to be almost ready for transition to Stable, after consulting the above I decided that it should be possible to make a simple replacement in my existing sources.list of 'beowulf' by 'chimaera'. That was accurate except for the commented-out Chimaera line below.

Method of Upgrade:
~$ sudo nano /etc/apt/sources.list
~$ cat /etc/apt/sources.list
deb http://deb.devuan.org/merged chimaera main non-free contrib
deb http://deb.devuan.org/merged chimaera-security main non-free contrib
deb http://deb.devuan.org/merged chimaera-updates main non-free contrib
deb http://deb.devuan.org/devuan chimaera-proposed-updates main non-free contrib
#deb http://deb.devuan.org/merged chimaera-backports main non-free contrib

## package repositories
#deb http://deb.devuan.org/merged/ beowulf main non-free contrib 
#deb http://deb.devuan.org/merged/ beowulf-updates main non-free contrib 
#deb http://deb.devuan.org/merged/ beowulf-security main non-free contrib 
#deb http://deb.devuan.org/devuan/ beowulf-proposed main non-free contrib  
#deb http://deb.devuan.org/merged/ beowulf-backports main non-free contrib 

~$ sudo apt-get update && sudo apt-get dist-upgrade
Errors Experienced:

A single package (Libreoffice from Backports) gave a 404 File Not Accessible & the whole update collapsed in the middle. Unfortunately XFCE was in the middle of update & the GUI (including SLIM) failed after I tried restarting. Fortunately, I'm comfortable administering servers from a terminal.

The Fix:

This was easy once I got the point.

The problem was in a remote mirror connected with chimaera-backports. After commenting-out that line I did the update/dist-upgrade again (and again & again). The system complained, but gave some sensible suggestions, which I followed:

~$ sudo apt --fix-broken install
~$ sudo dpkg --configure -a

It's a heck of a business replacing a complete OS, of course, so I was patient and it finally completed.

The whole thing has gone from:

Devuan GNU/Linux 3.1 (beowulf) x86_64
to:
Devuan GNU/Linux 4 (chimaera) x86_64

Good job, veteran Admins!

(updated (speling))

Last edited by alexkemp (2021-10-03 12:37:48)

Offline

#2 2021-10-14 17:25:28

alexkemp
Member
Registered: 2018-05-14
Posts: 43  

Re: Updating to Chimaera - Marginally Painless

Backports has been uncommented, resulting in LibreOffice updating to 7.2.1. The reason for that is that I appear to have done a customary system update just now exactly as Chimaera has gone from 'testing' to 'stable' (see the terminal results below):

:~$ sudo apt update && sudo apt install -f && sudo apt upgrade && sudo /usr/local/bin/youtube-dl -U && sudo /etc/cron.daily/mlocate
Get:1 https://josm.openstreetmap.de/apt alldist InRelease [4,591 B]
Get:2 https://josm.openstreetmap.de/apt alldist/universe amd64 Packages [1,083 B]
Get:3 http://deb.devuan.org/merged chimaera InRelease [33.8 kB]    
Get:4 http://deb.devuan.org/merged chimaera-security InRelease [21.3 kB]
Get:5 http://deb.devuan.org/merged chimaera-updates InRelease [26.4 kB]
Get:6 http://deb.devuan.org/devuan chimaera-proposed-updates InRelease [24.5 kB]
Fetched 112 kB in 3s (39.5 kB/s)    
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
N: Repository 'http://deb.devuan.org/merged chimaera InRelease' changed its 'Version' value from '4.0.0' to '4.0'
N: Repository 'http://deb.devuan.org/merged chimaera InRelease' changed its 'Suite' value from 'testing' to 'stable'
N: Repository 'http://deb.devuan.org/merged chimaera-security InRelease' changed its 'Suite' value from 'testing-security' to 'stable-security'
N: Repository 'http://deb.devuan.org/merged chimaera-updates InRelease' changed its 'Suite' value from 'testing-updates' to 'stable-updates'
N: Repository 'http://deb.devuan.org/devuan chimaera-proposed-updates InRelease' changed its 'Suite' value from 'testing-proposed-updates' to 'chimaera-proposed-updates'
Reading package lists... Done
…
Do you want to continue? [Y/n] n
Abort.

A quick `sudo nano /etc/apt/sources.list`, remove the comment ('#') from backports & run the original update again, with dramatic results:

:~$ sudo apt update && sudo apt install -f && sudo apt upgrade && sudo /usr/local/bin/youtube-dl -U && sudo /etc/cron.daily/mlocate
Hit:1 http://deb.devuan.org/merged chimaera InRelease
Get:2 http://deb.devuan.org/merged chimaera-security InRelease [21.3 kB]     
Get:3 http://deb.devuan.org/merged chimaera-updates InRelease [26.4 kB]      
Hit:4 http://deb.devuan.org/devuan chimaera-proposed-updates InRelease                   
Get:5 http://deb.devuan.org/merged chimaera-backports InRelease [19.3 kB]    
Hit:6 https://josm.openstreetmap.de/apt alldist InRelease                    
Get:7 http://deb.devuan.org/merged chimaera-security/main amd64 Packages [47.9 kB]
Get:8 http://deb.devuan.org/merged chimaera-backports/main amd64 Packages [89.5 kB]
Get:9 http://deb.devuan.org/merged chimaera-backports/non-free amd64 Packages [1,216 B]
Get:10 http://deb.devuan.org/merged chimaera-backports/contrib amd64 Packages [536 B]
Fetched 206 kB in 2s (131 kB/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
36 packages can be upgraded. Run 'apt list --upgradable' to see them.
…
The following packages were automatically installed and are no longer required:
  libcmis-0.5-5v5 libjuh-java libjurt-java libqrcodegencpp1 libridl-java libunoil-java
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libbox2d2.3.0 libzxingcore1 ure-java
The following packages have been kept back:
  liblibreoffice-java
The following packages will be upgraded:
  at-spi2-core fonts-opensymbol gir1.2-atspi-2.0 gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 iproute2 josm-latest libatspi2.0-0
  libjavascriptcoregtk-4.0-18 libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-gtk3 libreoffice-help-common libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-style-colibre libreoffice-writer libuno-cppu3
  libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3 libunoloader-java libvulkan1
  libwebkit2gtk-4.0-37 orca uno-libs-private ure
35 upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Need to get 135 MB/135 MB of archives.
After this operation, 12.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
…

Not too long, and everyone can now expect an auto-update to Chimaera as Stable!

Offline

#3 2021-10-14 23:35:52

alexkemp
Member
Registered: 2018-05-14
Posts: 43  

Re: Updating to Chimaera - Marginally Painless

OK, it's official (announced yesterday), Chimera is now the STABLE release:

https://www.devuan.org/os/announce/chim … 2021-10-14

Re-running the general update again & liblibreoffice-java has been updated & is no longer held back.

Last edited by alexkemp (2021-10-14 23:38:20)

Offline

#4 2021-12-12 14:47:03

swarfendor437
Member
From: Somewhere off Atlantis
Registered: 2020-10-28
Posts: 103  

Re: Updating to Chimaera - Marginally Painless

I am curious about upgrading from 3.1 to 4. Will the OS update interfere with installed proprietary applications? (SoftMaker Office 2021, pdf Stuio Pro 2021).

Is there an instruction note on the main Devuan page on how to update?

I did install 4 on an old drive as wanted to see how the accessible speech install worked - outstanding!

Offline

#5 2021-12-12 17:09:27

alexkemp
Member
Registered: 2018-05-14
Posts: 43  

Re: Updating to Chimaera - Marginally Painless

Hi there swarfendor437

I cannot answer for SoftMaker nor pdf Studio Pro, but my recall is that I got problems with a single installation, which was KeyMon (a python-driven utility which shows the keyboard keys pressed as you press them - very useful for YouTube videos if you are recording your desktop/terminal for YT).

The issue was the departure from Python2 to a base-standard of Python3 (all of this is off the top of my head & thus prone to errors). The repository-version of KeyMon could not run on python3 and thus KeyMon was not in Chimaera & wiped from my system on upgrade. Thankfully I found a github version by the original writer with specifically added python-3 support & it works fine.

For the rest I give the full instructions that allowed me to upgrade. So, either use that or refer to the links in the OP to bake it yourself.

Offline

#6 2021-12-12 18:21:55

rolfie
Member
Registered: 2017-11-25
Posts: 644  

Re: Updating to Chimaera - Marginally Painless

On the top of the forum page is a link to Devuan.org where you can find the official documentation and several howtos.

Myself I have upgraded my wifes PC and my file server from Beowulf to Chimaera without any issues. My PC is using parallel installation of Arch/Beowulf/Chimaera. I have moved my activities from Beowulf to Chimaera early summer this year before Chimaera even got stable.

General advice: disable any foreign repositories during the upgrade.

rolfie

Offline

Board footer