The officially official Devuan Forum!

You are not logged in.

#1 2021-11-04 09:07:09

vanfanel
Member
Registered: 2021-10-27
Posts: 3  

Video turns off on high CPU usage with Devuan 4.0 on Raspberry PI 4

Hi there,

I successfully run Devuan 4.0 arm64 on a Pi4b, but HDMI screen turns off and never comes back when all 4 cores are used for long compilation tasks. The screen goes off and never comes back.

Note that I use the full KMS graphics stack, so in config.txt I have:

dtoverlay=vc4-kms-v3d

And in cmdline.txt I have:

video="HDMI-A-1:1280x720@60"

Note that all hdmi_* config options are ignored in full KMS mode, since it uses the standard Linux KMS interface instead of the Broadcom-propietary video interface that those hdmi_* options are for.

This bug also happened on Raspberry Pi OS at some point, but it was eventually fixed:

https://github.com/raspberrypi/firmware/issues/1598

It has to do with throttling: throttling is happening, but it shouldn't cause video to be disconnected.

Also, is there a Pi4 arm64 kernel package I can update via apt-get? The image comes with a custom PREEMPT kernel, which is great, but I don't know how to update the kernel or the firmware (dtbs, etc).

Thanks!

Last edited by vanfanel (2021-11-04 12:30:34)

Offline

#2 2021-11-04 12:59:13

ShorTie
Member
Registered: 2020-05-14
Posts: 17  

Re: Video turns off on high CPU usage with Devuan 4.0 on Raspberry PI 4

If you fix your heat/thermal problem so no throttling occurs.
With a simple heatsink.
All this will go away .. hmm~

Offline

#3 2021-11-04 13:50:51

vanfanel
Member
Registered: 2021-10-27
Posts: 3  

Re: Video turns off on high CPU usage with Devuan 4.0 on Raspberry PI 4

@ShorTie: Yes, but throttling shouldn't cause video to go off. That's a different issue.

Offline

Board footer