The officially official Devuan Forum!

You are not logged in.

#1 2021-10-15 01:36:08

erdos
Member
Registered: 2018-06-04
Posts: 66  

[SOLVED] Apt-get update error during Chimaera upgrade

hi, i'm trying to upgrade to Chimaera from beowulf and encountered the following during apt update:

root@htpc-devuan:/home/erdos/Downloads# apt-get update
Get:1 [url]http://dl.google.com/linux/earth/deb[/url] stable InRelease [1,807 B]
Get:2 [url]https://repo.skype.com/deb[/url] stable InRelease [4,502 B]         
Err:1 [url]http://dl.google.com/linux/earth/deb[/url] stable InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13
Get:3 [url]https://repo.skype.com/deb[/url] stable/main amd64 Packages [2,256 B]
Get:4 [url]http://deb.devuan.org/merged[/url] chimaera InRelease [33.8 kB]
Get:5 [url]http://deb.devuan.org/merged[/url] chimaera-updates InRelease [26.4 kB]
Get:6 [url]http://deb.devuan.org/merged[/url] chimaera-security InRelease [21.3 kB]
Get:7 [url]http://deb.devuan.org/merged[/url] chimaera/main i386 Packages [8,247 kB]
Get:8 [url]http://deb.devuan.org/merged[/url] chimaera/main amd64 Packages [8,309 kB]
Get:9 [url]http://deb.devuan.org/merged[/url] chimaera/main Translation-en [6,482 kB]     
Get:10 [url]http://deb.devuan.org/merged[/url] chimaera-updates/main Translation-en [2,108 B]
Get:11 [url]http://deb.devuan.org/merged[/url] chimaera-security/main i386 Packages [48.0 kB]
Get:12 [url]http://deb.devuan.org/merged[/url] chimaera-security/main amd64 Packages [48.0 kB]
Reading package lists... Done                                                  
W: GPG error: [url]http://dl.google.com/linux/earth/deb[/url] stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13
E: The repository 'http://dl.google.com/linux/earth/deb stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@htpc-devuan:/home/erdos/Downloads# 

i believe i installed zoom and google-earth through .deb package.  is this a concern for continuing upgrade to chimaera?

Last edited by erdos (2021-10-16 00:14:23)

Offline

#2 2021-10-15 02:05:20

GlennW
Member
Registered: 2019-07-18
Posts: 169  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

Hi, I don't think it is a concern for updating/upgrading chimaera. Your Earth package may survive intact.

Offline

#3 2021-10-15 16:21:40

rolfie
Member
Registered: 2017-11-25
Posts: 587  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

The recommendation is to exclude all foreign sources from the upgrade. In your case Earth and Skype and maybe Zoom.

Once the upgrade is done you may take care for the other stuff one by one.

rolfie

Online

#4 2021-10-15 23:56:58

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

I encountered additional error while performing 'apt-get dist-upgrade'

Setting up linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-5.10.0-9-amd64.postinst line 11.
dpkg: error processing package linux-headers-5.10.0-9-amd64 (--configure):
 installed linux-headers-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-headers-amd64:
 linux-headers-amd64 depends on linux-headers-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-headers-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libgc1:amd64 (1:8.0.4-3) ...
Setting up linux-image-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-5.10.0-9-amd64 (--configure):
 installed linux-image-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
Setting up guile-2.2-libs:amd64 (2.2.7+1-6) ...
dpkg: dependency problems prevent configuration of linux-image-amd64:
 linux-image-amd64 depends on linux-image-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-image-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-13+deb11u2) ...
Errors were encountered while processing:
 linux-headers-5.10.0-9-amd64
 linux-headers-amd64
 linux-image-5.10.0-9-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@htpc-devuan:/home/erdos/Downloads#

I have proprietary nvidia driver installed before upgrade.

any idea how to proceed?

Offline

#5 2021-10-16 02:16:31

GlennW
Member
Registered: 2019-07-18
Posts: 169  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

linux-image-amd64 is a "Task" package, enables updates for your amd64 kernel.

What you do need is Guile, dkms, linux-headers and linux-headers-common to suit your kernel version, linux-image-5.10.0-9-amd64 (5.10.70-1) installed to get your nvidia drivers/modules installed and running.

Offline

#6 2021-10-16 02:53:46

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

GlennW wrote:

linux-image-amd64 is a "Task" package, enables updates for your amd64 kernel.

What you do need is Guile, dkms, linux-headers and linux-headers-common to suit your kernel version, linux-image-5.10.0-9-amd64 (5.10.70-1) installed to get your nvidia drivers/modules installed and running.

thanks for the reply!
I try to install 'Guile-3.0', but it seems to indicating that linux-image-5.10.0-9-amd64 isn't properly installed/configured.  i can boot into 4.19 kernel for now but 'apt-get dist-upgrade' results the same error.   trying to remove 'nvidia-persistenced' package also results the same error.

erdos@htpc-devuan:~$ sudo apt-get install guile-3.0
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme
  clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp
  fonts-arphic-gbsn00lp fonts-linuxlibertine fonts-noto-extra
  fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database
  gtk2-engines-xfce hp-ppd irqbalance libasan5 libasync-mergepoint-perl
  libbind9-161 libboost-atomic1.67.0 libboost-chrono1.67.0
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0
  libboost-locale1.67.0 libboost-regex1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libbsh-java libcdio18 libcec4
  libcgi-fast-perl libcgi-pm-perl libclass-accessor-perl libcodec2-0.8.1
  libcroco3 libcwidget3v5 libdc1394-22 libdigest-bubblebabble-perl
  libdns-export1104 libdns1104 libdns1110 libdouble-conversion1 libdvdread4
  libemail-valid-perl libenchant1c2a libept1.5.0 libevent-2.1-6
  libevent-core-2.1-6 libevent-pthreads-2.1-6 libexiv2-14 libfcgi-bin
  libfcgi-perl libfcgi0ldbl libfluidsynth1 libfuture-perl libgail-3-0
  libgcc1:i386 libgeoip1 libgspell-1-1 libgssdp-1.0-3 libgupnp-1.0-4
  libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100 libhdf5-hl-fortran-100
  libicu63 libigdgmm5 libilmbase23 libio-async-perl libio-pty-perl
  libipc-run-perl libisc-export1100 libisc1100 libisc1105 libisccc161
  libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3 libjsoncpp1
  libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8 liblua5.3-0
  liblwres161 libm17n-0 libmetrics-any-perl libmpdec2 libmypaint-1.3-0
  libmysofa0 libnet-dns-perl libnet-dns-sec-perl libnet-ip-perl libnfs12
  libnftables0 libopenblas-base libopenexr23 liborcus-0.14-0 libotf0
  libpango-perl libparse-debianchangelog-perl libperl4-corelibs-perl
  libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7 libpython2-stdlib
  libpython2.7 libpython3.7 libpython3.7-minimal libpython3.7-stdlib libqhull7
  libqpdf21 libqscintilla2-qt5-13 libqt5concurrent5 libqt5opengl5 libraw19
  libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsdl1.2debian libsereal-perl
  libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl
  libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5
  libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165
  libxcb-util0 libxml-simple-perl linux-headers-4.19.0-9-common
  linux-image-4.9.0-12-amd64 linux-kbuild-4.19 m17n-db perl-modules-5.28
  printer-driver-hpijs python-pkg-resources python2 python2-minimal
  python3-gst-1.0 python3.7-minimal runit-helper xfce4-notes
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  guile-3.0-libs
Suggested packages:
  guile-3.0-doc
The following NEW packages will be installed:
  guile-3.0 guile-3.0-libs
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
Need to get 6,429 kB of archives.
After this operation, 53.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://deb.devuan.org/merged chimaera/main amd64 guile-3.0-libs amd64 3.0.5-4 [6,406 kB]
Get:2 http://deb.devuan.org/merged chimaera/main amd64 guile-3.0 amd64 3.0.5-4 [23.1 kB]
Fetched 6,429 kB in 4s (1,573 kB/s)
Selecting previously unselected package guile-3.0-libs:amd64.
(Reading database ... 215844 files and directories currently installed.)
Preparing to unpack .../guile-3.0-libs_3.0.5-4_amd64.deb ...
Unpacking guile-3.0-libs:amd64 (3.0.5-4) ...
Selecting previously unselected package guile-3.0.
Preparing to unpack .../guile-3.0_3.0.5-4_amd64.deb ...
Unpacking guile-3.0 (3.0.5-4) ...
Setting up linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-5.10.0-9-amd64.postinst line 11.
dpkg: error processing package linux-headers-5.10.0-9-amd64 (--configure):
 installed linux-headers-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
Setting up guile-3.0-libs:amd64 (3.0.5-4) ...
dpkg: dependency problems prevent configuration of linux-headers-amd64:
 linux-headers-amd64 depends on linux-headers-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-headers-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up linux-image-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-5.10.0-9-amd64 (--configure):
 installed linux-image-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
Setting up guile-3.0 (3.0.5-4) ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/guile/3.0/bin/guile to provide /usr/bin/guile (guile) in auto mode
dpkg: dependency problems prevent configuration of linux-image-amd64:
 linux-image-amd64 depends on linux-image-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-image-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-13+deb11u2) ...
Processing triggers for man-db (2.9.4-2) ...
Errors were encountered while processing:
 linux-headers-5.10.0-9-amd64
 linux-headers-amd64
 linux-image-5.10.0-9-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
erdos@htpc-devuan:~$ 
erdos@htpc-devuan:~$ sudo apt-get remove nvidia-persistenced
[sudo] password for erdos: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'nvidia-persistenced' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp fonts-arphic-gbsn00lp fonts-linuxlibertine
  fonts-noto-extra fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database gtk2-engines-xfce hp-ppd irqbalance libasan5 libasync-mergepoint-perl libbind9-161
  libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0 libboost-locale1.67.0 libboost-regex1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libbsh-java libcdio18 libcec4 libcgi-fast-perl libcgi-pm-perl libclass-accessor-perl libcodec2-0.8.1 libcroco3 libcwidget3v5 libdc1394-22
  libdigest-bubblebabble-perl libdns-export1104 libdns1104 libdns1110 libdouble-conversion1 libdvdread4 libemail-valid-perl libenchant1c2a libept1.5.0 libevent-2.1-6 libevent-core-2.1-6
  libevent-pthreads-2.1-6 libexiv2-14 libfcgi-bin libfcgi-perl libfcgi0ldbl libfluidsynth1 libfuture-perl libgail-3-0 libgcc1:i386 libgeoip1 libgspell-1-1 libgssdp-1.0-3 libgupnp-1.0-4
  libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100 libhdf5-hl-fortran-100 libicu63 libigdgmm5 libilmbase23 libio-async-perl libio-pty-perl libipc-run-perl libisc-export1100 libisc1100
  libisc1105 libisccc161 libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3 libjsoncpp1 libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8 liblua5.3-0 liblwres161
  libm17n-0 libmetrics-any-perl libmpdec2 libmypaint-1.3-0 libmysofa0 libnet-dns-perl libnet-dns-sec-perl libnet-ip-perl libnfs12 libnftables0 libopenblas-base libopenexr23 liborcus-0.14-0
  libotf0 libpango-perl libparse-debianchangelog-perl libperl4-corelibs-perl libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7 libpython2-stdlib libpython2.7 libpython3.7
  libpython3.7-minimal libpython3.7-stdlib libqhull7 libqpdf21 libqscintilla2-qt5-13 libqt5concurrent5 libqt5opengl5 libraw19 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-librelogo libreoffice-nlpsolver libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-wiki-publisher libsane
  libsdl1.2debian libsereal-perl libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5 libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165 libxcb-util0 libxml-simple-perl
  linux-headers-4.19.0-9-common linux-image-4.9.0-12-amd64 linux-kbuild-4.19 m17n-db perl-modules-5.28 printer-driver-hpijs python-pkg-resources python2 python2-minimal python3-gst-1.0
  python3.7-minimal runit-helper xfce4-notes
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-5.10.0-9-amd64.postinst line 11.
dpkg: error processing package linux-headers-5.10.0-9-amd64 (--configure):
 installed linux-headers-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-headers-amd64:
 linux-headers-amd64 depends on linux-headers-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-headers-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up linux-image-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-5.10.0-9-amd64 (--configure):
 installed linux-image-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-amd64:
 linux-image-amd64 depends on linux-image-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-image-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-5.10.0-9-amd64
 linux-headers-amd64
 linux-image-5.10.0-9-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

Last edited by erdos (2021-10-16 03:09:48)

Offline

#7 2021-10-16 09:50:00

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 117  
Website

Re: [SOLVED] Apt-get update error during Chimaera upgrade

erdos wrote:
GlennW wrote:

linux-image-amd64 is a "Task" package, enables updates for your amd64 kernel.

What you do need is Guile, dkms, linux-headers and linux-headers-common to suit your kernel version, linux-image-5.10.0-9-amd64 (5.10.70-1) installed to get your nvidia drivers/modules installed and running.

thanks for the reply!
I try to install 'Guile-3.0', but it seems to indicating that linux-image-5.10.0-9-amd64 isn't properly installed/configured.  i can boot into 4.19 kernel for now but 'apt-get dist-upgrade' results the same error.   trying to remove 'nvidia-persistenced' package also results the same error.

Try as root or sudo:
apt install -f
and dpkg --configure -a
and if the problem is not resolved, try removing the kernel packages and install nvidia dependencies and later install  kernel.
apt purge linux-image-5.10.0-9-amd64

Offline

#8 2021-10-16 13:54:51

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

Debuser2018 wrote:

Try as root or sudo:
apt install -f
and dpkg --configure -a
and if the problem is not resolved, try removing the kernel packages and install nvidia dependencies and later install  kernel.
apt purge linux-image-5.10.0-9-amd64


tried both and failed.  it seems to be a dependency hell now.

root@htpc-devuan:/home/erdos# apt install -f 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme
  clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp
  fonts-arphic-gbsn00lp fonts-linuxlibertine fonts-noto-extra
  fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database
  gtk2-engines-xfce hp-ppd irqbalance libasan5 libasync-mergepoint-perl
  libbind9-161 libboost-atomic1.67.0 libboost-chrono1.67.0
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0
  libboost-locale1.67.0 libboost-regex1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libbsh-java libcdio18 libcec4
  libcgi-fast-perl libcgi-pm-perl libclass-accessor-perl libcodec2-0.8.1
  libcroco3 libcwidget3v5 libdc1394-22 libdigest-bubblebabble-perl
  libdns-export1104 libdns1104 libdns1110 libdouble-conversion1 libdvdread4
  libemail-valid-perl libenchant1c2a libept1.5.0 libevent-2.1-6
  libevent-core-2.1-6 libevent-pthreads-2.1-6 libexiv2-14 libfcgi-bin
  libfcgi-perl libfcgi0ldbl libfluidsynth1 libfuture-perl libgail-3-0
  libgcc1:i386 libgeoip1 libgspell-1-1 libgssdp-1.0-3 libgupnp-1.0-4
  libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100 libhdf5-hl-fortran-100
  libicu63 libigdgmm5 libilmbase23 libio-async-perl libio-pty-perl
  libipc-run-perl libisc-export1100 libisc1100 libisc1105 libisccc161
  libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3 libjsoncpp1
  libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8 liblua5.3-0
  liblwres161 libm17n-0 libmetrics-any-perl libmpdec2 libmypaint-1.3-0
  libmysofa0 libnet-dns-perl libnet-dns-sec-perl libnet-ip-perl libnfs12
  libnftables0 libopenblas-base libopenexr23 liborcus-0.14-0 libotf0
  libpango-perl libparse-debianchangelog-perl libperl4-corelibs-perl
  libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7 libpython2-stdlib
  libpython2.7 libpython3.7 libpython3.7-minimal libpython3.7-stdlib libqhull7
  libqpdf21 libqscintilla2-qt5-13 libqt5concurrent5 libqt5opengl5 libraw19
  libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsdl1.2debian libsereal-perl
  libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl
  libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5
  libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165
  libxcb-util0 libxml-simple-perl linux-headers-4.19.0-9-common
  linux-image-4.9.0-12-amd64 linux-kbuild-4.19 m17n-db perl-modules-5.28
  printer-driver-hpijs python-pkg-resources python2 python2-minimal
  python3-gst-1.0 python3.7-minimal runit-helper xfce4-notes
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could n
ot locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-head
ers-5.10.0-9-amd64.postinst line 11.
dpkg: error processing package linux-headers-5.10.0-9-amd64 (--configure):
 installed linux-headers-5.10.0-9-amd64 package post-installation script subproc
ess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-headers-amd64:
 linux-headers-amd64 depends on linux-headers-5.10.0-9-amd64 (= 5.10.70-1); howe
ver:
  Package linux-headers-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up linux-image-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could n
ot locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-5.10.0-9-amd64 (--configure):
 installed linux-image-5.10.0-9-amd64 package post-installation script subproces
s returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-amd64:
 linux-image-amd64 depends on linux-image-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-image-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-5.10.0-9-amd64
 linux-headers-amd64
 linux-image-5.10.0-9-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@htpc-devuan:/home/erdos# dpkg --configure -a
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
root@htpc-devuan:/home/erdos#

root@htpc-devuan:/home/erdos# apt purge linux-image-5.10.0-9-amd64
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme
  clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp
  fonts-arphic-gbsn00lp fonts-linuxlibertine fonts-noto-extra
  fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database
  gtk2-engines-xfce hp-ppd irqbalance libasan5 libasync-mergepoint-perl
  libbind9-161 libboost-atomic1.67.0 libboost-chrono1.67.0
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0
  libboost-locale1.67.0 libboost-regex1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libbsh-java libcdio18 libcec4
  libcgi-fast-perl libcgi-pm-perl libclass-accessor-perl libcodec2-0.8.1
  libcroco3 libcwidget3v5 libdc1394-22 libdigest-bubblebabble-perl
  libdns-export1104 libdns1104 libdns1110 libdouble-conversion1 libdvdread4
  libemail-valid-perl libenchant1c2a libept1.5.0 libevent-2.1-6
  libevent-core-2.1-6 libevent-pthreads-2.1-6 libexiv2-14 libfcgi-bin
  libfcgi-perl libfcgi0ldbl libfluidsynth1 libfuture-perl libgail-3-0
  libgcc1:i386 libgeoip1 libgspell-1-1 libgssdp-1.0-3 libgupnp-1.0-4
  libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100 libhdf5-hl-fortran-100
  libicu63 libigdgmm5 libilmbase23 libio-async-perl libio-pty-perl
  libipc-run-perl libisc-export1100 libisc1100 libisc1105 libisccc161
  libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3 libjsoncpp1
  libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8 liblua5.3-0
  liblwres161 libm17n-0 libmetrics-any-perl libmpdec2 libmypaint-1.3-0
  libmysofa0 libnet-dns-perl libnet-dns-sec-perl libnet-ip-perl libnfs12
  libnftables0 libopenblas-base libopenexr23 liborcus-0.14-0 libotf0
  libpango-perl libparse-debianchangelog-perl libperl4-corelibs-perl
  libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7 libpython2-stdlib
  libpython2.7 libpython3.7 libpython3.7-minimal libpython3.7-stdlib libqhull7
  libqpdf21 libqscintilla2-qt5-13 libqt5concurrent5 libqt5opengl5 libraw19
  libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsdl1.2debian libsereal-perl
  libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl
  libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5
  libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165
  libxcb-util0 libxml-simple-perl linux-headers-4.19.0-9-common
  linux-image-4.9.0-12-amd64 linux-kbuild-4.19 m17n-db perl-modules-5.28
  printer-driver-hpijs python-pkg-resources python2 python2-minimal
  python3-gst-1.0 python3.7-minimal runit-helper xfce4-notes
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  linux-image-5.10.0-9-amd64* linux-image-amd64*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 302 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 216585 files and directories currently installed.)
Removing linux-image-amd64 (5.10.70-1) ...
Removing linux-image-5.10.0-9-amd64 (5.10.70-1) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.9.0-12-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-4.9.0-12-amd64
I: /vmlinuz is now a symlink to boot/vmlinuz-4.19.0-9-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.19.0-9-amd64
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-5.10.0-9-amd64
/etc/kernel/postrm.d/zz-update-grub:
Generating grub configuration file ...
Found theme: /usr/share/desktop-base/grub-themes/desktop-grub-theme/theme.txt
Found linux image: /boot/vmlinuz-4.19.0-9-amd64
Found initrd image: /boot/initrd.img-4.19.0-9-amd64
Found linux image: /boot/vmlinuz-4.9.0-12-amd64
Found initrd image: /boot/initrd.img-4.9.0-12-amd64
done
Setting up linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could n
ot locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-head
ers-5.10.0-9-amd64.postinst line 11.
dpkg: error processing package linux-headers-5.10.0-9-amd64 (--configure):
 installed linux-headers-5.10.0-9-amd64 package post-installation script subproc
ess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-headers-amd64:
 linux-headers-amd64 depends on linux-headers-5.10.0-9-amd64 (= 5.10.70-1); howe
ver:
  Package linux-headers-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-5.10.0-9-amd64
 linux-headers-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@htpc-devuan:/home/erdos#

Last edited by erdos (2021-10-16 14:08:53)

Offline

#9 2021-10-16 14:02:36

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

I poke around for the 'missing' dkms.conf file, it's there but in a different directory than devuan expected.

erdos@htpc-devuan:~$ ls -l /var/lib/dkms/nvidia/340.108/
total 4
drwxr-xr-x 2 root root 4096 Mar  7  2020 build
lrwxrwxrwx 1 root root   23 Mar  7  2020 source -> /usr/src/nvidia-340.108
erdos@htpc-devuan:~$ ls -l /usr/src/nvidia-legacy-340xx-340.108/dkms*
-rw-r--r-- 1 root root 861 Feb  2  2020 /usr/src/nvidia-legacy-340xx-340.108/dkms.conf
erdos@htpc-devuan:~$

Offline

#10 2021-10-16 15:46:38

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 117  
Website

Re: [SOLVED] Apt-get update error during Chimaera upgrade

Remove all the 5.x kernels and kernel headers and retry.
apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64

Offline

#11 2021-10-16 16:06:16

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

Debuser2018 wrote:

Remove all the 5.x kernels and kernel headers and retry.
apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64

both
apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64
apt install -f

are success, but dpkg --configure -a still ends with error.

root@htpc-devuan:/home/erdos# apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme
  clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp
  fonts-arphic-gbsn00lp fonts-linuxlibertine fonts-noto-extra
  fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database
  gtk2-engines-xfce hp-ppd libasan5 libasync-mergepoint-perl libbind9-161
  libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0
  libboost-filesystem1.67.0 libboost-iostreams1.67.0 libboost-locale1.67.0
  libboost-regex1.67.0 libboost-system1.67.0 libboost-thread1.67.0
  libbrlapi0.6 libbsh-java libcdio18 libcec4 libcgi-fast-perl libcgi-pm-perl
  libclass-accessor-perl libcodec2-0.8.1 libcroco3 libcwidget3v5 libdc1394-22
  libdigest-bubblebabble-perl libdns-export1104 libdns1104 libdns1110
  libdouble-conversion1 libdvdread4 libemail-valid-perl libenchant1c2a
  libept1.5.0 libevent-2.1-6 libevent-core-2.1-6 libevent-pthreads-2.1-6
  libexiv2-14 libfcgi-bin libfcgi-perl libfcgi0ldbl libfluidsynth1
  libfuture-perl libgail-3-0 libgcc1:i386 libgeoip1 libgspell-1-1
  libgssdp-1.0-3 libgupnp-1.0-4 libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100
  libhdf5-hl-fortran-100 libicu63 libigdgmm5 libilmbase23 libio-async-perl
  libio-pty-perl libipc-run-perl libisc-export1100 libisc1100 libisc1105
  libisccc161 libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3
  libjsoncpp1 libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8
  liblua5.3-0 liblwres161 libm17n-0 libmetrics-any-perl libmpdec2
  libmypaint-1.3-0 libmysofa0 libnet-dns-perl libnet-dns-sec-perl
  libnet-ip-perl libnfs12 libnftables0 libopenblas-base libopenexr23
  liborcus-0.14-0 libotf0 libpango-perl libparse-debianchangelog-perl
  libperl4-corelibs-perl libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7
  libpython2-stdlib libpython2.7 libpython3.7 libpython3.7-minimal
  libpython3.7-stdlib libqhull7 libqpdf21 libqscintilla2-qt5-13
  libqt5concurrent5 libqt5opengl5 libraw19 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsdl1.2debian libsereal-perl
  libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl
  libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5
  libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165
  libxcb-util0 libxml-simple-perl linux-compiler-gcc-10-x86
  linux-headers-4.19.0-9-common linux-headers-5.10.0-9-common
  linux-kbuild-4.19 linux-kbuild-5.10 m17n-db perl-modules-5.28
  printer-driver-hpijs python-pkg-resources python2 python2-minimal
  python3-gst-1.0 python3.7-minimal xfce4-notes
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  linux-headers-5.10.0-9-amd64* linux-headers-amd64*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 5,548 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 211815 files and directories currently installed.)
Removing linux-headers-amd64 (5.10.70-1) ...
Removing linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
dpkg: warning: while removing linux-headers-5.10.0-9-amd64, directory '/lib/modu
les/5.10.0-9-amd64' not empty so not removed
(Reading database ... 202885 files and directories currently installed.)
Purging configuration files for linux-headers-amd64 (5.10.70-1) ...
dpkg: warning: while removing linux-headers-amd64, directory '/usr/share/doc/lin
ux-headers-amd64' not empty so not removed
root@htpc-devuan:/home/erdos# apt install -f 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme
  clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp
  fonts-arphic-gbsn00lp fonts-linuxlibertine fonts-noto-extra
  fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database
  gtk2-engines-xfce hp-ppd libasan5 libasync-mergepoint-perl libbind9-161
  libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0
  libboost-filesystem1.67.0 libboost-iostreams1.67.0 libboost-locale1.67.0
  libboost-regex1.67.0 libboost-system1.67.0 libboost-thread1.67.0
  libbrlapi0.6 libbsh-java libcdio18 libcec4 libcgi-fast-perl libcgi-pm-perl
  libclass-accessor-perl libcodec2-0.8.1 libcroco3 libcwidget3v5 libdc1394-22
  libdigest-bubblebabble-perl libdns-export1104 libdns1104 libdns1110
  libdouble-conversion1 libdvdread4 libemail-valid-perl libenchant1c2a
  libept1.5.0 libevent-2.1-6 libevent-core-2.1-6 libevent-pthreads-2.1-6
  libexiv2-14 libfcgi-bin libfcgi-perl libfcgi0ldbl libfluidsynth1
  libfuture-perl libgail-3-0 libgcc1:i386 libgeoip1 libgspell-1-1
  libgssdp-1.0-3 libgupnp-1.0-4 libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100
  libhdf5-hl-fortran-100 libicu63 libigdgmm5 libilmbase23 libio-async-perl
  libio-pty-perl libipc-run-perl libisc-export1100 libisc1100 libisc1105
  libisccc161 libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3
  libjsoncpp1 libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8
  liblua5.3-0 liblwres161 libm17n-0 libmetrics-any-perl libmpdec2
  libmypaint-1.3-0 libmysofa0 libnet-dns-perl libnet-dns-sec-perl
  libnet-ip-perl libnfs12 libnftables0 libopenblas-base libopenexr23
  liborcus-0.14-0 libotf0 libpango-perl libparse-debianchangelog-perl
  libperl4-corelibs-perl libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7
  libpython2-stdlib libpython2.7 libpython3.7 libpython3.7-minimal
  libpython3.7-stdlib libqhull7 libqpdf21 libqscintilla2-qt5-13
  libqt5concurrent5 libqt5opengl5 libraw19 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsdl1.2debian libsereal-perl
  libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl
  libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5
  libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165
  libxcb-util0 libxml-simple-perl linux-compiler-gcc-10-x86
  linux-headers-4.19.0-9-common linux-headers-5.10.0-9-common
  linux-kbuild-4.19 linux-kbuild-5.10 m17n-db perl-modules-5.28
  printer-driver-hpijs python-pkg-resources python2 python2-minimal
  python3-gst-1.0 python3.7-minimal xfce4-notes
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@htpc-devuan:/home/erdos# y
bash: y: command not found
root@htpc-devuan:/home/erdos# dpkg --configure -a
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
root@htpc-devuan:/home/erdos# apt purge linux-image-5.10.0-9-amd64
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant-contrib apt-transport-https bsdmainutils cinnabar-icon-theme
  clearlooks-phenix-cinnabar-theme cpp-8 enchant fonts-arphic-bsmi00lp
  fonts-arphic-gbsn00lp fonts-linuxlibertine fonts-noto-extra
  fonts-roboto-slab fonts-sil-gentium fonts-sil-gentium-basic geoip-database
  gtk2-engines-xfce hp-ppd libasan5 libasync-mergepoint-perl libbind9-161
  libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0
  libboost-filesystem1.67.0 libboost-iostreams1.67.0 libboost-locale1.67.0
  libboost-regex1.67.0 libboost-system1.67.0 libboost-thread1.67.0
  libbrlapi0.6 libbsh-java libcdio18 libcec4 libcgi-fast-perl libcgi-pm-perl
  libclass-accessor-perl libcodec2-0.8.1 libcroco3 libcwidget3v5 libdc1394-22
  libdigest-bubblebabble-perl libdns-export1104 libdns1104 libdns1110
  libdouble-conversion1 libdvdread4 libemail-valid-perl libenchant1c2a
  libept1.5.0 libevent-2.1-6 libevent-core-2.1-6 libevent-pthreads-2.1-6
  libexiv2-14 libfcgi-bin libfcgi-perl libfcgi0ldbl libfluidsynth1
  libfuture-perl libgail-3-0 libgcc1:i386 libgeoip1 libgspell-1-1
  libgssdp-1.0-3 libgupnp-1.0-4 libhdf5-103 libhdf5-fortran-102 libhdf5-hl-100
  libhdf5-hl-fortran-100 libicu63 libigdgmm5 libilmbase23 libio-async-perl
  libio-pty-perl libipc-run-perl libisc-export1100 libisc1100 libisc1105
  libisccc161 libisccfg163 libisl19 libjim0.77 libjs-modernizr libjson-c3
  libjsoncpp1 libjte1 libkyotocabinet16v5 libllvm7 liblouis17 liblouisutdml8
  liblua5.3-0 liblwres161 libm17n-0 libmetrics-any-perl libmpdec2
  libmypaint-1.3-0 libmysofa0 libnet-dns-perl libnet-dns-sec-perl
  libnet-ip-perl libnfs12 libnftables0 libopenblas-base libopenexr23
  liborcus-0.14-0 libotf0 libpango-perl libparse-debianchangelog-perl
  libperl4-corelibs-perl libperl5.28 libpgm-5.2-0 libpoppler82 libprocps7
  libpython2-stdlib libpython2.7 libpython3.7 libpython3.7-minimal
  libpython3.7-stdlib libqhull7 libqpdf21 libqscintilla2-qt5-13
  libqt5concurrent5 libqt5opengl5 libraw19 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsdl1.2debian libsereal-perl
  libsisu-guice-java libsisu-ioc-java libsnmp30 libstruct-dumb-perl
  libtest-fatal-perl libtest-metrics-any-perl libtest-refcount-perl
  libtext-levenshtein-perl libu2f-udev libunique-1.0-0 libusbmuxd4 libvpx5
  libwnck-common libwnck22 libwxgtk3.0-0v5 libx264-155 libx265-165
  libxcb-util0 libxml-simple-perl linux-compiler-gcc-10-x86
  linux-headers-4.19.0-9-common linux-headers-5.10.0-9-common
  linux-kbuild-4.19 linux-kbuild-5.10 m17n-db perl-modules-5.28
  printer-driver-hpijs python-pkg-resources python2 python2-minimal
  python3-gst-1.0 python3.7-minimal xfce4-notes
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  linux-image-5.10.0-9-amd64*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 202884 files and directories currently installed.)
Purging configuration files for linux-image-5.10.0-9-amd64 (5.10.70-1) ...
root@htpc-devuan:/home/erdos# dpkg --configure -a
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin

Offline

#12 2021-10-16 16:18:24

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 117  
Website

Re: [SOLVED] Apt-get update error during Chimaera upgrade

erdos wrote:
Debuser2018 wrote:

Remove all the 5.x kernels and kernel headers and retry.
apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64

both
apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64
apt install -f

are success, but dpkg --configure -a still ends with error.

As you see dkms has compiled some modules in the library. Inspect & Remove these directories ('/usr/share/doc/lin
ux-headers-amd64,/lib/modules/5.10.0-9-amd64)  & retry.
rm /usr/share/doc/linux-headers-amd64 && rm /lib/modules/5.10.0-9-amd64
dpkg --configure -a && sync

As regarding the dpkg warnings about missing PATH variables, you may look into: https://unix.stackexchange.com/question … h-variable

Offline

#13 2021-10-16 16:26:29

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 117  
Website

Re: [SOLVED] Apt-get update error during Chimaera upgrade

erdos wrote:

hi, i'm trying to upgrade to Chimaera from beowulf and encountered the following during apt update:

root@htpc-devuan:/home/erdos/Downloads# apt-get update
Get:1 [url]http://dl.google.com/linux/earth/deb[/url] stable InRelease [1,807 B]
Get:2 [url]https://repo.skype.com/deb[/url] stable InRelease [4,502 B]         
Err:1 [url]http://dl.google.com/linux/earth/deb[/url] stable InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13
Get:3 [url]https://repo.skype.com/deb[/url] stable/main amd64 Packages [2,256 B]
Get:4 [url]http://deb.devuan.org/merged[/url] chimaera InRelease [33.8 kB]
Get:5 [url]http://deb.devuan.org/merged[/url] chimaera-updates InRelease [26.4 kB]
Get:6 [url]http://deb.devuan.org/merged[/url] chimaera-security InRelease [21.3 kB]
Get:7 [url]http://deb.devuan.org/merged[/url] chimaera/main i386 Packages [8,247 kB]
Get:8 [url]http://deb.devuan.org/merged[/url] chimaera/main amd64 Packages [8,309 kB]
Get:9 [url]http://deb.devuan.org/merged[/url] chimaera/main Translation-en [6,482 kB]     
Get:10 [url]http://deb.devuan.org/merged[/url] chimaera-updates/main Translation-en [2,108 B]
Get:11 [url]http://deb.devuan.org/merged[/url] chimaera-security/main i386 Packages [48.0 kB]
Get:12 [url]http://deb.devuan.org/merged[/url] chimaera-security/main amd64 Packages [48.0 kB]
Reading package lists... Done                                                  
W: GPG error: [url]http://dl.google.com/linux/earth/deb[/url] stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13
E: The repository 'http://dl.google.com/linux/earth/deb stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@htpc-devuan:/home/erdos/Downloads# 

i believe i installed zoom and google-earth through .deb package.  is this a concern for continuing upgrade to chimaera?

I assume you're using amd64 (64-bit intels or amd processor). Make sure Google repositories look like this in /etc/apt/sources.list or inside /etc/apt/sources.list.d/ :

deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Add missing GPG key as root:
sudo -i
Then,
wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | apt-key add -
apt update && apt upgrade

Offline

#14 2021-10-16 16:33:50

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 117  
Website

Re: [SOLVED] Apt-get update error during Chimaera upgrade

This is a sample Chimaera /etc/apt/sources.list:
# Devuan chimaera
deb http://deb.devuan.org/merged chimaera main contrib non-free
#deb-src http://deb.devuan.org/merged chimaera main contrib non-free
deb http://deb.devuan.org/merged chimaera-security main contrib non-free
# deb-src http://deb.devuan.org/merged chimaera-security main

# chimaera-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://deb.devuan.org/merged chimaera-updates main contrib non-free
# deb-src http://deb.devuan.org/merged chimaera-updates main

# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://deb.devuan.org/merged chimaera-backports main contrib non-free
# deb-src http://deb.devuan.org/merged chimaera-backports main

deb http://deb.devuan.org/devuan chimaera-proposed main contrib non-free

# Google Chrome & earth pro
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main
# Ubuntuzilla for Firefox browser
# deb http://downloads.sourceforge.net/projec … ozilla/apt all main
deb https://altushost-swe.dl.sourceforge.ne … ozilla/apt all main

Offline

#15 2021-10-17 02:54:10

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

Debuser2018 wrote:

As you see dkms has compiled some modules in the library. Inspect & Remove these directories ('/usr/share/doc/lin
ux-headers-amd64,/lib/modules/5.10.0-9-amd64)  & retry.
rm /usr/share/doc/linux-headers-amd64 && rm /lib/modules/5.10.0-9-amd64
dpkg --configure -a && sync

As regarding the dpkg warnings about missing PATH variables, you may look into: https://unix.stackexchange.com/question … h-variable

i was able to run above commands, removed /usr/share/doc/linux-headers-amd64,  /lib/modules/5.10.0-9-amd64 doesn't exist though.  'dpkg' runs ok too after modify path.

but trying to reinstall 5.10 kernel/headers still results the same error - complaining it couldn't find dkms.conf
apt install linux-headers-5.10.0-9-amd64 linux-headers-amd64

root@htpc-devuan:/home/erdos# export PATH="$PATH:/sbin"
root@htpc-devuan:/home/erdos# apt install linux-headers-5.10.0-9-amd64 linux-headers-amd64
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  glx-alternative-mesa libbsd0:i386 libmd0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386
  update-glx
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  linux-headers-5.10.0-9-amd64 linux-headers-amd64
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/902 kB of archives.
After this operation, 5,548 kB of additional disk space will be used.
Selecting previously unselected package linux-headers-5.10.0-9-amd64.
(Reading database ... 182681 files and directories currently installed.)
Preparing to unpack .../linux-headers-5.10.0-9-amd64_5.10.70-1_amd64.deb ...
Unpacking linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
Selecting previously unselected package linux-headers-amd64.
Preparing to unpack .../linux-headers-amd64_5.10.70-1_amd64.deb ...
Unpacking linux-headers-amd64 (5.10.70-1) ...
Setting up linux-headers-5.10.0-9-amd64 (5.10.70-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 5.10.0-9-amd64:Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/340.108/source/dkms.conf does not exist.
 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-5.10.0-9-amd64.postinst line 11.
dpkg: error processing package linux-headers-5.10.0-9-amd64 (--configure):
 installed linux-headers-5.10.0-9-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-headers-amd64:
 linux-headers-amd64 depends on linux-headers-5.10.0-9-amd64 (= 5.10.70-1); however:
  Package linux-headers-5.10.0-9-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-5.10.0-9-amd64
 linux-headers-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@htpc-devuan:/home/erdos#

i purged all 'nvidia' in the system, and tried again, still no success.
# apt-get  remove --purge '^nvidia-.*'
It seems that repository is messed up now, i couldn't find any 'nvidia' driver include 'nvidia-persistenced',  using synaptics display ed 'xserver-xorg-video-nvidia-legacy-340xx' but shows:
"
Package xserver-xorg-video-nvidia-legacy-340xx has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list"

Offline

#16 2021-10-17 05:16:39

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 117  
Website

Re: [SOLVED] Apt-get update error during Chimaera upgrade

A simple Google search gave this result:
https://askubuntu.com/questions/227258/ … -conf-file

I think there is no dependency hell, rather some missing or conflicting modules or conf files that needs to be sorted. It is achievable.

Offline

#17 2021-10-17 15:38:20

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

thanks!
erdos@htpc-devuan:~$ for i in /var/lib/dkms/*/[^k]*/source; do [ -e "$i" ] || echo "$i";done
/var/lib/dkms/*/[^k]*/source

removed 'nvidia' directory, and reinstalled header/kernel for 5.10, ok
rm -r /var/lib/dkms/nvidia
# export PATH="$PATH:/sbin"
dpkg --configure -a && sync
apt purge linux-headers-5.10.0-9-amd64 linux-headers-amd64
apt-get update && apt-get upgrade
apt-get autoremove --purge
apt-get dist-upgrade
apt install linux-headers-5.10.0-9-amd64 linux-headers-amd64
apt install linux-image-5.10.0-9-amd64

I updated /etc/apt/sources.list to include 'no-free' and update repository list:
however, it seems that i could no longer install nvidia driver for my graphics card (GeForce 9300 GE), i.e. nvidia-legacy-340xx-driver

erdos@htpc-devuan:~$ sudo apt-get install nvidia-legacy-340xx-driver
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package nvidia-legacy-340xx-driver is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nvidia-legacy-340xx-driver' has no installation candidate

this driver is no longer available in chimaera

https://pkginfo.devuan.org/cgi-bin/poli … r&x=submit

Last edited by erdos (2021-10-17 15:42:33)

Offline

#18 2021-10-18 02:51:56

erdos
Member
Registered: 2018-06-04
Posts: 66  

Re: [SOLVED] Apt-get update error during Chimaera upgrade

solution has been given here https://dev1galaxy.org/viewtopic.php?id=4585

Offline

Board footer