The officially official Devuan Forum!

You are not logged in.

#1 2021-06-27 14:43:42

Marjorie
Member
From: Teignmouth, UK
Registered: 2019-06-09
Posts: 109  

[SOLVED] Cinnamon timer no longer working for suspend/screensaving

I use Cinnamon (3.8.8) as my DE on Beowulf. I'm running a mains-powered desktop PC not a laptop with battery.

I've previously used my particular setup unchanged, apart from a few tweaks on both Mint (pre-systemd) and ASCII and for some time now Beowulf and it 'just worked'.

However I now find that the timer that automatically blanks the screen and then suspends my computer, and is controlled by the Power Management menu option (cinnamon-settings power) no longer works. Invoking suspend directly does work.

Cinnamon-screensaver also doesn't start automatically if you set a delay, though again it can be started directly.

Anyone with any suggestions as to what has broken previous behaviour? The only changes I've made in recent weeks are regular upgrades.

I note that cinnamon-settings-daemon 3.8.4.2 shows a dependency on libsystemd0 and I don't have libsystemd0 installed. However the Debian changelog shows the deb dates from 2018.

Offline

#2 2021-06-27 14:58:53

dice
Member
Registered: 2020-11-22
Posts: 559  
Website

Re: [SOLVED] Cinnamon timer no longer working for suspend/screensaving

Im not sure what controls screen blanking with cinnamon but im fairly certain you can use xset to fix it.

what does xset -q say in a terminal?

Offline

#3 2021-06-27 16:19:49

Marjorie
Member
From: Teignmouth, UK
Registered: 2019-06-09
Posts: 109  

Re: [SOLVED] Cinnamon timer no longer working for suspend/screensaving

dice wrote:

Im not sure what controls screen blanking with cinnamon but im fairly certain you can use xset to fix it.

what does xset -q say in a terminal?

marjorie@grendel:~$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

Offline

#4 2021-06-28 11:57:58

dice
Member
Registered: 2020-11-22
Posts: 559  
Website

Re: [SOLVED] Cinnamon timer no longer working for suspend/screensaving

depending on how you want blanking and suspend setup you can use xset commands to test if its working.

in your autostart file do something like this below and log out and log back in.

xset s 2 2

this will just test if blanking is working, the screen should blank after 2 minutes with no activity. You will need remove that autostart command and reboot to take it back to normal.

have a look at the archwiki for some settings that may suit you.

https://wiki.archlinux.org/title/Displa … _Signaling

Hopefully someone could help you with the cinnamon settings, maybe check if they have a forum or github you can ask.

Last edited by dice (2021-06-28 12:02:14)

Offline

#5 2021-08-07 11:07:41

Marjorie
Member
From: Teignmouth, UK
Registered: 2019-06-09
Posts: 109  

Re: [SOLVED] Cinnamon timer no longer working for suspend/screensaving

Just to report that my system has reverted to normal behaviour, with automatic screen blanking and then suspend after a pre-determined delay.

I've not done anything I'm aware of to achieve this, it has just happened. Not sure exactly when either as I normally invoke suspend manually.

I can't find any relevant reverted package updates.

My suspicion is that it may be have been triggered by minor kernel updates: I upgraded to 4.19.0.16 on 16 March and 4.19.0.17 on 18 July.

Offline

Board footer