The officially official Devuan Forum!

You are not logged in.

#1 2021-07-12 13:48:37

swarfendor437
Member
From: Somewhere off Atlantis
Registered: 2020-10-28
Posts: 69  

Dependency not available to install an application needed

Hi, I am trying to install the latest version of Bralleblaster stable. This now comes as a .deb package but when running gdebi it comes back with a dependency error. It needs

libgcc-s1

This is not in the repos and only available using Debian Sid repo - would I break my system if I added that repository?

Currently running Devuan 3.1.1
KDE Plasma: 5.14.5
KDE Frameworks: 5,54.0
Qt Version: 5.11.3
Kernel Version: 4.19.0-17-amd4

Thanks in advance!

Offline

#2 2021-07-12 16:15:56

Altoid
Member
Registered: 2017-05-07
Posts: 850  

Re: Dependency not available to install an application needed

Hello:

swarfendor437 wrote:

... trying to install the latest version of Bralleblaster stable.

Is this application in the stable Debian repository?
If it is, it should (unless for some reason blacklisted) also be in the stable Devuan repository.

But ...
Check this thread from 11/2017 at lists.debian.org:

https://lists.debian.org/debian-accessi … 00047.html

It is mid-2021 and I could not find it in the Debian package repository search:

https://packages.debian.org/search?keyw … ection=all

Have you asked the developers about the dependency and the reason it is not included in the package?

Edit:

Check this page: https://www.brailleblaster.org/docs/sys … ements.php

brailleblaster.org wrote:

BrailleBlaster System Requirements
Software Requirements

When using one of the BrailleBlaster installer packages you will need a computer running one of the below operating systems.

    Windows 10 or Newer
    Mac OS X or Newer
    Ubuntu Linux 20.04 or later   <-------------- Bear in mind that Ubuntu Linux Debian/Devuan Linux.
                                                                         ie: it does not mean that it will run on them and that there's probably
                                                                         a reason Ubuntu is mentioned but not Debian/Devuan.

Only if using the universal zip archive distribution of BrailleBlaster you will also need Java15 or higher installed on your computer.

Best,

A.

Last edited by Altoid (2021-07-12 19:15:33)

Offline

#3 2021-07-14 15:42:30

swarfendor437
Member
From: Somewhere off Atlantis
Registered: 2020-10-28
Posts: 69  

Re: Dependency not available to install an application needed

Hi Altoid,

I think because I was in a rush working from home I had not spotted that element on the site. Many thanks. On earlier iterations on a different OS before I moved to Devuan I had to splatter the desktop with all the gubbins, remove Java 11 and install Java 8. The fact they now have it properly packaged I was hoping it would have worked - hey ho, no matter. I retire at end of August so no sweat but much appreciated that you took all that trouble to attempt to resolve the issue.

Warm regards,
swarf'

Last edited by swarfendor437 (2021-07-14 15:42:52)

Offline

#4 2021-07-14 16:04:16

Altoid
Member
Registered: 2017-05-07
Posts: 850  

Re: Dependency not available to install an application needed

Hello:

swarfendor437 wrote:

... not spotted that element on the site.
Many thanks.

You're welcome.

swarfendor437 wrote:

... before I moved to Devuan I had to splatter the desktop ...
... remove Java 11 and install Java 8.

The type of thing that frequently happens with packages from outside the repositories.

swarfendor437 wrote:

... hoping it would have worked ...

You may want to consider sending them an email to let them know about your issue.
There's probably other users affected, some may run on Devuan.

swarfendor437 wrote:

... appreciated that you took all that trouble ...

No trouble at all.
That's how the Pay It Forward system works.

Others here at Dev1 have done the same for me many times, so I try to do it for someone if I have the chance.
Usually works => everyone wins.  8^)

Best,

A.

Last edited by Altoid (2021-07-15 15:15:51)

Offline

Board footer