The officially official Devuan Forum!

You are not logged in.

#1 2021-04-30 11:01:06

nick_stokie
Member
Registered: 2018-05-30
Posts: 12  

[SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

I've upgraded a laptop from Beowulf to Chimaera. On Beowulf the wifi connected automatically on startup/login. On Chimaera, it does not automatically connect. It's a Broadcom BCM4352 wifi.

My /etc/network/interfaces is:

auto lo
iface lo inet loopback

#allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
   wpa-ssid {my-ssid}
   wpa-psk {passphrase}

I've tried alternating 'allow-hotplug' and 'auto'. Neither triggers automatic connection, but both work when I manually force it using:

ip link set wlan0 up
service networking restart

How do I make the connection automatic and persistent at startup/logon, please?

Last edited by nick_stokie (2021-04-30 13:37:30)

Offline

#2 2021-04-30 11:14:26

dice
Member
Registered: 2020-11-22
Posts: 526  
Website

Re: [SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

First check rfkill ( tool for enabling and disabling wireless devices )

# apt install rfkill

then let us know the output of using sudo or root account

# rfkill list 

sorry i didnt read your post correctly.

You can manually connect using ifup wlan0 ?

so maybe reset the network interfaces file like so.

# wpa_passphrase ESSID WPAKEY > /etc/wpa_supplicant/wpa_supplicant.conf

then edit /etc/network/interfaces file to look like so.

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
         wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Last edited by dice (2021-04-30 11:28:00)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life
"everything is magnetized" - kmart employee
"you just opened pandora's shitbox ray" - jim lahey

Offline

#3 2021-04-30 11:51:52

nick_stokie
Member
Registered: 2018-05-30
Posts: 12  

Re: [SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

dice wrote:

You can manually connect using ifup wlan0 ?

Yes, manual connection is fine.

dice wrote:

so maybe reset the network interfaces file like so.

# wpa_passphrase ESSID WPAKEY > /etc/wpa_supplicant/wpa_supplicant.conf

then edit /etc/network/interfaces file to look like so.

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
         wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Unfortunately no difference. No automatic connection on startup but manual forcing works fine. Out of interest, does this change how it connects or is the 'wpa_supplicant' line a convenient shorthand for what I previously had in /etc/network/interfaces?

Offline

#4 2021-04-30 11:56:37

dice
Member
Registered: 2020-11-22
Posts: 526  
Website

Re: [SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

by startup do you mean a reboot of the machine?

Its just another way to connect wpa_supplicant using a conf file. Thought it might help.


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life
"everything is magnetized" - kmart employee
"you just opened pandora's shitbox ray" - jim lahey

Offline

#5 2021-04-30 12:14:50

nick_stokie
Member
Registered: 2018-05-30
Posts: 12  

Re: [SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

dice wrote:

by startup do you mean a reboot of the machine?

Yes, when I turn on or reboot the machine I don't get the automatic connection to the wireless network that I used to. (This is at home so there's a persistent wireless network waiting for it.)

dice wrote:

Its just another way to connect wpa_supplicant using a conf file. Thought it might help.

And thanks for suggesting. Always worth trying in case it made the difference.

Offline

#6 2021-04-30 12:15:04

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 564  

Re: [SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

@dice's advice is for registering the connection details for the particular ESSID and WPAKEY.

For a laptop, you might want a slightly more flexible configuration, and to use the wpa_gui to deal with new wireless access points.

First, enter the following at the top of /etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
p2p_disabled=1

Secondly, bring down wlan0 (ifdown wlan0) before changing /etc/network/interfaces to have the follwing variant declaration:

auto wlan0
iface wlan0 inet manual
         wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

You'll note the difference of having a manual stanza with wpa-roam rather than wpa-conf, and a seemingly extra stanza declaring use of a dhcp configuration for a virtual default interface. All that is in support of roaming with dhcp.

Next, install wpagui (that's the package name for the wpa_gui tool) as user management tool for connecting your wireless interface to available acccess point by choice. By virtue of the update_config=1 setting you may save accesspoint settings so wpa_supplicant can find them "automatically" later.

You might also need to re-login the user after ensuring the user is in the netdev group, as per that first configuration line which wpa_supplicant will use for its control sockets.

With that you should be all set. for completeness, the p2p_disabled=1 is needed in order to disable that function which otherwise causes wpa_supplicant to be confused.. I'm not sure about the details.

Online

#7 2021-04-30 13:36:18

nick_stokie
Member
Registered: 2018-05-30
Posts: 12  

Re: [SOLVED] WiFi doesn't autoconnect after Beowulf to Chimaera

Brilliant @ralph.ronnquist . That's fixed it. Thanks for the really clear instructions.

Of minor note, should others have a similar issue: it now takes a bit longer than before when logging in to connect to the network. I get a spinning cursor for about 15secs on logon (to xfce desktop) as it is detecting and connecting to the network. I'm sure that's longer than on Beowulf. So if I'm really speedy launching email / browser then it won't have acquired the connection. But I'm not complaining, just noting.

Thanks again, such a brilliant and helpful forum.

Offline

Board footer