The officially official Devuan Forum!

You are not logged in.

#1 2019-11-28 00:10:15

From: Fredericton, NB, Canada
Registered: 2019-11-27
Posts: 3  

pm-suspend becomes catatonic - screen blanks; system never halts

Hi Everyone,

I'm a recent convert to Devuan, after several years of otherwise happy times as an Ubuntu weenie. I thought I had a pretty good understanding of linux system management but this has been an education otherwise! Let me preface everything by saying I am otherwise extremely happy with Devuan - I'll even say there seem to be a few key improvements right out of the box!

The last hangup for me is that this system is a lenovo ideapad 310 - a laptop - and I can't for the life of me get it to suspend. The essential problem statement is this: On issuing pm-suspend or pm-hibernate via CLI, ACPI Hooks, or the mate power manager (at least, I think it's the Mate power Manager), I get a nice black screen and... nothing.

To give you a precise idea what I'm working with here...

patches@nostromo:~$ inxi -F
System:    Host: nostromo Kernel: 4.9.0-11-amd64 x86_64 (64 bit)
           Desktop: MATE 1.16.2  Distro: Devuan GNU/Linux ascii
Machine:   Device: laptop System: LENOVO product: 80ST v: Lenovo ideapad 310-15ABR
           Mobo: LENOVO model: Toronto 5B1 v: SDK0J40700WIN
           UEFI: LENOVO v: 1LCN32WW date: 09/05/2016
Battery    BAT0: charge: 20.3 Wh 98.0% condition: 20.7/28.5 Wh (73%)
CPU:       Quad core AMD A12-9700P RADEON R7 10 COMPUTE CORES 4C+6G (-MCP-) cache: 4096 KB 
           clock speeds: max: 2500 MHz 1: 1600 MHz 2: 2100 MHz 3: 1600 MHz
           4: 1300 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Carrizo
           Display Server: X.Org 1.19.2 drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Gallium 0.4 on AMD CARRIZO (DRM 3.8.0 / 4.9.0-11-amd64, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 13.0.6
Audio:     Card-1 Advanced Micro Devices [AMD] Device 157a
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-11-amd64
Network:   Card-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae
           IF: wlan0 state: up mac: 78:45:61:cb:84:c3
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: eth0 state: down mac: c8:5b:76:76:eb:be
Drives:    HDD Total Size: 1000.2GB (14.4% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 904G used: 124G (15%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 237M used: 66M (30%) fs: ext2 dev: /dev/sda2
           ID-3: swap-1 size: 12.23GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
Sensors:   System Temperatures: cpu: 0.0C mobo: N/A gpu: 0.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 222 Uptime: 21 min Memory: 1641.2/11403.5MB
           Client: Shell (bash) inxi: 2.3.5 

I've been on Devuan for about a month now, and trying to debug this suspend issue off and on throughout. I've tried a few things (made sure the right permissions were given to my user to actually trigger it, for a start - added "rtl8821ae and xhci_hd" to MODULES_SUSPEND, etc - but no love. pm-hibernate produces the same results, and I've noticed when working through the pm_tests progression that I tend to fail at the `devices` test - freeze works just fine. I suspect that fixing the problem with suspend will likely also allow proper hibernation.

I'm assuming there's a bad module somewhere but I'm at wits end trying to figure out which it is, so any pointers in that regard would be helpful.

I'm including the pm-suspend.log file from the most recent round of debugging attempts. There's one in there where PM_Debug was set to true, but I'm at a loss as to how to interpret it. It's long, so I threw it on pastebin.


Apologies if this is an often-asked question - I did my best to grep around the forum looking for similar instances but I haven't been able to find a solution. I like Devuan and I'll probably keep it for my fileserver, but without these power management features working it won't be practical for me as a daily driver.

Last edited by pAtchSavage87 (2019-11-28 03:11:58)

Perpetual motion autodidact; accidental sysadmin


#2 2019-11-29 14:53:27

From: Fredericton, NB, Canada
Registered: 2019-11-27
Posts: 3  

Re: pm-suspend becomes catatonic - screen blanks; system never halts

One thing I neglected to mention was this line of testing:

# echo devices > /sys/power/pm_test
# echo platform > /sys/power/disk
# echo disk > /sys/power/state

Produces the same result, while echo freezer > /sys/power/pm_test completes successfully.

Perpetual motion autodidact; accidental sysadmin


Board footer