The officially official Devuan Forum!

You are not logged in.

#1 2018-07-20 14:32:59

From: $HOME/♫♪
Registered: 2016-12-01
Posts: 230  

[SOLVED] (Devuan Jessie) libuuid-perl: no longer required

Hello! Today I found that during the update process libuuid-perl wants to be removed.

#! nili ~ $ update
Hit jessie InRelease
Hit jessie-updates InRelease
Hit jessie-security InRelease
Hit jessie-backports InRelease
Hit jessie/main i386 Packages
Hit jessie-updates/main i386 Packages
Hit jessie-security/main i386 Packages
Hit jessie-backports/main i386 Packages
Ign jessie/main Translation-en_US
Ign jessie/main Translation-en
Ign jessie-updates/main Translation-en_US
Ign jessie-updates/main Translation-en
Ign jessie-security/main Translation-en_US
Ign jessie-security/main Translation-en
Ign jessie-backports/main Translation-en_US
Ign jessie-backports/main Translation-en
Reading package lists... Done
#! nili ~ $ upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove it.
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 19.7 kB of archives.
After this operation, 46.1 kB disk space will be freed.
Do you want to continue? [Y/n] n

This is my sources list:

deb jessie main

deb jessie-updates main

deb jessie-security main

deb jessie-backports main

First time I see such a thing on the stable, A few ago when actively when i used testing, I faced very often similar situations that came out as temporary bug.

Is it a bug that I just have to wait? OR let it go libuuid-perl? To me it seems not look like a simple package that i should let out. From Debian DSA there is no news for this.

Do someone know anything about this case?
Thank you!

System runs...:

Devuan GNU/Linux 1 (jessie)
Linux coeurlinux 3.16.0-4-686-pae #1 SMP Debian 3.16.51-3 (2017-12-13) i686 GNU/Linux

P.S. update/upgrade command shortened it as alias on .bashrc.

alias update="sudo apt-get update"
alias upgrade="sudo apt-get upgrade"

Edit: Found this SECURITY THREAD about this case.
I gave the update linux-base, removed libuuid-perl and installed again. Currently it seems quiet, i'll look at it later.

This thread is solved! Thank you for the attention.


Last edited by Nili (2018-07-22 16:42:53)

openSUSE Tumbleweed KDE/Wayland

♫♪ Elisa playing...
Damascus Cocktail ♪ Black Reverie ♪ Dye the sky.


Board footer