The officially official Devuan Forum!

You are not logged in.

#1 2024-06-25 11:44:50

SysManOne
Member
From: LED
Registered: 2024-06-25
Posts: 1  

Chimaera - Audio and Video problem

Hello There!
I have a problem with using Audio and Video on Thinkpad notebook under Chimaera (under mint video and audio hw has been recognized and works fine) , some info wollows:

root@sysman-nb-udv:~# cat /proc/asound/cards
--- no soundcards ---

snd_hda_codec_hdmi     77824  0
snd_hda_codec_realtek   167936  0
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
snd_sof_intel_hda_common   102400  1 snd_sof_pci
snd_sof_xtensa_dsp     16384  2 snd_sof_intel_hda_common,snd_sof_intel_byt
snd_sof               139264  4 snd_sof_pci,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_soc_hdac_hda       24576  1 snd_sof_intel_hda_common
snd_hda_ext_core       36864  3 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
snd_soc_acpi_intel_match    45056  2 snd_sof_pci,snd_sof_intel_hda_common
snd_soc_acpi           16384  3 snd_soc_acpi_intel_match,snd_sof_intel_hda_common,snd_sof_intel_byt
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_sof
snd_hda_intel          57344  0
snd_intel_dspcfg       28672  3 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common
soundwire_intel        45056  2 snd_sof_intel_hda_common,snd_intel_dspcfg
snd_soc_core          319488  5 soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_dmic
snd_hda_codec         176128  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core          110592  9 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
snd_hwdep              20480  1 snd_hda_codec
snd_pcm               143360  9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_compress,snd_soc_core,snd_hda_core
snd                   110592  10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm

root@sysman-nb-udv:~# dmesg | grep hda
[    4.539057] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[    4.539074] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    5.982328] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[    5.982330] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
root@sysman-nb-udv:~# 

Is there what I'm need to check ?

Last edited by SysManOne (2024-06-25 11:52:22)


VAX/VMS biggot, plain C coder .

Offline

#2 2024-06-25 18:38:41

delgado
Member
Registered: 2022-07-14
Posts: 182  

Re: Chimaera - Audio and Video problem

Maybe missing firmware?

apt list --installed | grep firmware

firmware-intel-sound
firmware-realtek
firmware-linux 
firmware-linux-free 
firmware-linux-nonfree

Offline

Board footer