The officially official Devuan Forum!

You are not logged in.

#1 2024-05-30 17:16:06

devuan_dk_fan
Member
Registered: 2018-01-10
Posts: 95  

[SOLVED] Very strange audio problem after testing USB sound card.

I would like to install Devuan, but as I have been experiencing audio issues, I started by booting from the live desktop image and testing the hardware. I should preface this by writing that I have just picked up the computer today, from my local computer tech shop. I had taken the computer there because of the audio problems, and was told that there is nothing wrong with the hardware. Sooo... I brought the computer back home, only to find that only the hdmi sound (crappy speakers in a monitor) is working. the built-in sound card still doesn't work in Linux. Here is what the hardware look like, and I emphasize that it was working before I tested the sound card:

$ inxi -SMA
System:
  Host: devuan Kernel: 6.1.0-10-amd64 arch: x86_64 bits: 64 Desktop: Xfce
    v: 4.18.1 Distro: Devuan GNU/Linux 5 (daedalus)
Machine:
  Type: Desktop System: HUAWEI product: PUM-WDX9 v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: PUM-WDX9-PCB-B1 v: M1010 serial: <superuser required>
    UEFI: HUAWEI v: 1.28 date: 08/22/2022
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.1.0-10-amd64 status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
$ lsmod | grep snd
snd_hda_codec_realtek   172032  1
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     81920  1
snd_hda_intel          57344  3
snd_intel_dspcfg       36864  1 snd_hda_intel
snd_intel_sdw_acpi     20480  1 snd_intel_dspcfg
snd_hda_codec         184320  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          122880  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_pci_acp6x          20480  0
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               159744  5 snd_hda_codec_hdmi,snd_pci_acp6x,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              49152  1 snd_pcm
snd                   126976  14 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
soundcore              16384  1 snd
snd_pci_acp5x          20480  0
snd_rn_pci_acp3x       20480  0
ledtrig_audio          16384  2 snd_hda_codec_generic,huawei_wmi
snd_acp_config         16384  1 snd_rn_pci_acp3x
snd_soc_acpi           16384  1 snd_acp_config
snd_pci_acp3x          20480  0

The USB sound card that I was testing is an AudioQuest DragonFly Black v1.5.

Any ideas about how I can get the hardware working?

Last edited by devuan_dk_fan (2024-05-30 17:16:59)


Military justice is to justice what military music is to music. - Groucho Marx
I’ve had a perfectly wonderful evening, but this wasn’t it. - Groucho Marx

Offline

#2 2024-05-30 21:19:18

devuan_dk_fan
Member
Registered: 2018-01-10
Posts: 95  

Re: [SOLVED] Very strange audio problem after testing USB sound card.

I think that I may have gotten this the wrong way round. From what I can see online, there never has been support for the sound card. I just always used it with a Behringer U-Phoria UMC202HD USB sound card, and never tried the built-in sound card until after I tried the AudioQuest sound card, making me think something happened due to that card… Unless someone has some ideas about a driver for the built-in sound card, I guess that this topic could be marked “solved”…


Military justice is to justice what military music is to music. - Groucho Marx
I’ve had a perfectly wonderful evening, but this wasn’t it. - Groucho Marx

Offline

#3 2024-05-30 22:34:53

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,190  

Re: [SOLVED] Very strange audio problem after testing USB sound card.

You should then click "Mark SOLVED" to let the forum s/w automagically edit the initial title... or edit it by hand if you prefer.

Offline

Board footer