The officially official Devuan Forum!

You are not logged in.

#1 2024-01-23 12:49:02

Registered: 2024-01-23
Posts: 3  

neomutt: smtp_authenticators: gssapi is not a valid authenticator


I try to configure my mail with mutt-wizard package on Devuan GNU/Linux 5 (daedalus)

Commandline: apt install mutt-wizard --install-recommends
Install: libxapian30:amd64 (1.4.22-1, automatic), neomutt:amd64 (20220429+dfsg1-4.1, automatic), libtokyocabinet9:amd64 (1.4.48-15, automatic), libgmime-3.0-0:amd64 (3.2.13+dfsg-2, automatic), elpa-notmuch:amd64 (0.37-1, automatic), liblua5.4-0:amd64 (5.4.4-3, automatic), isync:amd64 (1.4.4-5, automatic), mutt-wizard:amd64 (3.3.1-2), mailcap:amd64 (3.70+nmu1, automatic), urlview:amd64 (0.9-23.1, automatic), libsexp1:amd64 (1.3.1+18~git20210718-1+b2, automatic), notmuch:amd64 (0.37-1+b1, automatic), dh-elpa-helper:amd64 (2.0.16, automatic), abook:amd64 (0.6.1-2+b1, automatic), libnotmuch5:amd64 (0.37-1+b1, automatic)

i configure my mail with mw -a

but when i execute neomutt i recive this message:

Error in /usr/share/mutt-wizard/mutt-wizard.muttrc, line 11: Option smtp_authenticators: gssapi is not a valid authenticator
Error in /home/mt/.config/mutt/muttrc, line 2: source: file /usr/share/mutt-wizard/mutt-wizard.muttrc could not be sourced
Error in /home/mt/.config/mutt/accounts/, line 12: .: unknown command
Error in /home/mt/.config/mutt/muttrc, line 3: source: file /home/mt/.config/mutt/accounts/ could not be sourced
source: errors in /home/mt/.config/mutt/muttrc

when i grep the .muttrc 'grep smtp_authenticators /usr/share/mutt-wizard/mutt-wizard.muttrc'

set smtp_authenticators = 'gssapi:login'

mw-mailsync work fine and sync all my mail
and when i launch neomutt and use him all seems work fine but the error message never goes away, any suggestion ?

Last edited by FOSSenjoyer (2024-01-23 18:32:58)


#2 2024-01-24 21:45:03

Registered: 2024-01-23
Posts: 3  

Re: neomutt: smtp_authenticators: gssapi is not a valid authenticator

i found the problem; the flag sasl should be compile but maybe there is a reason for why devuan ship neomutt and mutt-wizard in this way
i wonder how should fix the problem, mutt-wizard changes or re-compile neomutt ?

neomutt -v
NeoMutt 20220429
Copyright (C) 1996-2022 Michael R. Elkins and others.
NeoMutt comes with ABSOLUTELY NO WARRANTY; for details type 'neomutt -vv'.
NeoMutt is free software, and you are welcome to redistribute it
under certain conditions; type 'neomutt -vv' for details.

System: Linux 6.1.0-17-amd64 (x86_64)
ncurses: ncurses 6.4.20221231 (compiled with 6.3.20220423)
libidn: 1.41 (compiled with 1.41)
GPGME: 1.18.0
GnuTLS: 3.7.8
libnotmuch: 5.6.0
storage: tokyocabinet

Configure options: --build=x86_64-linux-gnu --prefix=/usr {--includedir=${prefix}/include} {--mandir=${prefix}/share/man} {--infodir=${prefix}/share/info} --sysconfdir=/etc --localstatedir=/var --disable-option-checking --disable-silent-rules {--libdir=${prefix}/lib/x86_64-linux-gnu} --runstatedir=/run --disable-maintainer-mode --disable-dependency-tracking --mandir=/usr/share/man --libexecdir=/usr/libexec --with-mailpath=/var/mail --gpgme --lua --notmuch --with-ui --gsasl --gnutls --gss --idn --mixmaster --tokyocabinet --sqlite --autocrypt --pkgconf

Compilation CFLAGS: -g -O2 -ffile-prefix-map=/build/neomutt-n0Dmud/neomutt-20220429+dfsg1=. -fstack-protector-strong -Wformat -Werror=format-security -std=c99 -D_ALL_SOURCE=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__ -I/usr/include/lua5.4 -I/usr/include -DNCURSES_WIDECHAR -I/usr/include/p11-kit-1 -isystem /usr/include/mit-krb5

Default options:
  +attach_headers_color +compose_to_sender +compress +cond_date +debug 
  +encrypt_to_self +forgotten_attachments +forwref +ifdef +imap +index_color 
  +initials +limit_current_thread +multiple_fcc +nested_if +new_mail +nntp +pop 
  +progress +quasi_delete +regcomp +reply_with_xorig +sensible_browser +sidebar 
  +skip_quoted +smtp +status_color +timeout +tls_sni +trash 

Compile options:
  +autocrypt +fcntl -flock -fmemopen +futimens +getaddrinfo +gnutls +gpgme 
  +gsasl +gss +hcache -homespool +idn +inotify -locales_hack +lua +mixmaster 
  +nls +notmuch -openssl +pgp +regex -sasl +smime +sqlite +sun_attachment 


To learn more about NeoMutt, visit:
If you find a bug in NeoMutt, please raise an issue at:
or send an email to: <>

now i fix making this 2 changes

sed -i -e  '/^set smtp_authenticators/ s/^set/\#set/'  /usr/share/mutt-wizard/mutt-wizard.muttrc
sed -i -e  '/switch\.muttrc/ s/^\\\./source/g' /home/mt/.config/mutt/accounts/

the frist one solve the gssapi error commenting the line that set gssapi
the second change the syntax of source from \. to source

and now i dont have any error but i dont know if this is the ideal solution to the problem
i make some test and all seems work fine.


Board footer