The officially official Devuan Forum!

You are not logged in.

#1 2023-11-02 00:59:19

Registered: 2023-11-02
Posts: 1  

[SOLVED] Dell Latitude 7520 -- eventual success

Situation:  Dell Latitude 7520. BIOS version 1.24.1.  i7-1185G7/4.8GHz.  Came installed with Windows.  Tried to go multiboot w/out reading instructions.  Blew away EFI partition.  Tried to build new partition table, misread things, used 1M EFI partition.  Yeah, this is a candidate for liveboot-only. big_smile

What I found:

1) BIG SECRET:  EFI data gets saved to NVRAM, and mount reads from the NVRAM.  fdisk, cfdisk, gdisk, and gparted DO NOT WRITE TO THIS NVRAM.  So, when I tried up the EFI partition size, mount still loaded a 1M partition--even after reboots.  How DOES it get written?  Clearly something in the EFI subsystem. 

Which leads to:
2) MAJOR NON-OBVIOUS FACT:  When you use fdisk, and you create an EFI partition, and it warns you about a flag, DO NOT CLEAR IT.  Especially if you end up using gparted to set the partition type to VFAT32.

Which gets us to
3) SECRET: If you use gparted to set the partition type, refracta will think that the drive is formatted.  Grub-install will then fail with "Unknown Partition Type" which is really confusing, because gparted will look exactly like the pictures say.  Sure, there are warnings "do not format an existing efi partition", but what exactly does that mean when you yourself just created the partition?

4) Of course, the "basics" are necessary--turn off "secure" boot, and copy files over to the multi-media install path.

And finally:
5) The dpackage config thingy to set the installation in the multi-media path fails on live boot with a missing overlay.  Copy the files over by hand, then run the config to make things better.

So in the end, after disabling secure boot, I used FDISK to create a 550M partition, changed its type to 1, ignored the warning about the EFI flag, created a second partition for the rest of the drive, and ran refracta.  The EFI install "just worked"--so long as I didn't drop into the chroot & cause that part of the process to be skipped.  And by "just worked", I don't mean that I could actually boot yet--I had to copy over the file into the multimedia path.  I ran dpackage config to try to clean up a bit afterwards.


Board footer