The officially official Devuan Forum!

You are not logged in.

#1 2023-09-07 20:45:52

rolfie
Member
Registered: 2017-11-25
Posts: 1,114  

[SOLVED] Connection to localhost:631

I am running Daedalus with Cinnamon and Firefox ESR since about 10 months on my workstation. I did set up my Kyocera P6230 when configuring the system during this time, and I did use https://localhost:631 in FF to configure my printer. Now I tried again to see if I could find some settings again, and my up to date FF-ESR tells me no connection to https://localhost:631.

I have checked hosts, network settings and anything I could think about. Could find nothing wrong. No more connection to localhost re. setting up cups. Can't tell when I last used it.

What may have changed meanwhile?

Last edited by rolfie (2023-09-08 15:50:10)

Offline

#2 2023-09-07 20:50:51

Dutch_Master
Member
Registered: 2018-05-31
Posts: 281  

Re: [SOLVED] Connection to localhost:631

Is CUPS actually running?

As root, do:

sh /etc/init.d/cups start

Then try connecting to localhost:631 again.

Offline

#3 2023-09-07 21:19:41

rolfie
Member
Registered: 2017-11-25
Posts: 1,114  

Re: [SOLVED] Connection to localhost:631

Tried that, no effect. Printing works.

Offline

#4 2023-09-07 21:32:18

Dutch_Master
Member
Registered: 2018-05-31
Posts: 281  

Re: [SOLVED] Connection to localhost:631

I'm on FF102.10.0esr (64-bit) and it works for me.

Offline

#5 2023-09-08 00:19:35

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,193  

Re: [SOLVED] Connection to localhost:631

@rolfie, use http without the s

Offline

#6 2023-09-08 11:38:40

rolfie
Member
Registered: 2017-11-25
Posts: 1,114  

Re: [SOLVED] Connection to localhost:631

Using http or https makes no difference. Emptied the cache, cookies, still doesn't work. A ping to 127.0.0.1 or localhost is working.

Crosschecked against my laptop: same FF-ESR version on board, connection to localhost:631 is possible, I get the cups menu.

Compared hosts and interfaces contents, the same for localhost. Difference between the two systems is that I let the network-manager handle all connections on the laptop while I use fixed IPs on my workstation.

Is it possible that I get interference from there? Tried to remove the network-manager on my workstation, but that also wants to remove Cinnamon.

Offline

#7 2023-09-08 14:15:26

boughtonp
Member
From: UK
Registered: 2023-01-19
Posts: 212  
Website

Re: [SOLVED] Connection to localhost:631

rolfie wrote:

my up to date FF-ESR tells me no connection to https://localhost:631.

Browsers frequently hide real errors, and complicate things with caches and cookies; usually better to diagnose things directly.

What does curl -Iv localhost:631 say?

Check with ss -ltnp sport 631 (as sudo/root) whether the server is running?

Anything relevant in the logs - i.e: tail /var/log/cups/*_log ?


3.1415P265E589T932E846R64338

Offline

#8 2023-09-08 16:04:40

rolfie
Member
Registered: 2017-11-25
Posts: 1,114  

Re: [SOLVED] Connection to localhost:631

Ping to localhost works as well as printing.

$ ping -c 5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.014 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.037 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.030 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.037 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.030 ms

--- localhost ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4088ms
rtt min/avg/max/mdev = 0.014/0.029/0.037/0.008 ms

curl does not work either

$ curl -Iv localhost:631
*   Trying 127.0.0.1:631...
* connect to 127.0.0.1 port 631 failed: Verbindungsaufbau abgelehnt
*   Trying [::1]:631...
* connect to ::1 port 631 failed: Verbindungsaufbau abgelehnt
* Failed to connect to localhost port 631 after 0 ms: Couldn't connect to server
* Closing connection 0
curl: (7) Failed to connect to localhost port 631 after 0 ms: Couldn't connect to server

No output on

# ss -ltnp sport 631
State         Recv-Q         Send-Q                  Local Address:Port                   Peer Address:Port         Process

Log entries

# tail /var/log/cups/*_log
==> /var/log/cups/access_log <==
localhost - - [08/Sep/2023:14:10:30 +0200] "POST / HTTP/1.1" 200 152 Cancel-Subscription successful-ok
localhost - - [08/Sep/2023:17:33:48 +0200] "POST / HTTP/1.1" 200 349 Create-Printer-Subscriptions successful-ok
localhost - - [08/Sep/2023:17:33:48 +0200] "POST / HTTP/1.1" 200 176 Create-Printer-Subscriptions successful-ok
localhost - - [08/Sep/2023:17:36:11 +0200] "POST / HTTP/1.1" 200 360 Create-Printer-Subscriptions successful-ok
localhost - - [08/Sep/2023:17:37:20 +0200] "POST / HTTP/1.1" 401 123 Cancel-Subscription successful-ok
localhost - root [08/Sep/2023:17:37:20 +0200] "POST / HTTP/1.1" 200 123 Cancel-Subscription successful-ok
localhost - - [08/Sep/2023:17:37:20 +0200] "POST / HTTP/1.1" 200 152 Cancel-Subscription successful-ok
localhost - - [08/Sep/2023:17:38:23 +0200] "POST / HTTP/1.1" 200 349 Create-Printer-Subscriptions successful-ok
localhost - - [08/Sep/2023:17:38:23 +0200] "POST / HTTP/1.1" 200 176 Create-Printer-Subscriptions successful-ok
localhost - - [08/Sep/2023:17:38:32 +0200] "POST / HTTP/1.1" 200 360 Create-Printer-Subscriptions successful-ok

==> /var/log/cups/error_log <==
E [08/Sep/2023:17:33:48 +0200] Unknown directive SubscriptionPrivateValues on line 128 of /etc/cups/cupsd.conf.
W [08/Sep/2023:17:33:48 +0200] Printer drivers are deprecated and will stop working in a future version of CUPS. See https://github.com/OpenPrinting/cups/issues/103
E [08/Sep/2023:17:33:48 +0200] Missing value on line 2039 of /var/cache/cups/job.cache.
W [08/Sep/2023:17:38:23 +0200] Duplicate listen address "/run/cups/cups.sock" ignored.
E [08/Sep/2023:17:38:23 +0200] Unknown directive JobPrivateAccess on line 125 of /etc/cups/cupsd.conf.
E [08/Sep/2023:17:38:23 +0200] Unknown directive JobPrivateValues on line 126 of /etc/cups/cupsd.conf.
E [08/Sep/2023:17:38:23 +0200] Unknown directive SubscriptionPrivateAccess on line 127 of /etc/cups/cupsd.conf.
E [08/Sep/2023:17:38:23 +0200] Unknown directive SubscriptionPrivateValues on line 128 of /etc/cups/cupsd.conf.
W [08/Sep/2023:17:38:23 +0200] Printer drivers are deprecated and will stop working in a future version of CUPS. See https://github.com/OpenPrinting/cups/issues/103

Can't read cupsd.conf, is a binary file.

Looks like no cups service is running, but why? Restarting the service has no effect on the problem.

# sh /etc/init.d/cups start
Starting Common Unix Printing System: cupsd.
# ss -ltnp sport 631
State                    Recv-Q                    Send-Q                                       Local Address:Port                                        Peer Address:Port                    Process

Offline

#9 2023-09-08 16:25:50

boughtonp
Member
From: UK
Registered: 2023-01-19
Posts: 212  
Website

Re: [SOLVED] Connection to localhost:631

So you have a bad config file, which is likely why the service fails to start.

cupsd.conf should not be a binary file - what is telling you that it is? (The error log say there are unknown directives, which suggest it is not binary, but maybe for a different version.)

Try checking file /etc/cups/*cupsd* to see if you have a backup that reports as "ASCII text" - if so, you could try diff to see if it can identify a problem, and/or rename the current bad file and copy the backup file into its place.


3.1415P265E589T932E846R64338

Offline

#10 2023-09-08 16:47:33

Andre4freedom
Member
Registered: 2017-11-15
Posts: 155  

Re: [SOLVED] Connection to localhost:631

Only my 2 pennies to it:
now I usually install Devuan (Daedalus) plain standard, Cinnamon DE, Console Productivity, SSH Server and Standard System Utilities, choosing OpenRC etc.
I don't even bother to check or configure any printer.
The CUPS-Browsed or Bonjour protocols seem to do all work.
When i check in Menu - Administration - Print Settings, my printer is already there. The same holds true for the scanner (MFP Printers).
This automatic setup seems to work with several modern printer brands. I can confirm this for Brother, HP and Canon.
I wonder if your Kyocera is an older model or configured differently.
My printer was set up just by connecting it to power and the internal network (I gave it a fixed IP address in the same subnet as the workstations)
So, maybe, this could work for modern Kyocera printers as well???

Offline

#11 2023-09-08 17:51:53

rolfie
Member
Registered: 2017-11-25
Posts: 1,114  

Re: [SOLVED] Connection to localhost:631

Well, problem solved.

Nemo claimed that cupsd.conf is a binary file, so initially I didn't bother to look at it. Got a hint from the German Debian forum to look at the "Listen" entries in the cupsd.conf. Tried to open it with geany in a root terminal, and found that the contents was plain text. Well, the "Listen" entries on my workstation were both identical pointing at /run/cups/cups.sock. Changed the first one to localhost:631, restarted the cups service, and voila, the problem is gone. Somehow the file was modified some time in Feb this year. There is a backup with the same timestamp which is one line longer due to a comment in line 1, the listen entries are also bad. Now I get:

# ss -ltnp sport 631
State                  Recv-Q                 Send-Q                                 Local Address:Port                                 Peer Address:Port                Process                                          
LISTEN                 0                      128                                        127.0.0.1:631                                       0.0.0.0:*                    users:(("cupsd",pid=18184,fd=7))                
LISTEN                 0                      128                                            [::1]:631                                          [::]:*

Crosschecked with my laptop which is working: the cupsd.conf looks different and is significantly bigger. There are lots of comments in the file, not only directives for cups like on my workstation.

Interesting troubeshooting ...

Last edited by rolfie (2023-09-08 18:01:07)

Offline

#12 2023-09-08 17:58:32

rolfie
Member
Registered: 2017-11-25
Posts: 1,114  

Re: [SOLVED] Connection to localhost:631

@Andre4freedom: The automatic setup is called IPP. When I bought the printer and installed it, can't remember if it was under Beowulf or Chimaera, I got a bunch of entries in the cups administration, and none really worked. I was totally confused getting in contact to something I never saw before. So I switched off this IPP feature in the printer, deleted all the not working printers, and configured it the traditional way with a PPD file and an individual entry in cups. Kept this for Daedalus ...

Offline

Board footer