The officially official Devuan Forum!

You are not logged in.

#1 2023-07-16 22:37:25

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 202  

xorg bug with daedalus rc5 ?

I may have run across a slight bug while installing the daedalus rc5 release iso. 

TL/DR -
I tried to install xorg and ran across this error:

root@localhost:/etc/apt# apt install xorg
...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 luit : Breaks: x11-utils (< 7.7+6) but 7.7+5 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I installed the rc5-netinstall iso file and initially only installed the system utilities and console productivity parts. Afterwards, I then tried to install xfce, lightdm, xorg, and a few other desktop programs.
It was the xorg package that gave me the problem.

This was the situation after the initial netinstall:

root@localhost:/etc/apt# apt policy xorg
xorg:
  Installed: (none)
  Candidate: 1:7.7+23
  Version table:
     1:7.7+23 500
        500 [url]http://deb.devuan.org/merged[/url] daedalus/main amd64 Packages

Once I ran the below to manually install x11-utils, xorg installed as expected.

root@localhost:/etc/apt# apt install x11-utils
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libxcb-shape0 libxv1 libxxf86dga1
Suggested packages:
  mesa-utils
The following packages will be REMOVED:
  luit
The following NEW packages will be installed:
  libxcb-shape0 libxv1 libxxf86dga1 x11-utils
0 upgraded, 4 newly installed, 1 to remove and 0 not upgraded.
Need to get 355 kB of archives.
After this operation, 831 kB of additional disk space will be used.
Do you want to continue? [Y/n] 

A subsequent reboot and the lightdm login worked fine.

It looks like it initially is trying to install an older version of the "x11-utils" package.  I hope that package "luit" was not important.  My sources.list file is the default, but I added the "non-free" and "contrib" sections to the repo lines.

Last edited by nixer (2023-07-16 22:47:29)

Offline

Board footer