The officially official Devuan Forum!

You are not logged in.

#1 2023-03-07 20:41:41

Registered: 2023-03-07
Posts: 5  

Devuan 4 + ReaR (Relax-and-Recover) Issue

Hi all. I am here to seek a bit of help.
I have been using Devuan for years and this seem to be the first time, for me at least that I came across an application that is available through apt-get that seems to be broken.
So after being fully updated to date, I ran apt-get install rear - which installed without any hesitation.

I am able to use rear to create backups in ISO format, but cannot restore as when it runs it wants to run systemd-udevd which doesnt exist.
I think that is the issue here.
So then it errors out like so: "ERROR: Cannot mount ISO because there is no/dev/disk/by-label/RELAXRECOVER".

I even went ahead and side loaded rear-2.7 and that blows up just as bad.

So, is it possible that this application just can't work with Devuan due to the systemd not being available or is there something else going on that I can't wrap my head around at this time?

Has anyone out there gotten ReaR to work on Devuan, and if so would you mind sharing your experience?

I have tried it on multiple physical and VM environments, and it always fails in the same way.
I then loaded Debian 10 and 11. ReaR works flawlessly on both of those with the same config that fails on Devuan 4.

I've also opened a ticket with ReaR on github, so if anything this is the link to it:

Any help would be greatly appreciated!



Board footer