The officially official Devuan Forum!

You are not logged in.

#1 2022-09-07 23:54:51

deepforest
Member
Registered: 2020-03-24
Posts: 93  

[SOLVED] Why i can't upgrade ceres?

https://pastebin.com/raw/QVbyX9gG

root@devuan:/etc/apt# apt update
Ign:1 http://deb.devuan.org/merged ceres-updates InRelease
Hit:2 https://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                         
Get:3 http://download.opensuse.org/repositories/home:/Alexx2000:/doublecmd-svn/Debian_11  InRelease [1,560 B]                                                                         
Get:4 http://deb.devuan.org/merged ceres InRelease [33.9 kB]                                                                                                                          
Hit:5 https://brave-browser-apt-release.s3.brave.com stable InRelease                                                       
Err:6 http://deb.devuan.org/merged ceres-updates Release                                                                    
  404  Not Found [IP: 46.4.50.2 80]
Hit:7 http://debian.drdteam.org stable InRelease                    
Ign:8 https://repo.hotspotshield.com/deb/rel/all release InRelease  
Err:4 http://deb.devuan.org/merged ceres InRelease
  The following signatures were invalid: EXPKEYSIG BB23C00C61FC752C Devuan Repository (Amprolla3 on Nemesis) <repository@devuan.org>
Hit:10 https://repo.hotspotshield.com/deb/rel/all release Release                
Hit:9 http://tde-mirror.yosemite.net/trinity/deb/trinity-sb ceres InRelease      
Ign:11 https://repo.hotspotshield.com/deb/rel/all release Release.gpg
Reading package lists... Done
E: The repository 'http://deb.devuan.org/merged ceres-updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://deb.devuan.org/merged ceres InRelease: The following signatures were invalid: EXPKEYSIG BB23C00C61FC752C Devuan Repository (Amprolla3 on Nemesis) <repository@devuan.org>
W: http://debian.drdteam.org/dists/stable/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
root@devuan:/etc/apt# 

Last edited by deepforest (2022-09-08 00:05:42)

Offline

#2 2022-09-08 00:29:59

deepforest
Member
Registered: 2020-03-24
Posts: 93  

Re: [SOLVED] Why i can't upgrade ceres?

https://wiki.trinitydesktop.org/Prelimi … lds#Devuan

root@devuan:/etc/apt# sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  akregator-trinity amor-trinity ark-trinity artsbuilder-trinity atlantik-trinity dcoprss-trinity eyesapplet-trinity fifteenapplet-trinity juk-trinity kaboodle-trinity kaddressbook-trinity
  kalarm-trinity kamera-trinity kandy-trinity kappfinder-trinity karm-trinity kasteroids-trinity kate-trinity katomic-trinity kaudiocreator-trinity kbackgammon-trinity kbattleship-trinity
  kblackbox-trinity kbounce-trinity kcalc-trinity kcharselect-trinity kcoloredit-trinity kcontrol-trinity kdesktop-trinity kdf-trinity kdict-trinity kdvi-trinity kedit-trinity
  kenolaba-trinity kfax-trinity kfaxview-trinity kfind-trinity kfloppy-trinity kfouleggs-trinity kgamma-trinity kget-trinity kghostview-trinity kgoldrunner-trinity kgpg-trinity
  khelpcenter-trinity khexedit-trinity kicker-trinity kimagemapeditor-trinity kitchensync-trinity kjots-trinity kjumpingcube-trinity klaptopdaemon-trinity kleopatra-trinity
  klickety-trinity klines-trinity klinkstatus-trinity klipper-trinity kmahjongg-trinity kmail-trinity kmailcvt-trinity kmenuedit-trinity kmilo-trinity kmines-trinity kmix-trinity
  kmoon-trinity kmrml-trinity knetwalk-trinity knewsticker-trinity knode-trinity knotes-trinity kodo-trinity kolf-trinity kolourpaint-trinity kommander-trinity konqueror-nsplugins-trinity
  konqueror-trinity konquest-trinity konsole-trinity konsolekalendar-trinity kontact-trinity kooka-trinity kopete-trinity korganizer-trinity korn-trinity kpager-trinity kpat-trinity
  kpdf-trinity kpersonalizer-trinity kpf-trinity kpoker-trinity kpovmodeler-trinity kppp-trinity krdc-trinity krec-trinity kregexpeditor-trinity kreversi-trinity krfb-trinity
  kruler-trinity ksame-trinity kscd-trinity kshisen-trinity ksim-trinity ksirc-trinity ksirtet-trinity ksmiletris-trinity ksmserver-trinity ksnake-trinity ksnapshot-trinity
  ksokoban-trinity kspaceduel-trinity ksplash-trinity ksvg-trinity ksysguard-trinity ksysguardd-trinity ktalkd-trinity kteatime-trinity ktimer-trinity ktip-trinity ktnef-trinity
  ktron-trinity ktuberling-trinity ktux-trinity kview-trinity kviewshell-trinity kweather-trinity kwifimanager-trinity kworldclock-trinity kxsldbg-trinity libarts1-xine-trinity
  libkcddb1-trinity libkgantt0-trinity libkleopatra1-trinity libkmime2-trinity libkonq4-trinity libkpimexchange1-trinity libkpimidentities1-trinity libkscan1-trinity libksieve0-trinity
  libktnef1-trinity libpoppler-tqt libr0 librss1-trinity libtdegames1-trinity libtdepim1a-trinity libtqt3-integration-trinity lisa-trinity lskat-trinity noatun-trinity quanta-trinity
  superkaramba-trinity tdeartwork-style-trinity tdeartwork-theme-window-trinity tdeartwork-trinity tdebase-tdeio-plugins-trinity tdebase-tdeio-smb-trinity tdebase-trinity
  tdebase-trinity-bin tdednssd-trinity tdefifteen-trinity tdefilereplace-trinity tdegames-trinity tdegraphics-tdefile-plugins-trinity tdegraphics-trinity tdeiconedit-trinity
  tdelibs-trinity tdelibs14-trinity tdelirc-trinity tdemid-trinity tdemultimedia-tdefile-plugins-trinity tdemultimedia-tdeio-plugins-trinity tdemultimedia-trinity
  tdenetwork-filesharing-trinity tdenetwork-tdefile-plugins-trinity tdenetwork-trinity tdepasswd-trinity tdepim-tdefile-plugins-trinity tdepim-tdeio-plugins-trinity
  tdepim-tderesources-trinity tdepim-trinity tdepim-wizards-trinity tdepowersave-trinity tdeprint-trinity tdescreensaver-trinity tdescreensaver-xsavers-trinity tdessh-trinity
  tdetoys-trinity tdeutils-trinity tdewalletmanager-trinity tdewebdev-trinity tdm-trinity twin-trinity twin4-trinity
0 upgraded, 0 newly installed, 0 to remove and 192 not upgraded.
root@devuan:/etc/apt# apt install akregator-trinity amor-trinity ark-trinity artsbuilder-trinity atlantik-trinity dcoprss-trinity eyesapplet-trinity fifteenapplet-trinity juk-trinity kaboodle-trinity kaddressbook-trinity kalarm-trinity kamera-trinity kandy-trinity kappfinder-trinity karm-trinity kasteroids-trinity kate-trinity katomic-trinity kaudiocreator-trinity kbackgammon-trinity kbattleship-trinity
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ark-trinity : Depends: libc6 (>= 2.34) but 2.33-7 is to be installed
               Recommends: zoo but it is not installable
 dcoprss-trinity : Depends: libc6 (>= 2.34) but 2.33-7 is to be installed
 kappfinder-trinity : Depends: libc6 (>= 2.34) but 2.33-7 is to be installed
 kate-trinity : Depends: libc6 (>= 2.34) but 2.33-7 is to be installed
 tdelibs14-trinity : Depends: libc6 (>= 2.34) but 2.33-7 is to be installed
                     Depends: libimath-3-1-29 (>= 3.1.5) but it is not installable
                     Depends: libopenexr-3-1-30 (>= 3.1.5) but it is not installable
E: Unable to correct problems, you have held broken packages.
root@devuan:/etc/apt# 

Last edited by deepforest (2022-09-08 00:31:14)

Offline

#3 2022-09-08 05:04:15

steve_v
Member
Registered: 2018-01-11
Posts: 137  

Re: [SOLVED] Why i can't upgrade ceres?

Because deb.devuan.org failed to update due to an expired GPG key.
See this topic regarding expired keys, or the 50 bazillion general search hits regarding this kind of error on any number of Debian-based distros. This is why we read the "new and announcements" section, no?
You're running unstable with a bunch of third-party repos enabled, so surely you can read those errors and warings from apt just as well as I can too...

You also appear to have a number of duplicates and errors in your sources in general, but that's another matter.

Last edited by steve_v (2022-09-08 05:23:57)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#4 2022-09-08 07:38:01

xinomilo
Member
Registered: 2017-07-02
Posts: 267  

Re: [SOLVED] Why i can't upgrade ceres?

fix your sources.list and update system again..
where did you get this "ceres-updates" thing from?
probably changed all stable repo references to ceres, but that's not right for ceres or testing.

for ceres you only need :
deb http://deb.devuan.org/merged ceres main non-free contrib

Offline

#5 2022-09-08 15:49:46

deepforest
Member
Registered: 2020-03-24
Posts: 93  

Re: [SOLVED] Why i can't upgrade ceres?

steve_v
Thanks a lot!)

xinomilo
I do all according this instructions.
https://dev1galaxy.org/viewtopic.php?id=5213

Now i am updating....

My source.list
https://imgur.com/a/4Ge9wST

Last edited by deepforest (2022-09-08 15:50:04)

Offline

Board footer