The officially official Devuan Forum!

You are not logged in.

#1 2022-03-30 20:17:31

deepforest
Member
Registered: 2020-03-24
Posts: 49  

[SOLVED] PulseAudio issues on Ceres

Devuan Ceres

After boot, AWAYS, volume is turned off and output port at audio mixer always sets "Headfones" instead of "Line out".

I need always fix that manually. How fix that?

https://ibb.co/mCHVt6P

Last edited by deepforest (2022-04-01 20:16:25)

Offline

#2 2022-03-31 08:22:57

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,326  

Re: [SOLVED] PulseAudio issues on Ceres

deepforest wrote:

Devuan sid

I presume you mean Devuan ceres? The Debian sid repository should not be mixed with Devuan unless you know what you're doing.

deepforest wrote:

How fix that?

Copy the init script in this post to /etc/init.d/alsa-restore then run

# update-rc.d alsa-restore defaults

To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#3 2022-04-01 18:40:58

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

Head_on_a_Stick wrote:
deepforest wrote:

Devuan sid

I presume you mean Devuan ceres? The Debian sid repository should not be mixed with Devuan unless you know what you're doing.

deepforest wrote:

How fix that?

Copy the init script in this post to /etc/init.d/alsa-restore then run

# update-rc.d alsa-restore defaults

I did according your instructions. But its same.

root@devuan:/etc/init.d# ls -l /etc/init.d/alsa-restore 
-rwxrwxrwx 1 root root 700 Apr  1 21:23 /etc/init.d/alsa-restore
root@devuan:/etc/init.d# 
/etc/init.d/alsa-restore                                                                                                                                            700/700               100%
#!/bin/sh
# Generated by sysd2v v0.3  --  http://www.trek.eu.org/devel/sysd2v
# kFreeBSD do not accept scripts as interpreters, using #!/bin/sh and sourcing.
if [ true != "$INIT_D_SCRIPT_SOURCED" ] ; then
    set "$0" "$@"; INIT_D_SCRIPT_SOURCED=true . /lib/init/init-d-script
fi
### BEGIN INIT INFO
# Provides:       alsa-restore
# Required-Start: $remote_fs
# Required-Stop:  $remote_fs
# Default-Start:  2 3 4 5
# Default-Stop:   0 1 6
# Description:    Save/Restore Sound Card State
### END INIT INFO
DESC="alsa-restore"
DAEMON=none
PIDFILE=none

do_start_cmd_override ()
{
  /usr/bin/alsactl restore
  true
}

do_stop_cmd_override ()
{
  /usr/bin/alsactl store
  true
}

do_status_override () :

in boot log i see this

INIT: Entering runlevel: 2

Fri Apr  1 21:26:02 2022: Using makefile-style concurrent boot in runlevel 2.
Fri Apr  1 21:26:03 2022: Starting alsa-restore: none/etc/init.d/alsa-restore: 21: /lib/init/init-d-script: /usr/bin/alsactl: not found
Fri Apr  1 21:26:03 2022: .

UPD
I search alsactl and found it only here at sbin but not bin

root@devuan:/usr/sbin# /usr/sbin/alsactl 

I am replace at script "bin" to "sbin" and again apply command

root@devuan:/usr/sbin# /usr/sbin/alsactl 

But still same, at booting no errors but after booting volume is disabled

UPD2
now at boot log

Fri Apr  1 23:13:08 2022: Starting alsa-restore: none.

Last edited by deepforest (2022-04-01 20:20:50)

Offline

#4 2022-04-01 19:25:13

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

also i have that output

freeartist@devuan:~$ sudo pacmd list-card
[sudo] password for freeartist: 
No PulseAudio daemon running, or not running as session daemon.
freeartist@devuan:~$ 

Offline

#5 2022-04-01 19:26:55

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

Its happened when i upgrade Chimaera to Ceres

Offline

#6 2022-04-02 09:31:57

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,326  

Re: [SOLVED] PulseAudio issues on Ceres

So was sound working under chimaera? Were your settings saved there?


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#7 2022-04-02 12:40:10

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

Head_on_a_Stick wrote:

So was sound working under chimaera? Were your settings saved there?

Its was working. I am upgrade chimaera to ceres and now after upgrade sound is disabled. Manually i can enable it, but i want that its auto work. How i can find settings? Sorry.

Last edited by deepforest (2022-04-02 12:41:36)

Offline

#8 2022-04-03 19:30:34

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

pacmd list-sinks | less
https://pastebin.com/raw/5ffkYe6m

pacmd list-sources | less
https://pastebin.com/raw/aZmVFeEg

pacmd list-cards
https://pastebin.com/raw/QR6UQrXg

Last edited by deepforest (2022-04-03 19:52:37)

Offline

#9 2022-04-04 11:02:38

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,326  

Re: [SOLVED] PulseAudio issues on Ceres


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#10 2022-04-04 14:05:32

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

Head_on_a_Stick wrote:

Thanks.

this 2 command make audio works again. But how i can make it work automatically? Not manually enter every time after booting?

freeartist@devuan:~$ pacmd set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout
freeartist@devuan:~$ amixer -D pulse sset Master toggle

Offline

#11 2022-04-04 16:41:44

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,326  

Re: [SOLVED] PulseAudio issues on Ceres

Create a file at ~/.config/pulse/default.pa with these lines:

.include /etc/pulse/default.pa
set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo 0

Reference: https://wiki.archlinux.org/title/PulseA … utput_sink

Last edited by Head_on_a_Stick (2022-04-04 16:43:14)


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#12 2022-04-05 15:46:06

deepforest
Member
Registered: 2020-03-24
Posts: 49  

Re: [SOLVED] PulseAudio issues on Ceres

Head_on_a_Stick wrote:

Create a file at ~/.config/pulse/default.pa with these lines:

.include /etc/pulse/default.pa
set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo 0

Reference: https://wiki.archlinux.org/title/PulseA … utput_sink

Thank you very much! Now sound working good!)

Offline

Board footer