The officially official Devuan Forum!

You are not logged in.

#1 2022-02-20 01:14:26

bimon
Member
Registered: 2019-09-09
Posts: 167  

Video camera cannot be detected in Chromium, e.g. in Google Meet

Hello,

Google Meet works on Firefox for me including video (which is actually a loopback device),

but there is no video if trying to do the same in Chromium.

Chrome does not see video camera too sad

I have wrote following script for converting a video stream from chines fish eye video camera to a /dev/video compatible with Zoom:

rmmod v4l2loopback;
modprobe v4l2loopback;

sleep 1s;

set -x;

URL="rtsp://192.168.x.x:554/user=vasya&password=xxx&channel=&stream=1.sdp?real_stream--rtp-caching=100";

#---Cut region, scales are specific to region size:
Crop=" crop=210:300:210:250,";
#--- Slim:
Scale="300:350";
#--- Normal:
#Scale="300:300";

PixFormat=" -pix_fmt yuv420p ";

nice -n 7 ffmpeg -rtsp_transport tcp -r 1  -i "$URL" -vf $Crop"hflip,scale="$Scale $PixFormat -f v4l2 /dev/video0;

#-reorder_queue_size 4000 -max_delay 10000000
#-target pal-dvd
#-loglevel debug
rmmod v4l2loopback;

It works very well in Zoom and Firefox, but  if trying to use default video camera setting with full resolution without a crop it would work too slow.

Also as I already told it does not work with Chrome and Chromium.

Last edited by bimon (2022-02-20 01:34:44)

Offline

#2 2022-02-20 01:19:58

bimon
Member
Registered: 2019-09-09
Posts: 167  

Re: Video camera cannot be detected in Chromium, e.g. in Google Meet

Please help me to make this video cam working in browsers based on Google Chrome.

Offline

#3 2022-02-20 02:29:07

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 688  

Re: Video camera cannot be detected in Chromium, e.g. in Google Meet

I've had some luck using "-pix_fmt yuyv422" and "scale=-1:720"

Offline

#4 2022-02-20 07:46:18

bimon
Member
Registered: 2019-09-09
Posts: 167  

Re: Video camera cannot be detected in Chromium, e.g. in Google Meet

ralph.ronnquist wrote:

I've had some luck using "-pix_fmt yuyv422" and "scale=-1:720"

Unfortunately this does not work for me in Chromium (the same way as my settings mentioned earlier).

Last edited by bimon (2022-02-20 07:47:27)

Offline

Board footer