The officially official Devuan Forum!

You are not logged in.

#1 2021-12-30 07:52:04

hevidevi
Member
Registered: 2021-09-17
Posts: 230  

Gnome on Ceres - unstable repo

Bored so decided to install ceres unstable and see how gnome desktop performs, the full bloated version, like 900 mb download.

So it is working ok, i have a few issues id like to share.

1. pulseaudio needs to be started via pulseaudio -D, can do this via xdg autostart in a .desktop file

[Desktop Entry]
Type=Application
Name=pulseaudio
Exec=/usr/bin/pulseaudio -D

2. i have commented #autospawn=yes in /etc/pulse/client.conf.d/01-enable-autospawn.conf but this made no difference to getting the pulseaudio daemon to start via sysvinit.

3. this is all on the wayland session, the x11 session works fine, so my guess is that wayland is the issue, and i do have xwayland installed.

4. i have to start firefox via MOZ_ENABLE_WAYLAND=1

Just some obeservations here, if anyone has some input on why these issues have arisen please let me know.

Last edited by hevidevi (2021-12-30 08:00:07)

Offline

#2 2021-12-30 09:58:50

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,436  

Re: Gnome on Ceres - unstable repo

hevidevi wrote:

1. pulseaudio needs to be started via pulseaudio -D, can do this via xdg autostart in a .desktop file

[Desktop Entry]
Type=Application
Name=pulseaudio
Exec=/usr/bin/pulseaudio -D

That's strange — the PA package already supplies /etc/xdg/autostart/pulseaudio.desktop hmm

hevidevi wrote:

2. i have commented #autospawn=yes in /etc/pulse/client.conf.d/01-enable-autospawn.conf but this made no difference to getting the pulseaudio daemon to start via sysvinit.

I take it you mean #autospawn=no? Does changing it to autospawn=yes (un-commented) make it start as expected?

Have you tried pipewire-pulse instead? PA is almost obsolete now.

hevidevi wrote:

4. i have to start firefox via MOZ_ENABLE_WAYLAND=1

What errors do you see if you try to start FF via Xwayland? It runs just fine in my GNOME Wayland desktop under Arch.


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#3 2021-12-30 10:08:20

hevidevi
Member
Registered: 2021-09-17
Posts: 230  

Re: Gnome on Ceres - unstable repo

there is no pulseaudio.desktop in /etc/xdg/autostart

When i originally edited the file /etc/pulse/client.conf.d/01-enable-autospawn.conf the file contained autospawn=yes un-commented and the audio was non existent.

I have pipewire-pulse installed.

Not sure what you mean by starting FF under Xwayland, from the wayland session in a terminal? How is that done?

Just to mention i start the session using gdm3 if you were wondering. And also the volume icon disappeared in gdm when i made my edits and desktop file and rebooted.

Last edited by hevidevi (2021-12-30 10:14:13)

Offline

#4 2021-12-30 10:17:13

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,436  

Re: Gnome on Ceres - unstable repo

hevidevi wrote:

there is no paulseaudio.desktop in /etc/xdg/autostart

There should be — it's listed in the file contents for that version.

What does this say:

dpkg -L pulseaudio | grep xdg # if there's no output remove the pipe to grep to make sure the package is actually installed
hevidevi wrote:

I have pipewire-pulse installed.

That replaces the PA daemon so that might explain the observed behaviour. Does uninstalling it fix things?

hevidevi wrote:

Not sure what you mean by starting FF under Xwayland, from the wayland session in a terminal? How is that done?

MOZ_ENABLE_WAYLAND=0 firefox

But make sure any other FF instances are closed first. Check about:support to see if the "Window Protocol" is Xwayland.

Last edited by Head_on_a_Stick (2021-12-30 10:18:00)


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#5 2021-12-30 10:30:20

hevidevi
Member
Registered: 2021-09-17
Posts: 230  

Re: Gnome on Ceres - unstable repo

my mistake it is there.

~ > dpkg -L pulseaudio | grep xdg
/etc/xdg
/etc/xdg/Xwayland-session.d
/etc/xdg/Xwayland-session.d/00-pulseaudio-x11
/etc/xdg/autostart
/etc/xdg/autostart/pulseaudio.desktop

uninstalled pipewire-pulse, i had actually installed that manually to begin with to see if it was the issue.

So i put everything back the way it was when i installed  gnome and still same issues. Im fairly certain xterm should start under wayland if Xwayland is installed but it does not.

MOZ_ENABLE_WAYLAND=0 firefox 

starting FF like that from the terminal does nothing, it just hangs there, no output either.

Offline

#6 2021-12-30 10:40:50

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,436  

Re: Gnome on Ceres - unstable repo

Well I've used xterm in GNOME's Wayland desktop for quite a while now so this might just be a ceres/sid SNAFU.

Which versions of GNOME & Xwayland are you on? I'll try testing stuff in a VM when I have a moment.


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#7 2021-12-30 10:47:42

hevidevi
Member
Registered: 2021-09-17
Posts: 230  

Re: Gnome on Ceres - unstable repo

definitely some sort of snafu. Must be a setting somewhere that needs tweaking.

Xwayland is Version: 2:21.1.4-1

Gnome is Version: 1:41+1

Offline

Board footer