The officially official Devuan Forum!

You are not logged in.

#1 2021-10-23 13:26:20

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 71  
Website

No more wlan after upgrade

During the last days I upgraded 7 machines from beowulf or chimaera-testing to the stable chimaera version - without any problem - perfect.
And today I did the upgrade on the last machine - an old Asus eee701, running chimaere-beta-386.
Upgrade went fine, but after the following reboot I had no connection to the internet. Ifconfig showed why: No IP address for wlan0.

The network handling for wlan0 was made by the wpa_supplicant, also perfect and stable. Now I saw that the wpa_supplicant was running on wlan0, but the dhclient was unable to give an ip.
Then I saw that further daemons were :
- avahi-daemon, which created an own interface wlan0:avahi with a fall-back ip adress from a wrong range.
-network-manager
-modem-manager

I never ever had configured this daemons to run and to handle my wlan interface - but they did. However none of the programs were able to fire up wlan0 and connect to my dhcp server. OK, to many cooks probably.

All this only happened on the old eee701 Asus machine, other computer with wlan interface are still running fine with wpa_supplicant.

What is the best way to connect to the internet? Is it time to say good-bye to the wpa_supplicant? Or shall I deactivate network-manager and modem-manager and let still do wpa_supplicant the job?
Hints are highly appreciated.

Regards
Berni


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

#2 2021-10-23 22:57:46

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,877  
Website

Re: No more wlan after upgrade

berni51 wrote:

The network handling for wlan0 was made by the wpa_supplicant

Please share the full configuration and also indicate which services were enabled (and how) to acheive this.

berni51 wrote:

Now I saw that the wpa_supplicant was running on wlan0, but the dhclient was unable to give an ip.

It's always best to provide the full, verbatim command output rather than a vague description.

berni51 wrote:

What is the best way to connect to the internet? Is it time to say good-bye to the wpa_supplicant? Or shall I deactivate network-manager and modem-manager and let still do wpa_supplicant the job?

There should be no problem using wpa_supplicant alone to associate with the access point. Disabling any other networking services that might conflict and configuring wpa_supplicant and dhclient correctly should work.


antifa ftw!

Offline

#3 2021-10-24 07:21:00

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 71  
Website

Re: No more wlan after upgrade

Thanks @Head_on_a_Stick. The problem was that I could not find any error message. Wpa_supplicant was running, as well as dhclient, but they never were able to connect the machine.
I did what you said and disabled avahi, network-manager and modem-manager, step by step and one after the other. After that and without any further other changing the wpa_supplicant connects the machine as all the years before.

Did the upgrade process started all these daemons?


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

#4 2021-10-24 08:49:28

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,877  
Website

Re: No more wlan after upgrade

It's possible the packages were pulled in as part of the upgrade process and if so then Devuan will automatically enable those services. Check the APT log(s) to be sure.


antifa ftw!

Offline

Board footer