The officially official Devuan Forum!

You are not logged in.

#1 2021-09-20 19:08:06

durham
Member
Registered: 2021-09-04
Posts: 28  

startx slowwww to start when offline

Running Devuan 64 Chimaera.

On my system I log in, in text mode, then, when I want to, I type startx to start up xorg & the window manager.

When my computer is not connected to the net, and I type startx, there is a minute before anything happens; I'm just staring at the text ode screen. When I am online, startx goes to a graphics mode screen almost instantly and starts the window manager without delay.

This is utterly strange. In several distros over several years, I have never encountered this!

Why would that make a difference? xorg has no reason to touch anything the net. Is it trying to send data to something out there?

log of output with no net:

hostname: Temporary failure in name resolution
xauth: (stdin):1:  bad display name "moonshadow:0" in "add" command


X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: linux Debian
Current Operating System: Linux moonshadow 5.10.0-8-amd64 #1 SMP Debian 5.10.46-4 (2021-08-03) x86_64
Kernel command line: BOOT_IMAGE=dawn ro root=fd0b loglevel=4 panic=12 loglevel=4 logo.nologo root=/dev/azura/dawn blacklist=bluetooth
Build Date: 13 April 2021  04:07:31PM
xorg-server 2:1.20.11-1 (https://www.debian.org/support) 
Current version of pixman: 0.40.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/bob/.local/share/xorg/Xorg.0.log", Time: Mon Sep 20 12:38:58 2021
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
xrdb: colon missing on line 107, ignoring line
xrdb: colon missing on line 108, ignoring line
xrdb: colon missing on line 109, ignoring line

(pnmixer:2549): Gtk-WARNING **: 12:39:01.989: Theme parsing error: gtk.css:8:12: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(pnmixer:2549): Gtk-WARNING **: 12:39:01.990: Theme parsing error: gtk.css:26:19: The :prelight pseudo-class is deprecated. Use :hover instead.

(pnmixer:2549): Gtk-WARNING **: 12:39:01.990: Theme parsing error: gtk.css:30:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(pnmixer:2549): Gtk-WARNING **: 12:39:01.990: Theme parsing error: gtk.css:68:17: 'foregound-color' is not a valid property name

(connman-gtk:2552): Gtk-WARNING **: 12:39:04.073: Theme parsing error: gtk.css:8:12: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(connman-gtk:2552): Gtk-WARNING **: 12:39:04.073: Theme parsing error: gtk.css:26:19: The :prelight pseudo-class is deprecated. Use :hover instead.

(connman-gtk:2552): Gtk-WARNING **: 12:39:04.078: Theme parsing error: gtk.css:30:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(connman-gtk:2552): Gtk-WARNING **: 12:39:04.078: Theme parsing error: gtk.css:68:17: 'foregound-color' is not a valid property name

(pnmixer:2549): Gdk-WARNING **: 12:53:35.191: GdkWindow 0x800007 unexpectedly destroyed

(connman-gtk:2552): Gdk-WARNING **: 12:53:35.191: GdkWindow 0x1000007 unexpectedly destroyed

(connman-gtk:2552): Gdk-ERROR **: 12:53:35.193: The program 'connman-gtk' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 9487 error_code 143 request_code 139 (RENDER) minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(pnmixer:2549): Gdk-ERROR **: 12:53:35.193: The program 'pnmixer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 514 error_code 143 request_code 139 (RENDER) minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

xauth: (argv):1:  bad display name "moonshadow:0" in "remove" command

log of output with net

hostname: Name or service not known
xauth: (stdin):1:  bad display name "moonshadow:0" in "add" command


X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System: linux Debian
Current Operating System: Linux moonshadow 5.10.0-8-amd64 #1 SMP Debian 5.10.46-4 (2021-08-03) x86_64
Kernel command line: BOOT_IMAGE=dawn ro root=fd0b loglevel=4 panic=12 loglevel=4 logo.nologo root=/dev/azura/dawn blacklist=bluetooth
Build Date: 13 April 2021  04:07:31PM
xorg-server 2:1.20.11-1 (https://www.debian.org/support) 
Current version of pixman: 0.40.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/bob/.local/share/xorg/Xorg.0.log", Time: Mon Sep 20 12:59:56 2021
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
xrdb: colon missing on line 107, ignoring line
xrdb: colon missing on line 108, ignoring line
xrdb: colon missing on line 109, ignoring line

(pnmixer:3784): Gtk-WARNING **: 13:00:00.034: Theme parsing error: gtk.css:8:12: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(pnmixer:3784): Gtk-WARNING **: 13:00:00.035: Theme parsing error: gtk.css:26:19: The :prelight pseudo-class is deprecated. Use :hover instead.

(pnmixer:3784): Gtk-WARNING **: 13:00:00.035: Theme parsing error: gtk.css:30:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(pnmixer:3784): Gtk-WARNING **: 13:00:00.035: Theme parsing error: gtk.css:68:17: 'foregound-color' is not a valid property name

(connman-gtk:3787): Gtk-WARNING **: 13:00:02.120: Theme parsing error: gtk.css:8:12: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'

(connman-gtk:3787): Gtk-WARNING **: 13:00:02.120: Theme parsing error: gtk.css:26:19: The :prelight pseudo-class is deprecated. Use :hover instead.

(connman-gtk:3787): Gtk-WARNING **: 13:00:02.126: Theme parsing error: gtk.css:30:13: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(connman-gtk:3787): Gtk-WARNING **: 13:00:02.126: Theme parsing error: gtk.css:68:17: 'foregound-color' is not a valid property name

(pnmixer:3784): Gdk-WARNING **: 13:00:29.097: GdkWindow 0x800007 unexpectedly destroyed

(connman-gtk:3787): Gdk-WARNING **: 13:00:29.098: GdkWindow 0x1200007 unexpectedly destroyed

(pnmixer:3784): Gdk-ERROR **: 13:00:29.099: The program 'pnmixer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 324 error_code 143 request_code 139 (RENDER) minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(connman-gtk:3787): Gdk-ERROR **: 13:00:29.100: The program 'connman-gtk' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 384 error_code 143 request_code 139 (RENDER) minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

xauth: (argv):1:  bad display name "moonshadow:0" in "remove" command

Running diff, the only non-common error-messages between the two runs was:

1c1
< hostname: Temporary failure in name resolution
---
> hostname: Name or service not known

Can anyone please advise?  This has me dumbfounded.

Thank you.

Last edited by durham (2021-09-20 19:09:53)


A dangerous technology is one that is available only to an elite group  -- George M. Ewing, Analog, April 1977

Offline

#2 2021-09-20 19:35:12

durham
Member
Registered: 2021-09-04
Posts: 28  

Re: startx slowwww to start when offline

Well, I figured it out. Rather, I got it to work. Pasted this in from a previous distro's /etc/hosts:

# This next entry is technically wrong, but good enough to get TCP/IP apps
# to quit complaining that they can't verify the hostname on a loopback-only
# Linux box.
127.0.0.1       moonshadow.example.net moonshadow

That comment, along with the man page for hostname, were my clues.

Rebooted.  Made sure I was offline.  Ran startx.  Blink: in the window manager without delay.

Last edited by durham (2021-09-20 19:36:35)


A dangerous technology is one that is available only to an elite group  -- George M. Ewing, Analog, April 1977

Offline

#3 2021-09-20 19:36:24

JWM-Kit
Member
Registered: 2020-06-29
Posts: 33  
Website

Re: startx slowwww to start when offline

A stab in the dark here. I see you are using connman.  If connman is allowed to change the host name it can cause problems with X authority as it expects a different name. Maybe try adding AllowHostnameUpdates=false to /etc/connman/main.conf

Like I said, "a stab in the dark". If it works good. Sorry, if I'm wrong just put it back how it was

EDIT : I see you had it fixed before I pressed post. I guess I was barking up the wrong tree and your hostname wasn't even set to begin with.

Last edited by JWM-Kit (2021-09-20 19:39:12)

Offline

#4 2021-09-20 19:39:21

durham
Member
Registered: 2021-09-04
Posts: 28  

Re: startx slowwww to start when offline

JWM-Kit: Thank you for the quick reply. I am new to (and not particularly fond of) connman, so your advice is appreciated.


A dangerous technology is one that is available only to an elite group  -- George M. Ewing, Analog, April 1977

Offline

#5 2021-09-20 19:44:24

durham
Member
Registered: 2021-09-04
Posts: 28  

Re: startx slowwww to start when offline

JWM-Kit wrote:

EDIT : I see you had it fixed before I pressed post. I guess I was barking up the wrong tree and your hostname wasn't even set to begin with.

It's as  if the /etc/hostname file is ignored?


A dangerous technology is one that is available only to an elite group  -- George M. Ewing, Analog, April 1977

Offline

#6 2021-09-20 20:18:23

JWM-Kit
Member
Registered: 2020-06-29
Posts: 33  
Website

Re: startx slowwww to start when offline

I've seen many cases where the hostname was ignored, changed, or overridden.  I'm sure there's someone else out there who knows a lot more about it than I do.

Offline

#7 2021-09-21 08:42:11

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,738  
Website

Re: startx slowwww to start when offline

I've just debootstraped a Debian buster system to test:

$ cat /tmp/debian/etc/hosts                                    
127.0.0.1       localhost
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

$

@OP: Was that the content prior to your modifications? localhost should work just as well as the actual FQDN (AFAIK).

Last edited by Head_on_a_Stick (2021-09-21 08:47:45)


antifa ftw!

Offline

Board footer