The officially official Devuan Forum!

You are not logged in.

#1 2021-04-27 01:17:39

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

[SOLVED] Toshiba Tecra S2

I have a Tecra S2 and everything working great....

Except audio..

I have alsa setup, I have apulse installed.

I get no audio from the speakers..

If i unmute the mic and turn on mic boost I do hear static.

I tried installing pulse audio and could see the bar going back and forth in pavucontrol

Never getting anything from the speakers.

This is an older model win xp style laptop.

Any suggestions?

Thanks

Offline

#2 2021-04-27 13:42:09

dice
Member
Registered: 2020-11-22
Posts: 559  
Website

Re: [SOLVED] Toshiba Tecra S2

Im assuming you are on stable/beowulf devuan installation.

Have you read the release notes, it may help with the pulseaudio issue. As for alsa, maybe the master needs to be unmuted. Do you have any physical knobs or sliders on the machine ?

https://files.devuan.org/devuan_beowulf … _notes.txt

Are you in the audio group?

Pulseaudio
 - If you install a desktop environment from the installer iso, you will
   automatically get the debian-pulseaudio-config-override package,
   which will ensure that pulseaudio is running. If you're running a
   window manager, you may need to install the override package to get
   sound. Alternatively, you may use the old method, described below.
   
 - If you have no sound, make sure the following line in
   /etc/pulse/client.conf.d/00-disable-autospawn.conf is commented as
   shown here:

   #autospawn=no

Last edited by dice (2021-04-27 13:43:28)

Offline

#3 2021-04-27 15:28:41

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,723  
Website

Re: [SOLVED] Toshiba Tecra S2

Users shouldn't need to be in the audio group for the speakers to work.

@OP: can we see

aplay -l
amixer

antifa ftw!

Offline

#4 2021-04-27 16:25:43

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

dice wrote:

Im assuming you are on stable/beowulf devuan installation.

Have you read the release notes, it may help with the pulseaudio issue. As for alsa, maybe the master needs to be unmuted. Do you have any physical knobs or sliders on the machine ?

https://files.devuan.org/devuan_beowulf … _notes.txt

Are you in the audio group?

Pulseaudio
 - If you install a desktop environment from the installer iso, you will
   automatically get the debian-pulseaudio-config-override package,
   which will ensure that pulseaudio is running. If you're running a
   window manager, you may need to install the override package to get
   sound. Alternatively, you may use the old method, described below.
   
 - If you have no sound, make sure the following line in
   /etc/pulse/client.conf.d/00-disable-autospawn.conf is commented as
   shown here:

   #autospawn=no

I am at work for the next 6 hours, I did check for physical volume slider / dial but found nothing.

At first i tried all volumes in alsamixergui...

Upon no results i switched to plain old alsamixer and unmuted more and turned up more volumes.

This is when i heard the mic static.

Still no audio though.

I will try your pulseaudio suggestion tonight.

Offline

#5 2021-04-27 16:27:15

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

Head_on_a_Stick wrote:

Users shouldn't need to be in the audio group for the speakers to work.

@OP: can we see

aplay -l
amixer

After work tonight I will post the output.

Offline

#6 2021-04-27 16:30:32

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

One detail I hadn't posted is that when I was in pulseaudio volume control it showed devices like HDMI / Spdif which this computer is way too old to have.

Last edited by Rpisp (2021-04-27 16:31:09)

Offline

#7 2021-04-28 01:52:42

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

hockey@hockey-TECRA-S2:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
hockey@hockey-TECRA-S2:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 63 [100%] [0.00dB] [on]
  Front Right: Playback 63 [100%] [0.00dB] [on]
Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 63 [100%] [0.00dB] [on]
  Front Right: Playback 63 [100%] [0.00dB] [on]
Simple mixer control '3D Control - Switch',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'PCM Out Path & Mute',0
  Capabilities: enum
  Items: 'pre 3D' 'post 3D'
  Item0: 'post 3D'
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [12.00dB] [on] Capture [off]
  Front Right: Playback 31 [100%] [12.00dB] [on] Capture [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [12.00dB] [on] Capture [on]
  Front Right: Playback 31 [100%] [12.00dB] [on] Capture [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [12.00dB] [off] Capture [off]
  Front Right: Playback 31 [100%] [12.00dB] [off] Capture [off]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic Select',0
  Capabilities: enum
  Items: 'Mic1' 'Mic2'
  Item0: 'Mic1'
Simple mixer control 'Video',0
  Capabilities: cswitch cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [12.00dB] [on]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Playback AC97-SPSA',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Capture channels: Mono
  Limits: 0 - 3
  Mono: 3 [100%]
Simple mixer control 'Beep',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 15 [100%] [0.00dB] [on]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [12.00dB] [on] Capture [off]
  Front Right: Playback 31 [100%] [12.00dB] [on] Capture [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

Offline

#8 2021-04-28 02:31:38

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

Apparently the headphone port works perfectly

Just no speakers

Offline

#9 2021-04-28 11:29:43

dice
Member
Registered: 2020-11-22
Posts: 559  
Website

Re: [SOLVED] Toshiba Tecra S2

That is quite an old laptop from 2005, see this link...

https://forums.whirlpool.net.au/archive/461197

Post 5 says....

To active the sound on the digital output, all I had to do was to *mute* the IEC958 Playback...

Im assuming IEC958 Playback should showup in alsamixer in the terminal ?

Maybe try installing alsa-oss package ??

https://wiki.debian.org/SoundConfiguration

Head on a stick will probably have a better analysis than me though.

I could be completely off the mark here as i dont know much about this, but cant hurt to try simple commands.

Interesting to note some info on

https://alsa.opensrc.org/Realtek_ALC650 aka, 'traditional' Intel Audio Codec 1997 (AC'97) standard. Which is listed in your output.

Last edited by dice (2021-04-28 11:43:31)

Offline

#10 2021-04-28 11:51:22

dice
Member
Registered: 2020-11-22
Posts: 559  
Website

Re: [SOLVED] Toshiba Tecra S2

Head_on_a_Stick wrote:

Users shouldn't need to be in the audio group for the speakers to work.

@OP: can we see

aplay -l
amixer

Having read the archwiki this is true, but debian wiki says something completely different, maybe it is just due to gnome desktop, either way you might be right and may have no bearing on speaker function.

https://wiki.debian.org/SoundConfiguration

Use 'adduser USER_NAME audio' to allow a specific user to write to the /dev/dsp, /dev/mixer and /dev/audio devices and thus output sound from the soundcard; note: the user needs to log off and on again for such changes to take effect! This is the recommended way to allow a user to play audio. If, instead, you changed the permissions of the /dev/audio etc devices to make them accessible to anyone, that would open a security hole because you would be allowing any trojan to read the microphone device.


better is to add your user to the audio group

Unix Group

If you notice that a user starts up Gnome and receives a message about Audio not working the likely cause is that the user is not in group audio (only the initialy created user is in the audio group by default).

I take it they must be talking about remote user of gnome? Vague to say the least.

Last edited by dice (2021-04-28 12:02:21)

Offline

#11 2021-04-28 16:18:40

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,723  
Website

Re: [SOLVED] Toshiba Tecra S2

^ I've never needed to add any users to the audio group to get the sound working in Debian.

@OP: it doesn't look like PulseAudio is running so try starting it and see if that changes anything.

You can also try

# alsactl init

But it looks like the system doesn't recognise an analogue soundcard, which is strange.

Can we see

lspci -k | grep -iA2 Audio

antifa ftw!

Offline

#12 2021-04-28 18:21:45

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

dice wrote:

That is quite an old laptop from 2005, see this link...

https://forums.whirlpool.net.au/archive/461197

Post 5 says....

To active the sound on the digital output, all I had to do was to *mute* the IEC958 Playback...

Funny that you post that right after I read a page about the exact same thing.

The page I read said that the headphone volume and the speaker volumes were linked and one had to be muted for the other to work.

Which I find very interesting because I have the headphones working and the speakers not.

I will try to confirm this tonight when I get home from work.

Last edited by Rpisp (2021-04-28 18:22:13)

Offline

#13 2021-04-29 01:08:56

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

So muting various channels had no effect.

Installing alsa-oss INSTANTLY fixed everything.

Thanks for all the help, this is solved.

Offline

#14 2021-04-29 01:23:27

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

For the record in case anyone reads this looking for the answer:

I needed alsa-oss AND pulseaudio installed

Also after tinkering in pavucontrol (pulseaudio volume control) Muting the IEC958 under the configuration tab is necessary.

So go to Configuration select IEC958 then go to Output Devices and mute

Then go back to Config tab and select Analog Stereo Duplex

Lastly go back to Output Devices and make sure you are not muted.

(May need to use alsamixer for last step)

All working here now.

Offline

#15 2021-04-29 12:44:22

dice
Member
Registered: 2020-11-22
Posts: 559  
Website

Re: [SOLVED] Toshiba Tecra S2

glad you got it working!

One cannot be without sound in this world if at all possible.

Cool you got that machine up and running with devuan beowulf too smile

Offline

#16 2021-04-30 16:20:48

Rpisp
Member
Registered: 2021-04-19
Posts: 30  

Re: [SOLVED] Toshiba Tecra S2

It's worth noting that this solution is useful elsewhere.

I was able to slightly modify this and fix the sound on my Fedora installation on my tablet.

I had to mute the HDMI so that the analog audio would work there as well.

Great trick to know.

Last edited by Rpisp (2021-04-30 16:23:29)

Offline

Board footer