The officially official Devuan Forum!

You are not logged in.

#1 2021-04-25 13:07:10

Registered: 2021-02-27
Posts: 11  

Graphical glitches on Radeon RX 6700 XT with proper firmware/Mesa...

I had posted this question (probably in the wrong section of the forum) but what separates (system76 Pop!_OS) from Debian/Devuan when trying to get these to work. I read somewhere that Pop!_OS had extracted files from the official amdgpu files from AMD. What prevents me from using these files for Ubuntu/Debian combo (Pop!_OS) on my pure Devuan install? Once installed on Devuan I get graphical glitches all over the place from the terminal when it refreshes to my Steam games, etc. On Devuan (Chimaera) all the firmware files were in place and I updated to the newer mesa 21.x. Everything was fine until I swapped out a RX 570 for a RX 6700 XT. I was able to boot w/o using "nomodeset" and I was able to use the higher resolution. Does anyone have a solution or suggestion that would allow me to move back to Devuan? I also tried using Artix with some installs from the AUR that used to be on top of things with modern hardware, but again, the same glitches I experienced with Devuan. I also tried lastly before installing Pop!_OS to change the install files from AMD from "ubuntu" to "devuan" which allowed me to install most of the files all the way up to the dkms stuff which it refused.

Thank you for your time (readers) & hope you all have a great day!


#2 2021-04-25 13:45:58

From: London
Registered: 2019-03-24
Posts: 1,654  

Re: Graphical glitches on Radeon RX 6700 XT with proper firmware/Mesa...

The amdgpu drivers are part of the kernel, AMD contribute directly to them so they are official. They also provide the firmware, which can be downloaded and added to /lib/firmware/ manaully if need be. If you want to try a newer kernel in Devuan then perhaps look at — their bullseye versions should be compatible with beowulf.

But I suspect your artefact problems are due to Mesa. IIRC there was a recent thread over at the Arch forums in which an AMD user fixed the glitches by using the mesa-git AUR package, which should also be installable in Artix. The most recent Mesa packages in Debian are only available from the experimental repositories and they are the same as the Arch (non-AUR) versions. The versions in sid/ceres should catch up once Debian 11 has been released though.


Last edited by Head_on_a_Stick (2021-04-25 14:19:18)

antifa ftw!


Board footer