The officially official Devuan Forum!

You are not logged in.

#1 2021-03-13 15:36:57

Muss
Member
Registered: 2020-02-21
Posts: 4  

[SOLVED] No LSB modules are available

Hello
When querying my devuan version with command

lsb_release -a

the output follows:
hermann@pinkman:~$ lsb_release -a               
No LSB modules are available.
Distributor ID: Devuan
Description: Devuan GNU/Linux 3 (beowulf)
Release: 3
Codename: beowulf
hermann@pinkman:~$
What does "No LSB modules are available" mean and if it is important, how can I fix it?
Thanks for an answer
Muss

Offline

#2 2021-03-13 16:18:21

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,694  
Website

Re: [SOLVED] No LSB modules are available

https://lwn.net/Articles/658809/

Ask a search engine for more details about this (which you should already have done before posting here btw).


antifa ftw!

Offline

#3 2021-03-13 16:57:59

Muss
Member
Registered: 2020-02-21
Posts: 4  

Re: [SOLVED] No LSB modules are available

Hello Head_on_a_Stick
Thanks anyway for your answer. But I already did that and there I got the answer that I should install lsb-core, but lsb-core is already installed on my system and that's why I posted the question here. Also lsb-base is installed. I do not know what to do without help. Unfortunately I am just a newbie on Linux/Devuan. My native language is German and probably sometimes I do not understand everything absolutely right, I think.
For help I am really grateful and wish a nice weekend
Muss

Offline

#4 2021-03-13 17:01:25

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,694  
Website

Re: [SOLVED] No LSB modules are available

Muss wrote:

I got the answer that I should install lsb-core, but lsb-core is already installed on my system

There is no lsb-core package in Devuan beowulf, it is obsolete.

Last edited by Head_on_a_Stick (2021-03-13 17:01:45)


antifa ftw!

Offline

#5 2021-03-13 19:07:56

rolfie
Member
Registered: 2017-11-25
Posts: 543  

Re: [SOLVED] No LSB modules are available

I have:

# apt list lsb*
Auflistung... Fertig
lsb-base/stable,stable,now 10.2019051400 all  [installiert]
lsb-release/stable,stable,now 10.2019051400 all  [Installiert,automatisch]

rolfie

Online

#6 2021-03-13 20:55:36

Muss
Member
Registered: 2020-02-21
Posts: 4  

Re: [SOLVED] No LSB modules are available

Thanks rolfie.
Here what
apt list lsb
outputs for me:

hermann@pinkman:~$ apt list lsb
Auflistung... Fertig
hermann@pinkman:~$

Nothing obviously

@Head_on_a_Stick:
On https://lwn.net/Articles/658809/ I found: "Debian dropping the Linux standard base". Does this mean that lsb-modules are no longer necessary? And if so, does this also apply to devuan?
Thanks for answer

Offline

#7 2021-03-13 21:08:59

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,694  
Website

Re: [SOLVED] No LSB modules are available

Muss wrote:

Does this mean that lsb-modules are no longer necessary? And if so, does this also apply to devuan?

Yes and yes.


antifa ftw!

Offline

#8 2021-03-13 21:19:46

rolfie
Member
Registered: 2017-11-25
Posts: 543  

Re: [SOLVED] No LSB modules are available

Muss wrote:

Thanks rolfie.
Here what
apt list lsb
outputs for me:

hermann@pinkman:~$ apt list lsb
Auflistung... Fertig
hermann@pinkman:~$

Nothing obviously

@Head_on_a_Stick:
On https://lwn.net/Articles/658809/ I found: "Debian dropping the Linux standard base". Does this mean that lsb-modules are no longer necessary? And if so, does this also apply to devuan?
Thanks for answer

You forgot the most important thing: "*"

Have a very close look at what I did post and compare to yours.

rolfie

Last edited by rolfie (2021-03-13 21:20:12)

Online

#9 2021-03-14 09:21:55

Muss
Member
Registered: 2020-02-21
Posts: 4  

Re: [SOLVED] No LSB modules are available

Thanks a lot Head_on_a_Stick and Rolfie.
Here is the correct output from apt list lsb*, Yes, I forgot the "*":

hermann@pinkman:~$ apt list lsb*
Listing... Done
lsb-base/stable,stable,now 10.2019051400 all [installed]
lsb-core/now 4.1+devuan2 amd64 [Installed,local]
lsb-release/stable,stable,now 10.2019051400 all [Installed,automatically]
lsb-security/now 4.1+devuan2 amd64 [Installed,local]
hermann@pinkman:~$

But this has no relevance according to Head_on_a_Stick's answer.
Thank you both. I'd like to mark the topic as [solved], but how?

Muss

Offline

Board footer