The officially official Devuan Forum!

You are not logged in.

#1 2021-02-24 17:20:43

devian
Member
Registered: 2019-11-08
Posts: 17  

No audio in KDE after dist-upgrade to Devuan 3.1

As title, my audio is no longer working since a recent upgrade. In my KDE system settings I have a "Dummy output" but that is it. My mixer has "master" control and nothing else - usually it has about 10 different sliders. Please could someone help me out?

Happy to provide more info as required but I like to think this is not a unique problem to me. Thanks.

Offline

#2 2021-02-24 17:22:59

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,542  
Website

Re: No audio in KDE after dist-upgrade to Devuan 3.1

Is PulseAudio running?

pgrep -a pulse

If not then read the beowulf release notes.


Black Lives Matter

Offline

#3 2021-02-24 20:27:43

devian
Member
Registered: 2019-11-08
Posts: 17  

Re: No audio in KDE after dist-upgrade to Devuan 3.1

I get this:

3069 /usr/bin/pulseaudio --start --log-target=syslog

I read the release notes again. I do not have this file:

/etc/pulse/client.conf.d/00-disable-autospawn.conf

debian-pulseaudio-config-override is installed.

If I enter alsamixer, I see the default soundcard is a dummy device. If I select the intel soundcard, suddenly I get all the expected sliders. That said, I still get no audio.

# pactl list short sinks
0       auto_null       module-null-sink.c      s16le 2ch 44100Hz       SUSPENDED

Last edited by devian (2021-02-24 20:54:17)

Offline

#4 2021-02-24 21:18:42

devian
Member
Registered: 2019-11-08
Posts: 17  

Re: No audio in KDE after dist-upgrade to Devuan 3.1

Fixed by uninstalling timidity.

apt-get purge timidity

Sigh.

Offline

Board footer