The officially official Devuan Forum!

You are not logged in.

#1 2021-01-02 21:44:37

Registered: 2020-08-03
Posts: 33  

Copy Speed??


I am a long time windows/mac user, and have been happily using duvean for the last year.

I could be convinced to almost make a permanent change except for one thing that bugs me:-)

Why is the copying SOO slow when I need to transfer files to , say , a usb stick?

We are talking maybe 50 times slower!

I found the same slowness in speeds on previous distros I had tried ( Mint. Manjero)

Is this specific to Linux? - the transfer starts fast and then LITERALLY crawls to an -almost -full stop :=)

If I stop the copy, that seems to happen quickly, but if I then try to eject the stick, it can stay on ''writing data to device'' for 5  minutes or more?

i am sure there are vastly more experienced people here who can help me out with my noobness.

Many  thanks



#2 2021-01-02 21:55:50

Registered: 2017-05-29
Posts: 239  

Re: Copy Speed??

I have had this problem and continue to have this problem on my thinkpad x200 librebooted device with Hyperbola as well as devuan, etc...

This I believe might be a hardware issue,  I don't know your hardware, but I begin to wonder if it is related to usb 3.0 not being used. You see, usb 3.0 at one point requires some unsafe blob which is a security issue and if you enabled it, you run the risk of a security problem.  I don't know if that has changed since I read about usb 3.0 a while back, it is entirely possible...  but that would be my guess, your not using usb 3.0 on linux.    If someone else wants to chime in, by all means, do so. 

But yeah, I think it has to do with Hardware, not software... when I say that it may have to do with hardware I mean compatibility with linux btw...


Black Lives Matter!  I am white, but I prefer equality over hatred.
Haughtiness comes before a fall, pride before destruction.
Peace be with you!


#3 2021-01-02 22:19:58

From: London
Registered: 2019-03-24
Posts: 1,542  

Re: Copy Speed?? … 722#107722

EDIT: using echo & /etc/rc.local is for n00bs so run this instead:

# sysctl vm.dirty_background_bytes=$((16*1024*1024))
# sysctl vm.dirty_bytes=$((48*1024*1024))

if that works use a file at /etc/sysctl.d/copy.conf to make the change permanent:


Last edited by Head_on_a_Stick (2021-01-02 23:24:59)

Black Lives Matter


Board footer