The officially official Devuan Forum!

You are not logged in.

#1 2020-08-08 20:36:39

sgage
Member
Registered: 2016-12-01
Posts: 246  

Install grub so that EFI directory is 'devuan'

I am running Ceres (which is running very well with MATE). How can I install grub so that the EFI directory is 'devuan' instead of 'debian'. Using the '--bootloader-id=devuan' argument to grub-install still creates a 'debian' directory. My os-release file has 'ID=devuan'. I don't know what else to try. Any ideas?

TIA...

Offline

#2 2020-08-08 21:06:36

rolfie
Member
Registered: 2017-11-25
Posts: 415  

Re: Install grub so that EFI directory is 'devuan'

That will work if you don't use Secure Boot. But you still will have a debian and a devuan EFI directory.

Use the efibootmgr to boot the devuan entry. If that works, you can delete the debian entry with the file manager.

rolfie

Offline

#3 2020-08-08 21:23:37

sgage
Member
Registered: 2016-12-01
Posts: 246  

Re: Install grub so that EFI directory is 'devuan'

rolfie wrote:

That will work if you don't use Secure Boot. But you still will have a debian and a devuan EFI directory.

Use the efibootmgr to boot the devuan entry. If that works, you can delete the debian entry with the file manager.

rolfie

I want to have a separate devuan and debian directory. The problem is, that in Ceres (this did not happen in Beowulf), I can not get grub-install to generate a devuan directory at all. No matter what I've tried, grub-install generates a debian directory in /boot/efi/EFI. I know how to use efibootmgr to set boot order and such.

Offline

#4 2020-08-09 07:20:50

rolfie
Member
Registered: 2017-11-25
Posts: 415  

Re: Install grub so that EFI directory is 'devuan'

I can confirm that also Chimaera (in a VM) has the same behaviour. What easily worked under Beowulf is no more working with the testing/unstable stuff.

Needs a closer look.

rolfie

Offline

#5 2020-08-09 11:24:41

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Install grub so that EFI directory is 'devuan'

sgage wrote:

I want to have a separate devuan and debian directory.

Why? If it's that important to you then install GRUB from an Arch live ISO (use the --boot-directory= & --efi-directory= options to avoid the need to chroot).

I can't find a reference in the changlelog but I presume $ESP/EFI/debian is being created because of https://bugs.debian.org/cgi-bin/bugrepo … bug=925309


Black Lives Matter

Offline

#6 2020-08-09 12:13:30

sgage
Member
Registered: 2016-12-01
Posts: 246  

Re: Install grub so that EFI directory is 'devuan'

Head_on_a_Stick wrote:
sgage wrote:

I want to have a separate devuan and debian directory.

Why? If it's that important to you then install GRUB from an Arch live ISO (use the --boot-directory= & --efi-directory= options to avoid the need to chroot).

I can't find a reference in the changlelog but I presume $ESP/EFI/debian is being created because of https://bugs.debian.org/cgi-bin/bugrepo … bug=925309

It's not that important. Thanks for the bug reference.

Offline

#7 2020-08-09 19:16:36

rolfie
Member
Registered: 2017-11-25
Posts: 415  

Re: Install grub so that EFI directory is 'devuan'

The following trick may do what you want:
1.) apt remove grub-efi-amd64-signed
2.) grub-install --bootloader-id=devuan

Worked in my Chimaera VM.

Offline

Board footer