The officially official Devuan Forum!

You are not logged in.

#1 2020-05-31 10:15:46

From: Wrocław, Poland
Registered: 2020-05-31
Posts: 13  

Devuan installer can't start on MX53 Loco (i.MX53 Quick Start board)


I have a "i.MX53 Quick Start board", which named "MCIMX53-START-R" (a new one, with PMIC MC34708 and Device tree file "imx53-qsrb.dtb", not old board with PMIC Dialog DA9053).

I repeated steps from … ble_images:

 % wget "
 % wget ""
 % zcat firmware.MX53LOCO.img.gz partition.img.gz > complete_image.img

Here are sha256sum(s):

fdb1096a90394878f0f5e23e146cc89ecd55d867b4b9327b791112041d8c9f51  complete_image.img
69376dc6f680a9d7273e36f39cb0d8d2f9d2fccd0756a13cff63b588e1b2ca24  firmware.MX53LOCO.img.gz
f3cf86ab65a1ca2469ca9fe9fe7ac1e9267d3c69bc5f12c7131503bb5e5764ca  partition.img.gz

And some other info:

 % file firmware.MX53LOCO.img partition.img complete_image.img
firmware.MX53LOCO.img: DOS/MBR boot sector; partition 1 : ID=0xc, active, start-CHS (0x0,32,33), end-CHS (0xc,114,38), startsector 2048, 197952 sectors
partition.img:         DOS/MBR boot sector, code offset 0x58+2, OEM-ID "mkfs.fat", Media descriptor 0xf8, sectors/track 32, heads 64, sectors 197952 (volumes > 32 MB), FAT (32 bit), sectors/FAT 1523, reserved 0x1, serial number 0x3498c0b4, unlabeled
complete_image.img:    DOS/MBR boot sector; partition 1 : ID=0xc, active, start-CHS (0x0,32,33), end-CHS (0xc,114,38), startsector 2048, 197952 sectors

Some useful information from U-Boot console, when I loaded board with this image:

=> printenv 
bootcmd=mmc dev ${mmcdev}; if mmc rescan; then if run loadbootscript; then run bootscript; else if run loadimage; then run mmcboot; else run netboot; fi; fi; else run netboot; fi
bootscript=echo Running bootscript from mmc ...; source
loadbootscript=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};
loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}
loadimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${image}
mmcargs=setenv bootargs console=ttymxc0,${baudrate} root=${mmcroot}
mmcboot=echo Booting from mmc ...; run mmcargs; if test ${boot_fdt} = yes || test ${boot_fdt} = try; then if run loadfdt; then bootz ${loadaddr} - ${fdt_addr}; else if test ${boot_fdt} = try; then bootz; else echo WARN: Cannot load the DT; fi; fi; else bootz; fi;
mmcroot=/dev/mmcblk0p2 rw rootwait
netargs=setenv bootargs console=ttymxc0,${baudrate} root=/dev/nfs ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp
netboot=echo Booting from net ...; run netargs; if test ${ip_dyn} = yes; then setenv get_cmd dhcp; else setenv get_cmd tftp; fi; ${get_cmd} ${image}; if test ${boot_fdt} = yes ||  test ${boot_fdt} = try; then if ${get_cmd} ${fdt_addr} ${fdt_file}; then bootz ${loadaddr} - ${fdt_addr}; else if test ${boot_fdt} = try; then bootz; else echo ERROR: Cannot load the DT; exit; fi; fi; else bootz; fi;

Environment size: 1549/8188 bytes
=> ls mmc ${mmcdev}:${mmcpart} /
 17385125   initrd.gz
     1575   boot.scr
  4260352   vmlinuz

3 file(s), 1 dir(s)
=> bdinfo
arch_number = 0x00000cc9
boot_params = 0x70000100
DRAM bank   = 0x00000000
-> start    = 0x70000000
-> size     = 0x20000000
DRAM bank   = 0x00000001
-> start    = 0xb0000000
-> size     = 0x20000000
eth0name    = FEC
ethaddr     = 00:04:9f:02:3e:73
current eth = FEC
ip_addr     = <NULL>
baudrate    = 115200 bps
TLB addr    = 0x8fff0000
relocaddr   = 0x8ff6c000
reloc off   = 0x1876c000
irq_sp      = 0x8f569eb0
sp start    = 0x8f569ea0
FB base     = 0x8f56c900

Also I mounted "partition.img" on my computer:

 % sudo losetup --show --find --partscan partition.img
 % sudo mount /dev/loop0 /mnt/imx53 
 % file /mnt/imx53/*       
/mnt/imx53/boot.scr:  u-boot legacy uImage, , Linux/ARM, Script File (gzip), 1511 bytes, Mon May 11 17:46:03 2020, Load Address: 0x00000000, Entry Point: 0x00000000, Header CRC: 0x79006BD0, Data CRC: 0x8734369F
/mnt/imx53/dtbs:      directory
/mnt/imx53/initrd.gz: gzip compressed data, max compression, from Unix, original size modulo 2^32 46077952
/mnt/imx53/vmlinuz:   Linux kernel ARM boot executable zImage (little-endian)
 % file /mnt/imx53/dtbs/imx53-qsrb.dtb
/mnt/imx53/dtbs/imx53-qsrb.dtb: Device Tree Blob version 17, size=21932, boot CPU=0, string block size=1236, DT structure block size=20640
 % strings /mnt/imx53/boot.scr
# Bootscript using the new unified bootcmd handling
# introduced with u-boot v2014.10
if test -n "${boot_targets}"; then
  echo "Mainline u-boot / new-style environment detected."
  echo "Non-mainline u-boot or old-style mainline u-boot detected."
  echo "This boot script uses the unified bootcmd handling of mainline"
  echo "u-boot >=v2014.10, which is not available on your system."
  echo "Please boot the installer manually."
  exit 0
if test -z "${fdtfile}"; then
  echo 'fdtfile environment variable not set. Aborting boot process.'
  exit 0
if test -n "${distro_bootpart}"; then
  setenv partition "${distro_bootpart}"
  setenv partition "${bootpart}"
if test ! -e ${devtype} ${devnum}:${partition} dtbs/${fdtfile}; then
  echo "This installer medium does not contain a suitable device-tree file for"
  echo "this system (${fdtfile}). Aborting boot process."
  exit 0
# Some i.MX6-based systems do not encode the baudrate in the console variable
if test "${console}" = "ttymxc0" && test -n "${baudrate}"; then
  setenv console "${console},${baudrate}"
if test -n "${console}"; then
  setenv bootargs "${bootargs} console=${console}"
load ${devtype} ${devnum}:${partition} ${kernel_addr_r} vmlinuz \
&& load ${devtype} ${devnum}:${partition} ${fdt_addr_r} dtbs/${fdtfile} \
&& load ${devtype} ${devnum}:${partition} ${ramdisk_addr_r} initrd.gz \
&& echo "Booting the Devuan installer..." \
&& bootz ${kernel_addr_r} ${ramdisk_addr_r}:${filesize} ${fdt_addr_r}

I wrote image to SD card:

 % sudo dd of=/dev/sdb if=complete_image.img bs=4M status=progress 
71303168 bytes (71 MB, 68 MiB) copied, 1 s, 66,8 MB/s
24+1 records in
24+1 records out
102400000 bytes (102 MB, 98 MiB) copied, 18,5083 s, 5,5 MB/s
The problem

I powered on my "i.MX53 Quick Start board" with SD card with Devuan installer:

U-Boot 2019.01+dfsg-7 (May 14 2019 - 02:07:44 +0000)

CPU:   Freescale i.MX53 rev2.1 at 800 MHz
Reset cause: POR
Board: MX53 LOCO
I2C:   ready
DRAM:  1 GiB
Loading Environment from MMC... *** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   FEC
Hit any key to stop autoboot:  0 
switch to partitions #0, OK
mmc0 is current device
1575 bytes read in 21 ms (73.2 KiB/s)
Running bootscript from mmc ...
## Executing script at 72000000
Non-mainline u-boot or old-style mainline u-boot detected.
This boot script uses the unified bootcmd handling of mainline
u-boot >=v2014.10, which is not available on your system.
Please boot the installer manually.

As I understand, "Warning - bad CRC, using default environment" is OK.

U-Boot not installed inside board, it run from SD-card, from Devuan file "firmware.MX53LOCO.img".
The file "boot.scr" also came with Devuan image, "partition.img".
But they don't want to work together.

Any ideas how to fix error "Please boot the installer manually"?


#2 2020-05-31 11:22:13

From: Wrocław, Poland
Registered: 2020-05-31
Posts: 13  

Re: Devuan installer can't start on MX53 Loco (i.MX53 Quick Start board)

Installer started after some manipulations (I'm not sure about addresses, especially kernel_addr_r=0x70008000):

=> setenv distro_bootpart ${mmcpart}
=> printenv distro_bootpart         
=> setenv boot_targets mmc
=> printenv boot_targets
=> setenv fdtfile ${fdt_file}
=> printenv fdtfile
=> setenv bootpart ${mmcpart}
=> printenv bootpart
=> setenv devnum ${mmcdev}
=> printenv devnum
=> setenv console ttymxc0
=> printenv console
=> setenv devtype mmc
=> printenv devtype  
=> setenv fdt_addr_r ${fdt_addr}
=> printenv fdt_addr_r                                    
=> setenv ramdisk_addr_r ${loadaddr}
=> printenv ramdisk_addr_r          
=> setenv kernel_addr_r 0x70008000
=> printenv kernel_addr_r
=> boot


#3 2020-05-31 13:08:53

From: Wrocław, Poland
Registered: 2020-05-31
Posts: 13  

Re: Devuan installer can't start on MX53 Loco (i.MX53 Quick Start board)

Problem 2: ISO image

What have I do here?

[            (1*installer)  2 shell  3 shell  4- log           ][ Jan 01  0:02 ]
   ┌─────────┤ [!!] Scan hard drives for an installer ISO image ├──────────┐    
   │                                                                       │    
   │                 Failed to find an installer ISO image                 │    
   │ No installer ISO images were found. If you downloaded the ISO image,  │    
   │ it may have a bad filename (not ending in ".iso"), or it may be on a  │    
   │ file system that could not be mounted.                                │    
   │                                                                       │    
   │ You'll have to use an alternative installation method, select another │    
   │ device to look for ISO image, or try again after you've fixed it.     │    
   │                                                                       │    
   │     <Go Back>                                          <Continue>     │    
   │                                                                       │    
<Tab> moves; <Space> selects; <Enter> activates buttons                         

Which ISO image to use? I tried … t/mini.iso — it is too small, only 33MB, and error is the same.


#4 2020-05-31 20:03:24

Registered: 2019-11-14
Posts: 183  

Re: Devuan installer can't start on MX53 Loco (i.MX53 Quick Start board)

hello vazhnov,
For what I see it seems that you had done it correctly,
But the hd-media type expects a different image type( with the contents of installation.. ) sad

I advise you to go with the netboot-install version,
Since the media image comes from the repos, and its usually the method less prone to errors..

I believe you have followed this instructions:
when dd'íng the image use a 'conv=sync'..

In that url, you will find Installable netboot Images, go to the correct place, and download the correct ones for you.. … ard-images smile

Last edited by tuxd3v (2020-06-05 04:09:38)

Best Regards,


Board footer