The officially official Devuan Forum!

You are not logged in.

#1 2019-07-03 14:09:26

kigen
Member
Registered: 2017-05-05
Posts: 2  

[SOLVED] Enable touchpad on LXQT

Hi, I have installed ASCII 2.0, LXQT desktop environment: there is not a touchpad enabled. I have downloaded xorg synaptic drivers but in gui preferences there is only mouse option and not touchpad. Is there a solution? Thanks

Last edited by kigen (2019-07-03 19:48:55)

Offline

#2 2019-07-03 15:36:15

dxrobertson
Member
Registered: 2017-05-04
Posts: 232  

Re: [SOLVED] Enable touchpad on LXQT

I think the root cause of this is the use of libinput, as opposed to synaptics.  Here is some info from Ubuntu:

https://askubuntu.com/questions/1031940 … untu-18-04

Sounds like you already installed xserver-xorg-input-synaptics, as they suggest.  I think you have to adjust the touchpad via synaptics/xorg conf files, as I dont believe LXQT Keyboard and Mouse provide a gui for touchpad.

Offline

#3 2019-07-03 18:40:28

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 340  
Website

Re: [SOLVED] Enable touchpad on LXQT

@OP: do you have xserver-xorg-input-evdev installed?

What does this say

synclient

Check the TouchPadOff value.

Also check

xinput --list

And use this for the touchpad device ID:

xinput --list-props $ID

For configuration copy the template file from /usr/share/X11/xorg.conf.d/70-synaptics.conf to /etc/X11/xorg.conf.d/70-synaptics.conf and add the desired options as per synaptics(4).


Fabricando fit faber

Offline

#4 2019-07-03 19:44:49

kigen
Member
Registered: 2017-05-05
Posts: 2  

Re: [SOLVED] Enable touchpad on LXQT

Now it works after typing this on terminal: synclient TapButton1=1 TapButton2=3 TapButton3=2
thanks all

Offline

Board footer