The officially official Devuan Forum!

You are not logged in.

#1 2019-05-23 21:26:59

Registered: 2017-05-07
Posts: 279  

[Solved] update-initramfs problem


For reasons long to explain, I had to transplant the HDD with a working Devuan installaiton in my 1000HE to another (presumably identical) 1000HE.

It had the original BIOS from purchase date which for some reason, had no AHCI option, so my Devuan installation would fail to boot as it was loading the AHCI modules.

So I updated the new 1000HE's BIOS to the same version but it seems that there's some difference in the hardware as this new BIOS does not have an AHCI option either.
It's exactly the same BIOS file that my original 1000HE has so it is probably a difference in the hardware.
But I'll only know for sure once I can boot it.  =-/

So, as I did once with the original 1000HE, I booted a netinstall DVD, entered 'rescue mode', opened a shell in the installation's root directory and made the necessary changes in /etc/initramfs-tools/modules and /etc/initramfs-tools/initramfs.conf.


Once done, I ran update-initramfs -u.

It should have ended there but no ...

Instead I get this:

# update-initramfs -u 
ls: cannot access '/var/lib/initramfs-tools': no such file or directory
update-initramfs: /boot/initrd.img-4.9.0-9-686-pae has been altered.
update-initramfs: Cannot update. Override with -t option.

I've tried -u -t and -t -k all -c to no avail as all give errors.

Any one can point to a solution to this?

Thanks in advance.


Last edited by Altoid (2019-05-24 19:12:06)


#2 2019-05-24 09:16:34

Registered: 2019-03-11
Posts: 146  

Re: [Solved] update-initramfs problem

First of all the laptop no BIOS at all. It has UEFI. As far as i know AHCI mode is enabled by default.
I don't know what is the problem because you just have to swap HDD to boot installed Devuan. No rescue operations are needed.


#3 2019-05-24 11:55:42

Registered: 2017-05-07
Posts: 279  

Re: [Solved] update-initramfs problem


ToxicExMachina wrote:

... laptop no BIOS at all.
... AHCI mode is enabled by default.

Hmm ...

The Asus 1000HE netbook does have a BIOS.
And it does not come enabled by default, you have to set it in the BIOS.

At least that is the case with the two I have at home and with a couple of others that I have worked on.
Maybe later production runs changed?

Could be, but I have seen no mention of Asus 1000 series eeepcs with UEFI on the web.


Just in case someone else needs it, the only version of the Asus Firmware Upgrade utility that I found which was compatible with the 1000HE's motherboard was AFU236U.exe.
It runs under plain DOS.

Newer versions threw an error:

Error: BIOS Does not support AFU


Last night I discovered that the lack of the AHCI option in the BIOS is not a hardware issue but related to some trigger-bit in the firmware.
It is there, but for some reason and although you'd be using the same BIOS file (1000HE.ROM) some machine's BIOS reveal it but others do not.

I have not found out why but the solution to the issue is to use a modified 1000HE BIOS file.

See here: … 1#pid26441

With respect to the problem with <c>update-initramfs</c>, apparently it is a bug from 2017.
I say apparently because I can't say it has to do with what was happening to me.
In any case, the solution was in this post: … comments/2

You have to create the missing directory: mkdir /var/lib/initramfs-tools and then when/if update-initramfs bitches about not finding /tmp/initramfs-tools, create that one too.
Then it works as advertised.

It took me a while to figure it out how to do it because while working as what I thought was root (because #) with full privileges, I was denied access to do mkdir. I had to su myself to be able to work in the root environment and be able to carry out the mkdir commands.

Thanks for your input.



Last edited by Altoid (2019-05-27 00:29:31)


Board footer