The officially official Devuan Forum!

You are not logged in.

#1 2017-08-01 22:51:41

From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,177  

Laptop not sleeping

This is a quick note that might help someone, although I haven't worked out the proper solution yet.

The deal is that recently my laptop stopped suspending properly. It suspends on closing the lid, but then immediately wakes up. It has Jessie installed since beta, then occasionally upgraded, and it has linux-image-4.9.0-0.bpo.2-amd64 from jessie-backports installed.

Eventually I worked out that apparently it is the xhci_pci module that gets a phantom signal from somewhere, and wakes up the system. I believe the module handles USB transport (esp. 3.0), and it is brought in when I plug in a USB stick.

So, my laptop is sleeping fine until I plug one in, and thereafter it keeps bouncing up, refusing to sleep, until I unload that  module.

Perhaps there's some module option to avoid the misbehaviour. I'll add an edit here if I find something.

EDIT 1: I've realized this to be an age old problem, though ascribed to the xhci_hcd module rather.

EDIT 2: See which suggests the fix of having

options xhci-hcd quirks=270336

in an /etc/modprobe.d/ file, so as to make the module load with that parameter. I'll try that for a while...


Board footer