The officially official Devuan Forum!

You are not logged in.

#1 2020-12-16 18:32:18

nobodyuknow
Member
Registered: 2017-09-10
Posts: 94  

PulseAudio always resets to mute

The release notes state that it is necessary to comment "autospawn=no" in /etc/pulse/client.conf.d/00-disable-autospawn.conf. Okay, that allows for sound. But there's still a minor bug. I think it happens with every boot, but it might be something a little more subtle, perhaps it happens on the first boot of a day. The volume slider is set all the way to the left, so there is no sound. It's simple to fix, just move the slider to the right, but why doesn't it retain the previous setting?

P.S. In case it matters, this is Cinnamon.

Last edited by nobodyuknow (2020-12-16 18:32:44)

Offline

#2 2020-12-16 19:14:41

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,088  

Re: PulseAudio always resets to mute

I don't know if this will work, but there are a couple of things you can try...

1. Open a terminal, and enter alsamixer. If it opens in the terminal, use your arrow keys to move to the right until Automute is highlighted. Then press the down arrow to disable it.

You may have to choose your sound card first by pressing F6...

If alsamixer isn't working on your system, then you can try...

2. When you first boot your computer up...BEFORE adjusting the volume on the panel, open Pavucontrol. Go to Output Devices. If the volume icon is highlighted (muted), press it to unmute it. THEN move the slider beneath it.

Both of those options have always worked for me, but I'm unfamiliar with Cinnamon.

Good luck

Last edited by MiyoLinux (2020-12-16 19:18:42)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#3 2020-12-17 18:01:11

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,549  
Website

Re: PulseAudio always resets to mute

Is the alsa-utils package installed? If so then make sure that the /etc/init.d/alsa-utils init script is enabled — that should save the audio level on shutdown and restore it when the machine is booted again.


Black Lives Matter

Offline

#4 2020-12-17 21:28:17

Pix3l
Member
Registered: 2019-03-25
Posts: 7  

Re: PulseAudio always resets to mute

Since I switched to devuan 3, I also experienced this issue, at every startup I need to manually start pulseaudio everytime to make firefox audible.

pulseaudio --start -v

Sick of this, I recompiled the latest version of pulseaudio from source (without systemd support by configure options), and the mute problem (on firefox) solved itself.

This issue was not present in the package for devuan 2, I think the new one is somekind of broken...

Offline

#5 2020-12-18 20:37:50

nobodyuknow
Member
Registered: 2017-09-10
Posts: 94  

Re: PulseAudio always resets to mute

@MiyoLinux @Head_on_a_Stick @Pix3l Thanks for the replies.

The problem is global (if that's the right word), as the taskbar volume control is set to zero.

alsa-utils is installed. And I'm not sure what you mean by /etc/init.d/alsa-utils init script being enabled. It's got executable permissions and the contents are not commented out.

Pix3l is correct, the problem was not present before.

Offline

#6 2020-12-18 21:46:48

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,088  

Re: PulseAudio always resets to mute

Well, the directions that I gave always does away with the global automate on startup for me. Good luck.


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#7 2020-12-18 22:41:22

Pix3l
Member
Registered: 2019-03-25
Posts: 7  

Re: PulseAudio always resets to mute

I inspected the devuan 2 and 3 pulseaudio packages, to see how the differs, but apart from some additions in configuration files, I don't see any change in default options.
Also the /etc/xdg/autostart/pulseaudio.desktop, that I think should start automatically the daemon, is there without any differences.

I think the main problem can be the daemon binary itself, and for test I recompiled it from source (14.0), there are also options to avoid systemd entirely, along others things:

--disable-systemd-daemon  --disable-systemd-login  --disable-systemd-journal

The original devaun packages includes some systemd services file under /usr/lib/systemd anyway.

After that, everything work without any problem, pulseaudio starts automatically at every boot.

Offline

#8 2020-12-18 23:21:35

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,549  
Website

Re: PulseAudio always resets to mute

@Pix3l: please read the beowulf release notes, the answer you seek is there. Your posts in this thread are off topic.

@Miyo: the automute setting in alsamixer refers to headphones and is not related to the issue described in the OP.

@OP: use sysv-rc-conf to check which services are enabled.


Black Lives Matter

Offline

#9 2020-12-18 23:59:51

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,088  

Re: PulseAudio always resets to mute

I guess that's why it works for me. I only use speakers that plug into my headphone jack. Hahaha!

Carry on. I'll be quiet now. big_smile


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#10 2020-12-19 00:21:46

Pix3l
Member
Registered: 2019-03-25
Posts: 7  

Re: PulseAudio always resets to mute

Head_on_a_Stick wrote:

@Pix3l: please read the beowulf release notes, the answer you seek is there. Your posts in this thread are off topic.

I think it's inherent, since I try to help it to fix the problem and provide my experiences.

From devuan 2 to 3, this packages seems to went somekind of broken (like many others as I experienced).
The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is not part of the deb package, it's generated by pulseaudio, and even by uncommenting or set to true autospawn, I experienced the same problems.

So, the solution for me was to switch to a next release, and solved...
That's all.

Offline

#11 2020-12-19 01:16:48

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 51  
Website

Re: PulseAudio always resets to mute

Pix3l wrote:

The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is not part of the deb package, it's generated by pulseaudio, and even by uncommenting or set to true autospawn, I experienced the same problems.

The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is inherit to the package. Uncompress the debian folder and you'll find it there.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#12 2020-12-19 11:06:42

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,549  
Website

Re: PulseAudio always resets to mute

Pix3l wrote:

I think it's inherent, since I try to help it to fix the problem and provide my experiences.

Please read the first two sentences of the first post in this thread. The OP has already fixed the problem you are experiencing and so does not need your help.

Pix3l wrote:

The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is not part of the deb package

That file is supplied by the libpulse0 package:

dpkg -L libpulse0 | grep autospawn

Or:

$ dpkg -S /etc/pulse/client.conf.d/00-disable-autospawn.conf 
libpulse0:amd64: /etc/pulse/client.conf.d/00-disable-autospawn.conf
$

Last edited by Head_on_a_Stick (2020-12-19 11:11:41)


Black Lives Matter

Offline

#13 2021-02-14 12:59:08

MLEvD
Member
Registered: 2021-02-14
Posts: 77  

Re: PulseAudio always resets to mute

Hello my vems, my tvvo cents

Devuan ascii - audio fine
Devuan Beowulf - DATA LOSS

User settings are data, and data loss of any kind is unacceptable

Offline

#14 2021-02-14 13:31:18

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,849  

Re: PulseAudio always resets to mute

Another solution (new in devuan 3.1.0 point-release.)

Install debian-pulseaudio-config-override
Description: Debian configuration overrides for pulseaudio

You'll get this automatically if you install a desktop environment from the 3.1.0 installer isos.
(task-desktop Recommends debian-pulseaudio-config-override)

Offline

#15 2021-02-16 05:58:41

MLEvD
Member
Registered: 2021-02-14
Posts: 77  

Re: PulseAudio always resets to mute

That did not work.
To reproduce:
Devuan 3.0 or 3.1 mate D.E.

Mate Media installed. Right click sound icon and choose 'Sound Preferences'

Change a setting for input or output device. I like to change input from 'duplex' to 'output only'

On reboot these user sound preference settings are lost.

This is unacceptable.

problem occurs under both sysv and runit

Last edited by MLEvD (2021-02-16 06:00:52)

Offline

#16 2021-02-16 07:32:07

Danielsan
Member
Registered: 2020-07-14
Posts: 70  

Re: PulseAudio always resets to mute

MLEvD wrote:

This is unacceptable.

Unacceptable is your behavior. Did you pay anything for using Devuan that made you believe that having a bug is unacceptable?

Anyway these kind of issues are usually in the .xsession-errors file in your homes, maybe you can find there what is preventing to save your preferences.

Last edited by Danielsan (2021-02-16 07:32:31)

Offline

#17 2021-02-16 09:48:35

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 543  

Re: PulseAudio always resets to mute

Here's a gratuitous web search result https://www.mycomputertips.co.uk/213
Iit's for Ubuntu but probably works here as well.

The suggestion is to

  • determine the label (XXX)  for the "active profile" by looking for that entry in the pulsaudio configuration file

  • then edit /etc/pulse/default.pa, to add a line like set-card-profile 1 XXX to it

  • and then restart pulsaudio

Probably not ideal for a pointy-clicky minded user.

Online

#18 2021-02-16 12:38:02

MLEvD
Member
Registered: 2021-02-14
Posts: 77  

Re: PulseAudio always resets to mute

Free, in this sense, does not mean it does not cost anyone anything.

We all pay and reporting bugs is acceptable. Rudeness is not, for which I apologise, if that's how it was taken?

Boris Beizer would turn in his grave, notwithstanding his cat.

Tell me, which of your user settings are you happy to have lost, if sound preferences are not important to you?

Heaven forbid your evening goes wrong because your audio comes out of the tv speakers via the hdmi rather than out of the decent stereo via the headphone jack or other networked device.

Just tried it again then looked in .xsessionerrors and sadly there's nothing there to help me. Thank you and if you have any other suggestions I'm all ears?

In the meantime, can anyone here reproduce this bug? I'm all 32-bit here, can someone try on 64 please?

Last edited by MLEvD (2021-02-16 12:38:54)

Offline

#19 2021-02-16 16:51:21

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,849  

Re: PulseAudio always resets to mute

In the meantime, can anyone here reproduce this bug? I'm all 32-bit here, can someone try on 64 please?

I can confirm that setting to output only is not saved across reboots. Tested amd64 mate in a qemu virtual machine. This happens to be an install with speech synthesis enabled (screen reader) but that probably doesn't matter.

I can also confirm that /etc/pulse/default.pa does not look anything like the one in the mycomputertips help page.

I don't see any bugs about settings not saved, but there are a couple about crashing mate-volume-control (the Sound Preferences app)
https://bugs.debian.org/cgi-bin/pkgrepo … mate-media

I also poked around in ~/.config/pulse and found 141 binary files. No help there.

Offline

#20 2021-02-16 18:11:54

MLEvD
Member
Registered: 2021-02-14
Posts: 77  

Re: PulseAudio always resets to mute

Thanks for that, good to know it's in 64 too, so the other 90% might care!

If it helps, I just removed mate-media and installed pavucontrol. The settings are lost here as well - change from duplex to output only, setting lost on reboot. Perversely happy that pavucontrol isn't the answer, as I don't particularly like it.

I tried mate-volume-control -d but couldn't really make head or tail of it on an 800x600 display.

It's not happening on ascii, or on debian, or anything else that I've got my hands on recently.


Happy to test all night. I built a small wooden stand, pop a frozen meal under it, the eee pc says cool and my supper slowly defrosts.

Offline

#21 2021-02-16 22:07:26

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 543  

Re: PulseAudio always resets to mute

that /etc/pulse/default.pa does not look anything like the one in the mycomputertips help page.

That page shows two files where the first is "the pusleaudio configuration file" .. whatever that is, and towards the bottom the excerpt for /etc/pulse/default.pa.

This issue is down at pulseaudio level and not desktop environment level. Clearly the GUI that lets you alter the configuration should have included something to register the new configuration as persistent over reboot. For pulseaudio that "persistence" is apparently implemented via the "default.pa" file.... or files perhaps, if you can have per-user defaults.

Online

#22 2021-02-17 00:04:02

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,849  

Re: PulseAudio always resets to mute

Ah, I didn't see that. Yeah the actual file is farther down the page. That first screenshot is the output of pacmd list-cards

When I run that command, I get "No PulseAudio daemon running, or not running as a session daemon."  So I can't find what the active profile is to put the line in default.pa

ps ax shows that it's running and that the --start option was used, which should make it run as a daemon. That's what the man page says.

There are a bunch of error messages about pulseaudio in the syslog, but they may be related to settings for the screen reader. They're complaining about a run file for user lightdm. I think I should stop here. It may not be a good comparison.

MLEvD, I hope you have better luck. Are you sure you need pulseaudio? Maybe plain alsa would behave better.

Offline

#23 2021-02-17 00:25:45

GlennW
Member
Registered: 2019-07-18
Posts: 103  

Re: PulseAudio always resets to mute

Head_on_a_Stick wrote:

For those who have laptops with HDMI outputs see this guide for setting the non-HDMI output as the default:

https://wiki.archlinux.org/index.php/Ad … sound_card

I'm using "~/.asoundrc" to personalise my sound config for the user.

Online

#24 2021-02-17 05:19:39

MLEvD
Member
Registered: 2021-02-14
Posts: 77  

Re: PulseAudio always resets to mute

fsmithred wrote:

MLEvD, I hope you have better luck. Are you sure you need pulseaudio? Maybe plain alsa would behave better.

I'm doing sychronised multi-room audio with asus eee pc as receiver boxes. Why not rpi? Because eee pc have screens and input attached, and are dust proof, have cases, are portable (own battery!). In addition to music. They also provide wifi, a digital picture frame/show, and anything else you might do with an 800x600 screen.

I read back at the start that one must use pulse or sndio for this avahi magic, alsa is a one horse town. Hopefully I am wrong?

Hack: I *could* just hack the scripts to enforce defaults and policies, but this is something clearly broken compared to the last version of devuan or the contemporary version of debian, so it's possibly an indication of some wider improvement opportunity in the development sphere. It's a very long time since I was a pro tester so forgive my antiquated language please!

Last edited by MLEvD (2021-02-17 05:20:20)

Offline

#25 2021-02-24 12:32:08

Lord Curzon
Member
Registered: 2021-02-24
Posts: 1  

Re: PulseAudio always resets to mute

I've just installed Devuan Beowulf 3.1 with the Mate desktop and experienced the same issue – the settings are not being saved.  Here's my workaround.

Like me, you might have more than one sink.  Usually, there is only one.  To check, run:

pacmd list-sinks | less

Note the index of the sink that you want to be the default.  Do the same for sources:

pacmd list-sources | less

Make a backup of /etc/pulse/default.pa.  Open the file as root with a text editor, for example:

sudo vi /etc/pulse/default.pa

At the end of the file, there is a two-line option to make some devices default:

### Make some devices default
#set-default-sink output
#set-default-source input

Uncomment the two lines (by deleting the hashes) and set the output to the correct index for the sink and the source.  In my case, it was:

### Make some devices default
set-default-sink 0
set-default-source 0

If you found the output of pacmd hard to interpret, note that there are only two possibilities if you have two sinks (0 and 1), so you can experiment.  I had three sources, so three possibilites: 0, 1, 2.

Devuan's /etc/pulse/default.pa has an option that restores the default sink/source if changed by the user, which might be part of the problem.  I commented it out:

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
#load-module module-default-device-restore

There's a similar option that restores the volume, which you might want to look at.

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

Hope this helps someone else!

Offline

Board footer