The officially official Devuan Forum!

You are not logged in.

#1 2020-12-16 18:32:18

nobodyuknow
Member
Registered: 2017-09-10
Posts: 87  

PulseAudio always resets to mute

The release notes state that it is necessary to comment "autospawn=no" in /etc/pulse/client.conf.d/00-disable-autospawn.conf. Okay, that allows for sound. But there's still a minor bug. I think it happens with every boot, but it might be something a little more subtle, perhaps it happens on the first boot of a day. The volume slider is set all the way to the left, so there is no sound. It's simple to fix, just move the slider to the right, but why doesn't it retain the previous setting?

P.S. In case it matters, this is Cinnamon.

Last edited by nobodyuknow (2020-12-16 18:32:44)

Offline

#2 2020-12-16 19:14:41

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,070  

Re: PulseAudio always resets to mute

I don't know if this will work, but there are a couple of things you can try...

1. Open a terminal, and enter alsamixer. If it opens in the terminal, use your arrow keys to move to the right until Automute is highlighted. Then press the down arrow to disable it.

You may have to choose your sound card first by pressing F6...

If alsamixer isn't working on your system, then you can try...

2. When you first boot your computer up...BEFORE adjusting the volume on the panel, open Pavucontrol. Go to Output Devices. If the volume icon is highlighted (muted), press it to unmute it. THEN move the slider beneath it.

Both of those options have always worked for me, but I'm unfamiliar with Cinnamon.

Good luck

Last edited by MiyoLinux (2020-12-16 19:18:42)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#3 2020-12-17 18:01:11

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,286  
Website

Re: PulseAudio always resets to mute

Is the alsa-utils package installed? If so then make sure that the /etc/init.d/alsa-utils init script is enabled — that should save the audio level on shutdown and restore it when the machine is booted again.


Black Lives Matter

Offline

#4 2020-12-17 21:28:17

Pix3l
Member
Registered: 2019-03-25
Posts: 7  

Re: PulseAudio always resets to mute

Since I switched to devuan 3, I also experienced this issue, at every startup I need to manually start pulseaudio everytime to make firefox audible.

pulseaudio --start -v

Sick of this, I recompiled the latest version of pulseaudio from source (without systemd support by configure options), and the mute problem (on firefox) solved itself.

This issue was not present in the package for devuan 2, I think the new one is somekind of broken...

Offline

#5 2020-12-18 20:37:50

nobodyuknow
Member
Registered: 2017-09-10
Posts: 87  

Re: PulseAudio always resets to mute

@MiyoLinux @Head_on_a_Stick @Pix3l Thanks for the replies.

The problem is global (if that's the right word), as the taskbar volume control is set to zero.

alsa-utils is installed. And I'm not sure what you mean by /etc/init.d/alsa-utils init script being enabled. It's got executable permissions and the contents are not commented out.

Pix3l is correct, the problem was not present before.

Offline

#6 2020-12-18 21:46:48

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,070  

Re: PulseAudio always resets to mute

Well, the directions that I gave always does away with the global automate on startup for me. Good luck.


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#7 2020-12-18 22:41:22

Pix3l
Member
Registered: 2019-03-25
Posts: 7  

Re: PulseAudio always resets to mute

I inspected the devuan 2 and 3 pulseaudio packages, to see how the differs, but apart from some additions in configuration files, I don't see any change in default options.
Also the /etc/xdg/autostart/pulseaudio.desktop, that I think should start automatically the daemon, is there without any differences.

I think the main problem can be the daemon binary itself, and for test I recompiled it from source (14.0), there are also options to avoid systemd entirely, along others things:

--disable-systemd-daemon  --disable-systemd-login  --disable-systemd-journal

The original devaun packages includes some systemd services file under /usr/lib/systemd anyway.

After that, everything work without any problem, pulseaudio starts automatically at every boot.

Offline

#8 2020-12-18 23:21:35

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,286  
Website

Re: PulseAudio always resets to mute

@Pix3l: please read the beowulf release notes, the answer you seek is there. Your posts in this thread are off topic.

@Miyo: the automute setting in alsamixer refers to headphones and is not related to the issue described in the OP.

@OP: use sysv-rc-conf to check which services are enabled.


Black Lives Matter

Offline

#9 2020-12-18 23:59:51

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,070  

Re: PulseAudio always resets to mute

I guess that's why it works for me. I only use speakers that plug into my headphone jack. Hahaha!

Carry on. I'll be quiet now. big_smile


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#10 2020-12-19 00:21:46

Pix3l
Member
Registered: 2019-03-25
Posts: 7  

Re: PulseAudio always resets to mute

Head_on_a_Stick wrote:

@Pix3l: please read the beowulf release notes, the answer you seek is there. Your posts in this thread are off topic.

I think it's inherent, since I try to help it to fix the problem and provide my experiences.

From devuan 2 to 3, this packages seems to went somekind of broken (like many others as I experienced).
The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is not part of the deb package, it's generated by pulseaudio, and even by uncommenting or set to true autospawn, I experienced the same problems.

So, the solution for me was to switch to a next release, and solved...
That's all.

Offline

#11 2020-12-19 01:16:48

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 45  
Website

Re: PulseAudio always resets to mute

Pix3l wrote:

The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is not part of the deb package, it's generated by pulseaudio, and even by uncommenting or set to true autospawn, I experienced the same problems.

The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is inherit to the package. Uncompress the debian folder and you'll find it there.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#12 2020-12-19 11:06:42

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,286  
Website

Re: PulseAudio always resets to mute

Pix3l wrote:

I think it's inherent, since I try to help it to fix the problem and provide my experiences.

Please read the first two sentences of the first post in this thread. The OP has already fixed the problem you are experiencing and so does not need your help.

Pix3l wrote:

The file /etc/pulse/client.conf.d/00-disable-autospawn.conf is not part of the deb package

That file is supplied by the libpulse0 package:

dpkg -L libpulse0 | grep autospawn

Or:

$ dpkg -S /etc/pulse/client.conf.d/00-disable-autospawn.conf 
libpulse0:amd64: /etc/pulse/client.conf.d/00-disable-autospawn.conf
$

Last edited by Head_on_a_Stick (2020-12-19 11:11:41)


Black Lives Matter

Offline

Board footer