The officially official Devuan Forum!

You are not logged in.

#26 2020-07-01 20:30:20

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

rolfie wrote:

My first candidate for removal would be the libboost-packages, then the util-linux from ASCII.

rolfie

Hi Rolfie,

I have noticed that you have the libdatetime-locale-perl, liblocale-gettext-perl and locales installed but I don't.

Are you suggesting that I remove the libboost-locale1.62.0, libboost-locale1.67.0 and util-linux-locales packages before attending to the removal of the dmo packages?

The only package I have installed that has libboost-locale1.62.0 as a Dependency is aegisub which is one of the dmo packages I have installed.


I'm not sure I can remove util-linux-locales as util-linux depends on it according to the following output.

apt-cache rdepends util-linux-locales
util-linux-locales
Reverse Depends:
  task-brazilian-portuguese
  util-linux
  task-turkish
  task-swedish
  task-spanish
  task-romanian
  task-polish
  task-norwegian
  task-galician
  task-french
  task-english
  task-danish
  task-czech
  task-catalan

 
However, the following output says that util-linux-locales is a Suggestion for util-linux. None of the task-* packages are installed.

dpkg -s util-linux
Package: util-linux
Essential: yes
Status: install ok installed
Priority: required
Section: utils
Installed-Size: 4589
Maintainer: Daniel Reurich <daniel@centurion.net.nz>
Architecture: amd64
Multi-Arch: foreign
Version: 2.33.1-0.1+devuan1~beowulf2
Replaces: bash-completion (<< 1:2.8), initscripts (<< 2.88dsf-59.2~), login (<< 1:4.5-1.1~), mount (<< 2.29.2-3~), s390-tools (<< 2.2.0-1~), setpriv (<< 2.32.1-0.2~), sysvinit-utils (<< 2.88dsf-59.1~)
Depends: fdisk, login (>= 1:4.5-1.1~)
Pre-Depends: libaudit1 (>= 1:2.2.1), libblkid1 (>= 2.31.1), libc6 (>= 2.25), libcap-ng0 (>= 0.7.9), libeudev1, libmount1 (>= 2.25), libpam0g (>= 0.99.7.1), libselinux1 (>= 2.6-3~), libsmartcols1 (>= 2.33), libtinfo6 (>= 6), libuuid1 (>= 2.16), zlib1g (>= 1:1.1.4)
Suggests: dosfstools, kbd | console-tools, util-linux-locales
Breaks: bash-completion (<< 1:2.8), grml-debootstrap (<< 0.68), mount (<< 2.29.2-3~), s390-tools (<< 2.2.0-1~), setpriv (<< 2.32.1-0.2~), sysvinit-utils (<< 2.88dsf-59.4~)
Conffiles:
 /etc/default/hwclock 3916544450533eca69131f894db0ca12
 /etc/init.d/hwclock.sh 1ca5c0743fa797ffa364db95bb8d8d8e
 /etc/pam.d/runuser b8b44b045259525e0fae9e38fdb2aeeb
 /etc/pam.d/runuser-l da714d1ef1b85471f3bb1a83daa7a88b
 /etc/pam.d/su ce6dcfda3b190a27a455bb38a45ff34a
 /etc/pam.d/su-l 756fef5687fecc0d986e5951427b0c4f
Description: miscellaneous system utilities
 This package contains a number of important utilities, most of which
 are oriented towards maintenance of your system. Some of the more
 important utilities included in this package allow you to view kernel
 messages, create new filesystems, view block device information,
 interface with real time clock, etc.

It looks like I should have locales installed. Should I do that after removing the libboost-locale1.62.0 and libboost-locale1.67.0 packages and perhaps the util-linux-locales package before removing the dmo packages?

Thanks!!, MTB.

Offline

#27 2020-07-01 20:32:28

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Head_on_a_Stick wrote:

Have you tried

# apt reinstall locales
# dpkg-reconfigure locales

Hi HoaS,

I just posted a response to Rolfie.

I just ran ls | grep locale on /var/cache/apt/archives which produced the following output.


krb5-locales_1.17-3_all.deb
libboost-locale1.62.0_1.62.0+dfsg-4_amd64.deb
libboost-locale1.67.0_1.67.0-13+deb10u1_amd64.deb
liblocale-gettext-perl_1.07-3+b4_amd64.deb
locales_2.24-11+deb9u4_all.deb
locales_2.28-10_all.deb
util-linux-locales_2.33.1-0.1+devuan1~beowulf2_all.deb

So after Rolfie's post (#28), I ran apt reinstall locales which produced the following output.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-gl1.0-0 (>= 1.14.0) but it is not going to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I ran apt --fix-broken install which produced the following output.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  cheese-common evolution-data-server evolution-data-server-common folks-common gir1.2-gdesktopenums-3.0 gir1.2-gnomedesktop-3.0 gjs
  gnome-contacts gstreamer1.0-clutter-3.0 gstreamer1.0-nice hp-ppd libapparmor-perl libass5 libavahi-gobject0 libbdplus0 libblas-common
  libboost-date-time1.62.0 libboost-iostreams1.62.0 libcamel-1.2-59 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk25 libcheese8
  libclutter-gst-3.0-0 libcryptui0a libebackend-1.2-10 libebook-1.2-16 libebook-contacts-1.2-2 libebur128-1 libecal-1.2-19
  libedata-book-1.2-25 libedata-cal-1.2-28 libedataserver-1.2-22 libedataserverui-1.2-1 libelogind0 libevent-2.0-5 libfarstream-0.2-5
  libfile-copy-recursive-perl libfolks-eds25 libfolks-telepathy25 libfolks25 libgadu3 libgail-3-0 libgcj-bc libgcr-3-common libgee-0.8-2
  libgeocode-glib0 libgfortran3 libgltf-0.0-0v5 libgnome-autoar-0-0 libgnome-autoar-common libgnome-autoar-gtk-0-0 libgphoto2-l10n
  libgraphicsmagick-q16-3 libgssdp-1.0-3 libgtkimageview0 libgtkspell3-3-0 libgupnp-1.0-4 libgupnp-igd-1.0-4 libgutenprint2 libgweather-3-6
  libgweather-common libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libkf5dbusaddons-bin libkf5iconthemes-bin libmeanwhile1
  libmission-control-plugins0 libnice10 libnm-glib4 libnm-util2 libopenmpt-modplug1 liborcus-0.11-0 libperl5.24 libphonenumber7 libprotobuf-c1
  libpst4 libpurple-bin libpurple0 libpython-all-dev libpython3.5-dev libqpdf17 libre2-3 librpm3 librpmbuild3 librpmio3 librpmsign3
  libsac-java-gcj libsane-extras libsane-extras-common libsdl-image1.2 libtelepathy-farstream3 libtelepathy-glib0 libtelepathy-logger3
  libtxc-dxtn-s2tc libwacom-bin libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libx264-148 libx265-95 libxine2-doc libxpp2-java libytnef0 libzephyr4
  linux-image-4.9.0-6-amd64 linux-image-4.9.0-8-amd64 mjpegtools-gtk pidgin-data python-all python-all-dev python3.5-dev qpdf rename seahorse
  seahorse-daemon sonnet-plugins task-print-server tcpd telepathy-gabble telepathy-haze telepathy-logger telepathy-mission-control-5
  telepathy-salut x11proto-dri2-dev x11proto-gl-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gstreamer1.0-gl libgstreamer-gl1.0-0
The following NEW packages will be installed:
  gstreamer1.0-gl libgstreamer-gl1.0-0
0 upgraded, 2 newly installed, 0 to remove and 1074 not upgraded.
1071 not fully installed or removed.
Need to get 0 B/2,643 kB of archives.
After this operation, 3,204 kB of additional disk space will be used.
Do you want to continue? [Y/n]

I responded like so Do you want to continue? [Y/n] Y which produced the following output.

(Reading database ... 432358 files and directories currently installed.)
Preparing to unpack .../libgstreamer-gl1.0-0_1.14.4-2_amd64.deb ...
Unpacking libgstreamer-gl1.0-0:amd64 (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libgstgl-1.0.so.0', which is also in package libgstreamer-plugins-bad1.0-0:amd64 1:1.10.4-dmo2
Preparing to unpack .../gstreamer1.0-gl_1.14.4-2_amd64.deb ...
Unpacking gstreamer1.0-gl:amd64 (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstopengl.so', which is also in package gstreamer1.0-plugins-bad:amd64 1:1.10.4-dmo2
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_amd64.deb
 /var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks !!, MTB.

Last edited by mtbvfr (2020-07-02 01:40:16)

Offline

#28 2020-07-01 20:52:23

rolfie
Member
Registered: 2017-11-25
Posts: 429  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

My background: Beowulf installed from scratch, German setup and locale, works fine the way it is, menus ... all in German. My Beowulf is clean....

Based on this:
1.) Give HOAS proposal a try. You can't loose anything but your problem. When that fixes your locale problem you are done so far.
2.) If it doesn't, try to remove the extra stuff vs my post one by one. Play it carefully with simulating with apt -s remove what the consequences are before executing without -s. If in doubt, ask here again with what you got as output.
3.) Repeat HOAS proposal.

Good luck, rolfie

Online

#29 2020-07-04 02:24:13

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi Folks,

I attempted the following.

aptitude -P remove gstreamer1.0-plugins-bad
[ ERR] Reading state information
E: Could not open lock file /var/lock/aptitude - open (2: No such file or directory)
E: Could not initialize dependency cache
W: Could not lock the cache file; this usually means that dpkg or another apt tool is already installing packages.  Opening in read-only mode; any changes you make to the states of packages will NOT be preserved!
The following packages will be REMOVED:
  cheese-common{u} evolution-data-server{u} evolution-data-server-common{u} folks-common{u} freepats{u} 
  gir1.2-gdesktopenums-3.0{u} gir1.2-gnomedesktop-3.0{u} gjs{u} gnome-contacts{u} gstreamer1.0-clutter-3.0{u} 
  gstreamer1.0-nice{u} gstreamer1.0-plugins-bad hp-ppd{u} libapparmor-perl{u} libass5{u} libavahi-gobject0{u} 
  libbdplus0{u} libblas-common{u} libboost-date-time1.62.0{u} libboost-iostreams1.62.0{u} libcamel-1.2-59{u} 
  libchamplain-0.12-0{u} libchamplain-gtk-0.12-0{u} libcheese-gtk25{u} libcheese8{u} libclutter-gst-3.0-0{u} 
  libcryptui0a{u} libebackend-1.2-10{u} libebook-1.2-16{u} libebook-contacts-1.2-2{u} libebur128-1{u} libecal-1.2-19{u} 
  libedata-book-1.2-25{u} libedata-cal-1.2-28{u} libedataserver-1.2-22{u} libedataserverui-1.2-1{u} libelogind0{u} 
  libevent-2.0-5{u} libfarstream-0.2-5{u} libfile-copy-recursive-perl{u} libflite1{u} libfluidsynth1{u} 
  libfolks-eds25{u} libfolks-telepathy25{u} libfolks25{u} libgadu3{u} libgail-3-0{u} libgcj-bc{u} libgcr-3-common{u} 
  libgee-0.8-2{u} libgeocode-glib0{u} libgfortran3{u} libgltf-0.0-0v5{u} libgnome-autoar-0-0{u} 
  libgnome-autoar-common{u} libgnome-autoar-gtk-0-0{u} libgphoto2-l10n{u} libgraphene-1.0-0{u} 
  libgraphicsmagick-q16-3{u} libgssdp-1.0-3{u} libgstreamer-plugins-bad1.0-0{u} libgtkimageview0{u} libgtkspell3-3-0{u} 
  libgupnp-1.0-4{u} libgupnp-igd-1.0-4{u} libgutenprint2{u} libgweather-3-6{u} libgweather-common{u} 
  libjavascriptcoregtk-1.0-0{u} libjavascriptcoregtk-3.0-0{u} libkf5dbusaddons-bin{u} libkf5iconthemes-bin{u} 
  libmeanwhile1{u} libmission-control-plugins0{u} libnice10{u} libnm-glib4{u} libnm-util2{u} libofa0{u} 
  libopenal-data{u} libopenal1{u} libopenmpt-modplug1{u} liborcus-0.11-0{u} libperl5.24{u} libphonenumber7{u} 
  libprotobuf-c1{u} libpst4{u} libpurple-bin{u} libpurple0{u} libpython-all-dev{u} libpython3.5-dev{u} libqpdf17{u} 
  libre2-3{u} librpm3{u} librpmbuild3{u} librpmio3{u} librpmsign3{u} libsac-java-gcj{u} libsane-extras{u} 
  libsane-extras-common{u} libsbc1{u} libsdl-image1.2{u} libspandsp2{u} libsrtp0{u} libtelepathy-farstream3{u} 
  libtelepathy-glib0{u} libtelepathy-logger3{u} libtxc-dxtn-s2tc{u} libvo-aacenc0{u} libwacom-bin{u} 
  libwebkitgtk-1.0-0{u} libwebkitgtk-3.0-0{u} libwildmidi-config{u} libwildmidi2{u} libx264-148{u} libx265-95{u} 
  libxine2-doc{u} libxpp2-java{u} libytnef0{u} libzbar0{u} libzephyr4{u} mjpegtools-gtk{u} pidgin-data{u} python-all{u} 
  python-all-dev{u} python3.5-dev{u} qpdf{u} rename{u} seahorse{u} seahorse-daemon{u} sonnet-plugins{u} 
  task-print-server{u} tcpd{u} telepathy-gabble{u} telepathy-haze{u} telepathy-logger{u} telepathy-mission-control-5{u} 
  telepathy-salut{u} x11proto-dri2-dev{u} x11proto-gl-dev{u} 
The following partially installed packages will be configured:
  acl adwaita-icon-theme anacron ant ant-contrib ant-optional apparmor apt-listchanges apt-transport-https apt-utils 
  aptitude aptitude-common aspell aspell-en aspell-es aspell-pt-pt at-spi2-core autoconf automake autopoint 
  autotools-dev bash-completion bc binutils binutils-common binutils-x86-64-linux-gnu blt bluez bsdmainutils bubblewrap 
  busybox bzip2 ca-certificates ca-certificates-java clamav clamav-base clamav-freshclam cmake cmake-data coinor-libcbc3 
  coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 console-setup 
  console-setup-linux consolekit cpio cpp cpp-8 cron cups cups-browsed cups-bsd cups-client cups-common 
  cups-core-drivers cups-daemon cups-filters cups-filters-core-drivers cups-ipp-utils cups-ppdc cups-server-common curl 
  dbus dbus-x11 dc dconf-cli dconf-gsettings-backend dconf-service debconf-i18n debhelper debugedit default-jre 
  default-jre-headless dh-autoreconf dh-python dh-strip-nondeterminism dictionaries-common dirmngr dpkg-dev dwz e2fslibs 
  emacsen-common enchant eudev file firefox-esr fontconfig fontconfig-config fonts-liberation fonts-opensymbol 
  foomatic-db-compressed-ppds foomatic-db-engine gcc gcc-8 gcr gettext gettext-base ghostscript gir1.2-atk-1.0 
  gir1.2-atspi-2.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-harfbuzz-0.0 
  gir1.2-pango-1.0 git git-man glib-networking glib-networking-common glib-networking-services 
  gnome-accessibility-themes gnome-icon-theme gnome-themes-extra gnome-themes-extra-data gnome-themes-standard gnupg 
  gnupg-agent gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm groff-base 
  gsettings-desktop-schemas gtk-update-icon-cache gtk2-engines-pixbuf guile-2.2-libs hicolor-icon-theme hplip hplip-data 
  hunspell-en-au hunspell-en-us hunspell-es icu-devtools initramfs-tools initramfs-tools-core initscripts insserv 
  install-info intltool-debian iso-codes java-common kbd keyboard-configuration kio klibc-utils kmod kpackagelauncherqml 
  kpackagetool5 libabw-0.1-1 libactivation-java libalgorithm-diff-perl libalgorithm-diff-xs-perl libaom0 
  libaopalliance-java libapache-poi-java libapache-pom-java libapparmor1 libapt-inst2.0 libapt-pkg-perl 
  libarchive-zip-perl libarchive13 libargs4j-java libasan5 libasound2 libasound2-data libaspell15 libassuan0 
  libatinject-jsr330-api-java libatk-bridge2.0-0 libatk-bridge2.0-dev libatk1.0-0 libatk1.0-data libatk1.0-dev 
  libatomic1 libatspi2.0-0 libatspi2.0-dev libaudio2 libavahi-client3 libavahi-common-data libavahi-common3 
  libavahi-glib1 libavcodec58 libavformat58 libavutil56 libbcmail-java libbcpkix-java libbcprov-java libbinutils 
  libblas3 libblkid-dev libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0 libboost-filesystem1.67.0 
  libboost-iostreams1.67.0 libboost-locale1.67.0 libboost-system1.67.0 libboost-thread1.67.0 libbrotli1 libbsd0 
  libbsh-java libc-bin libc-dev-bin libc-l10n libc6-dev libcairo-gobject2 libcairo-perl libcairo-script-interpreter2 
  libcairo2 libcairo2-dev libcap2 libcap2-bin libcc1-0 libccid libcdi-api-java libcdr-0.1-1 libcgi-fast-perl 
  libcgi-pm-perl libcgmanager0 libck-connector0 libclamav9 libclass-accessor-perl libclone-perl libclutter-1.0-0 
  libcmis-0.5-5v5 libcodec2-0.8.1 libcodemodel-java libcogl-pango20 libcogl-path20 libcogl20 libcolord2 
  libcommons-cli-java libcommons-codec-java libcommons-collections4-java libcommons-compress-java libcommons-io-java 
  libcommons-lang3-java libcommons-logging-java libcommons-math3-java libcommons-parent-java libcroco3 
  libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcrystalhd3 libcups2 
  libcupsfilters1 libcupsimage2 libcurl3-gnutls libcurl4 libcurvesapi-java libcwidget3v5 libdatrie1 libdbus-1-3 
  libdbus-1-dev libdbus-glib-1-2 libdconf1 libde265-0 libdom4j-java libdouble-conversion1 libdpkg-perl libdrm-amdgpu1 
  libdrm-common libdrm-dev libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libdtd-parser-java libdw1 
  libe-book-0.1-1 libedit2 libegl-mesa0 libegl1 libegl1-mesa libegl1-mesa-dev libel-api-java libelf1 libenchant1c2a 
  libeot0 libepoxy-dev libepoxy0 libepubgen-0.1-1 liberror-perl libetonyek-0.1-1 libevdev2 libevent-2.1-6 libexif12 
  libexpat1-dev libexttextcat-2.0-0 libexttextcat-data libfam0 libfastinfoset-java libfcgi-perl libffi-dev 
  libfile-fcntllock-perl libfile-stripnondeterminism-perl libflac8 libflute-java libfontconfig1 libfontconfig1-dev 
  libfontembed1 libfreehand-0.1-1 libfreetype6 libfreetype6-dev libfribidi-dev libfribidi0 libgail-common libgail18 
  libgbm1 libgc1c2 libgcc-8-dev libgck-1-0 libgcr-base-3-1 libgcr-ui-3-1 libgd3 libgdbm-compat4 libgdbm6 
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgdk-pixbuf2.0-dev 
  libgeronimo-annotation-1.3-spec-java libgeronimo-interceptor-3.0-spec-java libgfortran5 libgif7 libgirepository-1.0-1 
  libgl1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles1 libgles2 libgles2-mesa libglib-perl 
  libglib2.0-0 libglib2.0-bin libglib2.0-data libglib2.0-dev libglib2.0-dev-bin libglu1-mesa libglu1-mesa-dev 
  libglvnd-core-dev libglvnd-dev libglvnd0 libglx-mesa0 libglx0 libgme0 libgomp1 libgpgme11 libgpgmepp6 libgphoto2-6 
  libgphoto2-port12 libgraphite2-3 libgraphite2-dev libgs9 libgs9-common libgsm1 libgssapi-krb5-2 
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk-3-dev libgtk2-perl 
  libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libguava-java libgudev-1.0-0 libguice-java libgutenprint-common 
  libgutenprint9 libharfbuzz-dev libharfbuzz-gobject0 libharfbuzz-icu0 libharfbuzz0b libheif1 libhpmud0 
  libhsqldb1.8.0-java libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl 
  libhttp-message-perl libhttp-negotiate-perl libhttpclient-java libhttpcore-java libhunspell-1.7-0 libhyphen0 
  libicu-dev libicu4j-java libicu63 libidn11 libijs-0.35 libimage-magick-q16-perl libimagequant0 libimobiledevice6 
  libinput-bin libinput10 libintellij-annotations-java libio-pty-perl libio-socket-ssl-perl libisl19 
  libistack-commons-java libitext-java libitm1 libjavascriptcoregtk-4.0-18 libjaxb-api-java libjaxb-java libjaxen-java 
  libjbig2dec0 libjdom1-java libjetbrains-annotations-java libjpeg62-turbo libjson-c3 libjson-glib-1.0-0 
  libjson-glib-1.0-common libjsoup-java libjsp-api-java libjsr305-java libk5crypto3 libkeyutils1 libkf5archive5 
  libkf5attica5 libkf5auth-data libkf5auth5 libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5 
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5 
  libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 
  libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5declarative5 libkf5doctools5 libkf5emoticons-bin 
  libkf5emoticons-data libkf5emoticons5 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5 
  libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 
  libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils5 
  libkf5kdelibs4support-data libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kiocore5 libkf5kiofilewidgets5 
  libkf5kiontlm5 libkf5kiowidgets5 libkf5krosscore5 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5 
  libkf5notifications-data libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data 
  libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5plasma5 libkf5quickaddons5 libkf5runner5 
  libkf5service-bin libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data 
  libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5 libkf5wallet-bin 
  libkf5wallet-data libkf5wallet5 libkf5webkit5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data 
  libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libklibc libkmod2 libkrb5-3 libkrb5support0 
  libkwalletbackend5-5 liblapack3 liblayout-java liblcms2-2 liblcms2-utils libldap-2.4-2 libldap-common 
  liblist-moreutils-perl libllvm7 liblocale-gettext-perl liblog4j1.2-java liblsan0 libltdl-dev libltdl7 
  liblwp-protocol-https-perl liblzo2-2 libmagic-mgc libmagic1 libmagickcore-6.q16-6 libmail-java libmailutils5 
  libmariadb3 libmaven-file-management-java libmaven-parent-java libmaven-resolver-java libmaven-shared-io-java 
  libmaven-shared-utils-java libmaven3-core-java libmount-dev libmpc3 libmpdec2 libmpfr6 libmpg123-0 libmpx2 libmspack0 
  libmspub-0.1-1 libmwaw-0.3-3 libncurses6 libneon27-gnutls libnet-dbus-perl libnet-http-perl libnet-ssleay-perl 
  libnetaddr-ip-perl libnghttp2-14 libnih-dbus1 libnih1 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnotify4 
  libnpth0 libnspr4 libnss3 libnuma1 libnumbertext-1.0-0 libnumbertext-data libodfgen-0.1-1 libogg0 libopengl0 
  libopenjp2-7 libopenmpt0 libopus0 liborc-0.4-0 liborcus-0.14-0 libpagemaker-0.0-0 libpam-cap libpango-1.0-0 
  libpango-perl libpango1.0-dev libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libpaper1 
  libparse-debianchangelog-perl libpciaccess0 libpcre16-3 libpcre2-16-0 libpcre2-8-0 libpcre3-dev libpcre32-3 
  libpcrecpp0v5 libpcsclite1 libpentaho-reporting-flow-engine-java libperl5.28 libperlio-gzip-perl libphonon4qt5-4 
  libpipeline1 libpixman-1-0 libpixman-1-dev libplexus-archiver-java libplexus-cipher-java libplexus-classworlds-java 
  libplexus-component-annotations-java libplexus-interpolation-java libplexus-io-java libplexus-sec-dispatcher-java 
  libplexus-utils2-java libplist3 libpng-dev libpng-tools libpng16-16 libpolkit-agent-1-0 libpolkit-backend-1-0 
  libpolkit-backend-consolekit-1-0 libpolkit-gobject-1-0 libpolkit-gobject-consolekit-1-0 libpoppler82 libpopt0 libpq5 
  libprocps7 libproxy1v5 libpsl5 libpthread-stubs0-dev libpulse-mainloop-glib0 libpulse0 libpulsedsp libpython-dev 
  libpython-stdlib libpython2-dev libpython2-stdlib libpython2.7 libpython2.7-dev libpython2.7-stdlib libpython3-dev 
  libpython3-stdlib libpython3.7 libpython3.7-dev libpython3.7-stdlib libqpdf21 libqt4-dbus libqt4-declarative 
  libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql 
  libqt4-sql-sqlite libqt4-svg libqt4-xml libqt4-xmlpatterns libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 
  libqt5network5 libqt5opengl5 libqt5opengl5-dev libqt5positioning5 libqt5printsupport5 libqt5qml5 libqt5quick5 
  libqt5quickwidgets5 libqt5script5 libqt5sensors5 libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite libqt5svg5 libqt5test5 
  libqt5texttospeech5 libqt5webchannel5 libqt5webengine-data libqt5webenginecore5 libqt5webenginewidgets5 libqt5webkit5 
  libqt5widgets5 libqt5x11extras5 libqt5xml5 libqt5xmlpatterns5 libqtcore4 libqtdbus4 libqtgui4 libquadmath0 
  libqxp-0.0-0 librdf0 libre2-5 libreadline7 libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base 
  libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw 
  libreoffice-gtk2 libreoffice-help-common libreoffice-help-en-us libreoffice-impress libreoffice-java-common 
  libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder libreoffice-report-builder-bin 
  libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python 
  libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-colibre libreoffice-style-tango 
  libreoffice-wiki-publisher libreoffice-writer librest-0.7-0 librhash0 librngom-java librpm8 librpmbuild8 librpmio8 
  librpmsign8 librsvg2-2 librsvg2-common libsac-java libsane libsane-common libsane-hpaio libsasl2-2 libsasl2-modules-db 
  libsaxonhe-java libsdl2-2.0-0 libsecret-1-0 libsecret-common libselinux1-dev libsensors-config libsensors5 
  libsepol1-dev libserializer-java libservlet-api-java libservlet3.1-java libshine3 libsigc++-2.0-0v5 libsigsegv2 
  libsisu-guice-java libsisu-inject-java libsisu-ioc-java libsisu-plexus-java libslf4j-java libsm-dev libsm6 
  libsnappy-java libsnappy-jni libsnappy1v5 libsndfile1 libsndio7.0 libsnmp-base libsnmp30 libsocket6-perl 
  libsoup-gnome2.4-1 libsoup2.4-1 libsoxr0 libsqlite3-0 libssh-gcrypt-4 libssh2-1 libstaroffice-0.0-0 
  libstartup-notification0 libstax-ex-java libstreambuffer-java libsub-name-perl libswresample3 libtcl8.6 libtdb1 
  libtext-charwidth-perl libtext-iconv-perl libthai-data libthai0 libtheora0 libtiff5 libtimedate-perl libtirpc-common 
  libtirpc3 libtk8.6 libtool libtry-tiny-perl libtsan0 libtxw2-java libubsan1 libuchardet0 liburi-perl libusb-1.0-0 
  libusbmuxd4 libuv1 libva-drm2 libva-x11-2 libva2 libvdpau1 libvisio-0.1-1 libvorbis0a libvorbisenc2 libvorbisfile3 
  libvpx5 libvulkan-dev libvulkan1 libwacom-common libwacom2 libwagon-http-java libwagon-provider-api-java libwavpack1 
  libwayland-bin libwayland-client0 libwayland-cursor0 libwayland-dev libwayland-egl1 libwayland-egl1-mesa 
  libwayland-server0 libwebkit2gtk-4.0-37{b} libwebp6 libwebpdemux2 libwebpmux3 libwebsocket-api-java libwoff1 
  libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libwrap0 libwww-perl libwww-robotrules-perl libx11-6 libx11-data libx11-dev 
  libx11-doc libx11-xcb-dev libx11-xcb1 libx264-155 libx265-165 libxapian30 libxatracker2 libxau-dev libxau6 
  libxcb-dri2-0 libxcb-dri2-0-dev libxcb-dri3-0 libxcb-dri3-dev libxcb-glx0 libxcb-glx0-dev libxcb-icccm4 
  libxcb-present-dev libxcb-present0 libxcb-randr0 libxcb-randr0-dev libxcb-render-util0 libxcb-render0 
  libxcb-render0-dev libxcb-shape0 libxcb-shape0-dev libxcb-shm0 libxcb-shm0-dev libxcb-sync-dev libxcb-sync1 
  libxcb-xfixes0 libxcb-xfixes0-dev libxcb-xinerama0 libxcb-xkb1 libxcb1 libxcb1-dev libxcursor-dev libxcursor1 
  libxdamage-dev libxdamage1 libxft-dev libxft2 libxinerama-dev libxinerama1 libxkbcommon-dev libxkbcommon-x11-0 
  libxkbcommon0 libxml-commons-resolver1.1-java libxml-libxml-perl libxml-namespacesupport-perl libxml-parser-perl 
  libxml-sax-base-perl libxml-sax-perl libxml-twig-perl libxml2 libxmlbeans-java libxmlsec1 libxmlsec1-nss libxnvctrl0 
  libxshmfence-dev libxshmfence1 libxslt1.1 libxsom-java libxss1 libxt6 libxz-java libyaml-0-2 libyaml-libyaml-perl 
  libzmf-0.0-0 libzvbi-common libzvbi0 linux-base linux-libc-dev lm-sensors locales logrotate lsb-base m4 mailutils 
  mailutils-common make man-db mariadb-common menu mesa-common-dev mesa-va-drivers mesa-vdpau-drivers mime-support mount 
  mysql-common netbase nfs-common node-normalize.css openjdk-11-jre openjdk-11-jre-headless openprinting-ppds openssl 
  p11-kit-modules pango1.0-tools patch pcscd perl perl-modules-5.28 phonon4qt5 pinentry-curses pinentry-gnome3 
  pinentry-gtk2 pinentry-qt pkg-config po-debconf policykit-1 poppler-data poppler-utils printer-driver-c2esp 
  printer-driver-escpr printer-driver-foo2zjs printer-driver-foo2zjs-common printer-driver-gutenprint 
  printer-driver-hpcups printer-driver-hpijs printer-driver-m2300w printer-driver-postscript-hp printer-driver-pxljr 
  printer-driver-sag-gdi procps pulseaudio pulseaudio-utils python python-apt-common python-dev python-imobiledevice 
  python-lxml python-numpy python-pkg-resources python-plist python-tk python2 python2-dev python2.7 python2.7-dev 
  python3 python3-apt python3-brlapi python3-cairo python3-cffi-backend python3-crypto python3-cups python3-dbus 
  python3-debconf python3-dev python3-distutils python3-gi python3-gi-cairo python3-lib2to3 python3-pexpect python3-pil 
  python3-ptyprocess python3-pyatspi python3-pycurl python3-renderpm python3-reportlab python3-reportlab-accel 
  python3-smbc python3-uno python3-yaml python3.7 python3.7-dev qdbus qml-module-org-kde-runnermodel 
  qt5-gtk-platformtheme qt5-qmake qt5-qmake-bin qtbase5-dev qtbase5-dev-tools qtchooser qtcore4-l10n readline-common 
  rpcbind rpm rpm-common rpm2cpio sane-utils sgml-base shared-mime-info startpar sysstat sysv-rc texinfo tk8.6-blt2.5 
  tzdata ucf udev uno-libs3 update-inetd ure usbmuxd uuid-dev wayland-protocols wget wpasupplicant 
  x11proto-composite-dev x11proto-core-dev x11proto-damage-dev x11proto-dev x11proto-fixes-dev x11proto-input-dev 
  x11proto-kb-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-xext-dev x11proto-xf86vidmode-dev 
  x11proto-xinerama-dev xdg-dbus-proxy xfce4-sensors-plugin xkb-data xz-utils zlib1g-dev 
0 packages upgraded, 0 newly installed, 139 to remove and 997 not upgraded.
Need to get 0 B of archives. After unpacking 387 MB will be freed.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-gl1.0-0 (>= 1.14.0) but it is not going to be installed
The following actions will resolve these dependencies:

     Install the following packages:                                            
1)     libgstreamer-gl1.0-0 [1.14.4-2 (stable)]                                 

     Leave the following dependencies unresolved:                               
2)     libgstreamer-gl1.0-0 recommends gstreamer1.0-gl                          
3)     libreoffice-avmedia-backend-gstreamer recommends gstreamer1.0-plugins-bad

Listing the files in /var produced the following.

ls -l
total 36
drwxr-xr-x  2 root root  4096 Jun  3  2018 backups/
drwxr-xr-x 14 root root  4096 Dec 18  2019 cache/
drwxr-xr-x 68 root root  4096 Jun 25 12:06 lib/
drwxrwsr-x  2 root staff 4096 Jun  3  2018 local/
lrwxrwxrwx  1 root root     9 Jun  5  2018 lock -> /run/lock
drwxr-xr-x 18 root root  4096 Jul  3 03:37 log/
drwxrwsr-x  2 root mail  4096 Jun 25 23:12 mail/
drwxr-xr-x  2 root root  4096 Jun  5  2018 opt/
lrwxrwxrwx  1 root root     4 Jun  5  2018 run -> /run/
drwxr-xr-x  8 root root  4096 Jun  5  2018 spool/
drwxrwxrwt  4 root root  4096 Jun 24 20:04 tmp/

Thanks!!, MTB.

Offline

#30 2020-07-04 15:03:14

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:
0 upgraded, 2 newly installed, 0 to remove and 1074 not upgraded.

So your system hasn't been upgraded to beowulf yet then.

mtbvfr wrote:
dpkg: error processing archive /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libgstgl-1.0.so.0', which is also in package libgstreamer-plugins-bad1.0-0:amd64 1:1.10.4-dmo2
Preparing to unpack .../gstreamer1.0-gl_1.14.4-2_amd64.deb ...
Unpacking gstreamer1.0-gl:amd64 (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstopengl.so', which is also in package gstreamer1.0-plugins-bad:amd64 1:1.10.4-dmo2

Can you remove the problematic packages?

# apt purge libgstreamer-plugins-bad1.0-0 gstreamer1.0-plugins-bad

If apt won't do it then try dpkg instead.

Don't use aptitude because it will auto-autoremove that long list of packages.

Not sure I entirely understand what's going on here though, I wasn't really following your other thread and I've never tried to use synaptic to upgrade between releases.


Black Lives Matter

Offline

#31 2020-07-04 16:05:28

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi HoaS,

Head_on_a_Stick wrote:
mtbvfr wrote:
0 upgraded, 2 newly installed, 0 to remove and 1074 not upgraded.

So your system hasn't been upgraded to beowulf yet then.

Not completely, no.


Head_on_a_Stick wrote:

Can you remove the problematic packages?

# apt purge libgstreamer-plugins-bad1.0-0 gstreamer1.0-plugins-bad

If apt won't do it then try dpkg instead.

Don't use aptitude because it will auto-autoremove that long list of packages.

I will give it a go and report back later.

Head_on_a_Stick wrote:

Not sure I entirely understand what's going on here though, I wasn't really following your other thread and I've never tried to use synaptic to upgrade between releases.

Other thread? Are you referring to the First page of this topic?

Thanks!!, MTB.

Offline

#32 2020-07-04 19:03:59

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Head_on_a_Stick wrote:

Can you remove the problematic packages?

# apt purge libgstreamer-plugins-bad1.0-0 gstreamer1.0-plugins-bad

If apt won't do it then try dpkg instead.

Hi HoaS,

After discovering that apt does not have a Simulation option and looking through the documentation for some of the other related package management commands, I ran the command apt -a show libgstreamer-plugins-bad1.0-0 which produced the following results.

Package: libgstreamer-plugins-bad1.0-0
Version: 1:1.10.4-dmo2
Priority: extra
Section: libs
Source: gst-plugins-bad1.0-dmo
Maintainer: Christian Marillat <marillat@deb-multimedia.org>
Bugs: mailto:marillat@deb-multimedia.org
Installed-Size: 2,870 kB
Depends: libc6 (>= 2.14), libegl1-mesa (>= 7.8.1) | libegl1-x11, libgl1-mesa-glx | libgl1, libgles2-mesa (>= 7.8.1) | libgles2, libglib2.0-0 (>= 2.37.3), libgstreamer-plugins-base1.0-0 (>= 1.8.0), libgstreamer1.0-0 (>= 1.10.0), liborc-0.4-0 (>= 1:0.4.25), libwayland-client0 (>= 1.9.91), libwayland-cursor0 (>= 1.0.2), libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1, libx11-6
Homepage: http://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
Download-Size: 1,873 kB
APT-Manual-Installed: no
APT-Sources: http://www.deb-multimedia.org stretch/main amd64 Packages
Description: GStreamer development files for libraries from the "bad" set

Package: libgstreamer-plugins-bad1.0-0
Version: 1.14.4-1+b1
Priority: optional
Section: libs
Source: gst-plugins-bad1.0 (1.14.4-1)
Maintainer: Maintainers of GStreamer packages <gst-plugins-bad1.0@packages.debian.org>
Installed-Size: 2,754 kB
Depends: libc6 (>= 2.14), libglib2.0-0 (>= 2.40), libgstreamer-plugins-base1.0-0 (>= 1.14.4), libgstreamer1.0-0 (>= 1.14.4)
Homepage: https://gstreamer.freedesktop.org
Tag: role::shared-lib
Download-Size: 1,935 kB
APT-Sources: http://deb.devuan.org/merged beowulf/main amd64 Packages
Description: GStreamer libraries from the "bad" set

However, that caused me to think that both of the packages listed were flagged as being installed.


Running the command dpkg -l | grep libgstream indicated the opposite.

(Devuan_GNU/Linux_3_(beowulf)_) Sat Jul 04 13:09:40 /var/cache/apt/archives
chroot> dpkg -l | grep libgstream
ii  libgstreamer-plugins-bad1.0-0:amd64                         1:1.10.4-dmo2                             amd64        GStreamer development files for libraries from the "bad" set
iU  libgstreamer-plugins-base1.0-0:amd64                        1.14.4-2                                  amd64        GStreamer libraries from the "base" set
iU  libgstreamer1.0-0:amd64                                     1.14.4-1                                  amd64        Core GStreamer libraries and elements
ii  libgstreamermm-1.0-1:amd64                                  1.8.0+dfsg-1                              amd64        C++ wrapper library for GStreamer (shared libraries)

So, I discovered that the apt-get command has a Simulation option and so I ran the command apt-get -s purge libgstreamer-plugins-bad1.0-0 gstreamer1.0-plugins-bad which produced the following output.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libcheese8 : Depends: gstreamer1.0-plugins-bad (>= 1.4) but it is not going to be installed
 libfarstream-0.2-5 : Depends: gstreamer1.0-plugins-bad but it is not going to be installed
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-gl1.0-0 (>= 1.14.0) but it is not going to be installed
                        Recommends: gstreamer1.0-gl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

apt --fix-broken install would do the same as before which I have already noted in this topic.

One thing I don't understand with the output above is which package the text but it is not going to be installed refers to. Does it refer to the First package listed on the line or the Package(s) that it Depends on or Recommends?

Thanks!!, MTB.

Offline

#33 2020-07-04 20:41:16

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:

Other thread? Are you referring to the First page of this topic?

I meant https://dev1galaxy.org/viewtopic.php?id=3629

mtbvfr wrote:

apt does not have a Simulation option

Yes it does, all of the options for apt-get can be used with apt.

mtbvfr wrote:
Package: libgstreamer-plugins-bad1.0-0
Version: 1:1.10.4-dmo2
Priority: extra
Section: libs
Source: gst-plugins-bad1.0-dmo
Maintainer: Christian Marillat <marillat@deb-multimedia.org>
Bugs: mailto:marillat@deb-multimedia.org
Installed-Size: 2,870 kB
Depends: libc6 (>= 2.14), libegl1-mesa (>= 7.8.1) | libegl1-x11, libgl1-mesa-glx | libgl1, libgles2-mesa (>= 7.8.1) | libgles2, libglib2.0-0 (>= 2.37.3), libgstreamer-plugins-base1.0-0 (>= 1.8.0), libgstreamer1.0-0 (>= 1.10.0), liborc-0.4-0 (>= 1:0.4.25), libwayland-client0 (>= 1.9.91), libwayland-cursor0 (>= 1.0.2), libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1, libx11-6
Homepage: http://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
Download-Size: 1,873 kB
APT-Manual-Installed: no
APT-Sources: http://www.deb-multimedia.org stretch/main amd64 Packages
Description: GStreamer development files for libraries from the "bad" set

The deb-multimedia developer has added an epoch to their version so that it is seen as "newer" than the Devuan package even though it isn't.

Try

apt install {libgstreamer-plugins-bad1.0-0,gstreamer1.0-plugins-bad}=1.14.4-1+b1 {libgstreamer-gl1.0-0,gstreamer1.0-gl}=1.14.4-2

Black Lives Matter

Offline

#34 2020-07-04 23:22:02

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Head_on_a_Stick wrote:
mtbvfr wrote:

apt does not have a Simulation option

Yes it does, all of the options for apt-get can be used with apt.

Ok, I was going by the info on the following page.

apt(8) — apt — Debian buster — Debian Manpages



Head_on_a_Stick wrote:

Try

apt install {libgstreamer-plugins-bad1.0-0,gstreamer1.0-plugins-bad}=1.14.4-1+b1 {libgstreamer-gl1.0-0,gstreamer1.0-gl}=1.14.4-2

apt -s install {libgstreamer-plugins-bad1.0-0,gstreamer1.0-plugins-bad}=1.14.4-1+b1 {libgstreamer-gl1.0-0,gstreamer1.0-gl}=1.14.4-2 produced the following.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gstreamer1.0-plugins-bad : Depends: libilmbase23 (>= 2.2.1) but it is not going to be installed
                            Depends: libopenexr23 but it is not going to be installed
                            Depends: libsoundtouch1 (>= 2.0.0) but 1.9.2-2+deb9u1 is to be installed
                            Depends: libsrtp2-1 (>= 2.0.0+20170516) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Which package does the text but it is not going to be installed refer to?

apt --fix-broken install produces the same output as before.

Thanks!!

Offline

#35 2020-07-04 23:39:58

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:

Which package does the text but it is not going to be installed refer to?

I think it's referring to other packages from deb-multimedia, use apt policy to check the available versions and origins of the packages.

Looks like deb-multimedia has really messed up your system, as per usual for that repository.

We could try an emergency "downgrade" to beowulf by using a file at /etc/apt/preferences.d/downgrade with this content:

Package: *
Pin: release n=beowulf
Pin-Priority: 1001

Then run

# apt update
# apt full-upgrade

Black Lives Matter

Offline

#36 2020-07-06 03:28:06

mtbvfr
Member
Registered: 2017-07-29
Posts: 62  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Head_on_a_Stick wrote:
mtbvfr wrote:

Which package does the text but it is not going to be installed refer to?

I think it's referring to other packages from deb-multimedia, use apt policy to check the available versions and origins of the packages.

Hi HoaS,

It looks like the Manpages need some updating. In my quest to understand what the apt policy command would/should do, I couldn't find policy listed as a command for apt but my searching revealed that apt policy has supposedly replaced apt-cache policy. Sure enough policy is listed as a command for apt-cache.

The output for both of these commands was the same as follows.

Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 https://repo.windscribe.com/debian buster/main amd64 Packages
     release o=. buster,a=buster,n=buster,l=. buster,c=main,b=amd64
     origin repo.windscribe.com
 500 https://packages.riot.im/debian stretch/main amd64 Packages
     release o=riot.im,a=oldstable,n=stretch,c=main,b=amd64
     origin packages.riot.im
 500 https://dl.jami.net/nightly/debian_9 ring/main amd64 Packages
     release o=ring,n=ring,l=Ring debian_9 Repository,c=main,b=amd64
     origin dl.jami.net
 500 http://apt.connectify.me speedify/main amd64 Packages
     release o=. speedify,a=speedify,n=speedify,l=. speedify,c=main,b=amd64
     origin apt.connectify.me
 500 http://www.deb-multimedia.org stretch/non-free amd64 Packages
     release v=9.12,o=Unofficial Multimedia Packages,a=oldstable,n=stretch,l=Unofficial Multimedia Packages,c=non-free,b=amd64
     origin www.deb-multimedia.org
 500 http://www.deb-multimedia.org stretch/main amd64 Packages
     release v=9.12,o=Unofficial Multimedia Packages,a=oldstable,n=stretch,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin www.deb-multimedia.org
 500 http://deb.devuan.org/merged beowulf-security/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/main amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
Pinned packages:

There were no Pinned packages.


Head_on_a_Stick wrote:

Looks like deb-multimedia has really messed up your system, as per usual for that repository.

We could try an emergency "downgrade" to beowulf by using a file at /etc/apt/preferences.d/downgrade with this content:

Package: *
Pin: release n=beowulf
Pin-Priority: 1001

Then run

# apt update
# apt full-upgrade

I found the Man page for apt_preferences(5) — apt — Debian buster — Debian Manpages.

I think I have a fair idea of what you think could be achieved with the "downgrade" but what would/should be the "cleanest" approach to resolving the issues?

For example, if I tried the apt-get purge libgstreamer-plugins-bad1.0-0 gstreamer1.0-plugins-bad and the apt install {libgstreamer-plugins-bad1.0-0,gstreamer1.0-plugins-bad}=1.14.4-1+b1 {libgstreamer-gl1.0-0,gstreamer1.0-gl}=1.14.4-2 commands without a simulation as you previously suggested, what could go wrong or would it help to fix things?


If you think that the emergency "downgrade" idea is a better option, should the apt-get update and apt-get -o dir::cache::archives="/disc/" dist-upgrade commands (as per my post #21) be used in place of your suggestion for apt update and apt full-upgrade.

When should commands such as apt autoremove and apt-get autoclean be used?

Thanks!!, MTB.

Offline

#37 2020-07-06 20:19:22

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:

The output for both of these commands was the same as follows.

Dear me, your sources are a mess. The deb-multimedia repositories definitely break things (as we've seen) and I don't trust the other foreign sources either. Probably best to reinstall from scratch and try to stick to Devuan's repositories in future if you want to avoid these issues.

See also https://wiki.debian.org/DontBreakDebian (s/Debian/Devuan/g).

mtbvfr wrote:

If you think that the emergency "downgrade" idea is a better option, should the apt-get update and apt-get -o dir::cache::archives="/disc/" dist-upgrade commands (as per my post #21) be used in place of your suggestion for apt update and apt full-upgrade.

The apt command is a user-friendly wrapper for apt-get &c, it is functionally very similar but with a few options changed. I suggested apt full-upgrade because that is recommended by the Debian buster upgrade guide.

mtbvfr wrote:

When should commands such as apt autoremove and apt-get autoclean be used?

Read man apt-get, that explains what those options do.


Black Lives Matter

Offline

#38 2020-07-07 08:27:07

larsH
Member
Registered: 2020-05-05
Posts: 143  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi

I am sorry to say this. You have a FrankenDevuan in your sources list. Apt (aswell apt-get and aptitude) cannot solve the dependencies with this. Deb-multimedia is a no go. They rebuild a lot of debians packages. And they are not compatible with Devuan. They are also a problem in pure Debian if you are doing anything special. Remove anything but devuan from your sources list. And if you are lucky a very necessary downgrade as suggested by Head_on_a_Stick  will solve most problems.

Have a nice day
Lars H

Offline

Board footer