The officially official Devuan Forum!

You are not logged in.

#1 2019-11-29 03:33:36

ezmax
Member
Registered: 2019-11-26
Posts: 4  

How to setup PHP=>7.1 on Devuan 2.1?

How to setup PHP=>7.1 on Devuan 2.1?

default installation is PHP v7.0.33-0+deb9u6

can i use deb.sury.org repository?

Last edited by ezmax (2019-11-29 12:41:54)

Offline

#2 2020-01-02 20:16:26

IdeaFix
Member
Registered: 2020-01-02
Posts: 11  
Website

Re: How to setup PHP=>7.1 on Devuan 2.1?

You can use sury, but you should edit apt sources file.

Hereis an official description - https://packages.sury.org/php/README.txt

but you may be should make not this code:

#!/bin/bash
# To add this repository please do:

if [ "$(whoami)" != "root" ]; then
    SUDO=sudo
fi

${SUDO} apt-get -y install apt-transport-https lsb-release ca-certificates curl
${SUDO} wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
${SUDO} sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
${SUDO} apt-get update

but this:

#!/bin/bash
# To add this repository please do:

if [ "$(whoami)" != "root" ]; then
    SUDO=sudo
fi

${SUDO} apt-get -y install apt-transport-https lsb-release ca-certificates curl
${SUDO} wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
${SUDO} sh -c 'echo "deb https://packages.sury.org/php/ stretch main" > /etc/apt/sources.list.d/php.list'
${SUDO} apt-get update

There is no ascii in deb.sury.org repository.

Last edited by IdeaFix (2020-01-02 20:45:28)

Offline

#3 2020-04-22 07:40:28

IdeaFix
Member
Registered: 2020-01-02
Posts: 11  
Website

Re: How to setup PHP=>7.1 on Devuan 2.1?

HELP! SOS!

I can not upgrade PHP from sury! It depends now from systemd-tmpfiles  sad

Offline

#4 2020-04-22 08:17:39

xinomilo
Member
Registered: 2017-07-02
Posts: 117  

Re: How to setup PHP=>7.1 on Devuan 2.1?

Offline

#5 2020-04-22 16:21:02

IdeaFix
Member
Registered: 2020-01-02
Posts: 11  
Website

Re: How to setup PHP=>7.1 on Devuan 2.1?

Unfortunately (for me) i need 386 builds, and there is only amd64.

Offline

#6 2020-05-05 06:38:02

steve_v
Member
Registered: 2018-01-11
Posts: 20  

Re: How to setup PHP=>7.1 on Devuan 2.1?

IdeaFix wrote:

Unfortunately (for me) i need 386 builds, and there is only amd64.

Just fudge it with equivs. Either use the dummy package as-is or build your own that symlinks opentmpfiles.

PHP-FPM from packages.sury.org doesn't really need systemd, some nit just decided to use systemd-tmpfiles because it's there... And be a dick about it when someone tries it where systemd is not installable.
It's probably time to retire the use of that repo if this kind of idiocy is going to continue (and I expect it will), but for now a dirty little one-line shell hack keeps the wheels turning.

Probably a bit late for you I know, but I'll leave it here for reference anyway.

Offline

Board footer