The officially official Devuan Forum!

You are not logged in.

#1 2019-08-20 05:42:17

masterpeace
Member
Registered: 2019-08-20
Posts: 9  

[SOLVED] [newbie] need help with minimal installation problem

hello

a linux newbie here . this is my 5th to 6th month using linux (MX 18.3) . i want to learn more about linux and so i decided to take a journey from MX in my vacation time . my first circle of linux is quite a minority that avoids systemd . it's not that i hate systemd since i don't even encounter that in my first distro ever (MX) . so they advised me to try minimal devuan install .

so i downloaded netinstall.iso first as they advised . the manual told me to burn the iso manually or use dd . since my work laptop (HP 242 G1) don't have dvd drive , so i used dd . but it won't boot . so i googled and tried unetbootin , it boots , but then i encountered firmware problem , it won't load the firmware it keeps asking me for the missing non-free wi-fi firmware even if i placed the firmware on the installation drive (.deb version and the unpacked version from github) . so i then tried to use minimal install version .

while the minimal install works even while encountering that firmware problem , i then encountered second problem . i can't turn my wi-fi on , so i am stuck with the base install . i don't have access to ethernet since i am on my paid vacation , and i am using free hotel wi-fi . what should i do ?

Offline

#2 2019-08-20 11:12:26

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,229  

Re: [SOLVED] [newbie] need help with minimal installation problem

First thing I would do is look behind the furniture for an ethernet outlet.

If you tried the minimal-live iso, it has firmware already installed. Run setnet.sh to configure wireless.

I don't know anything about your model of laptop, but you might want to take a look at this to see if you have any of the same problems: https://dev1galaxy.org/viewtopic.php?id=15

Offline

#3 2019-08-21 06:49:20

masterpeace
Member
Registered: 2019-08-20
Posts: 9  

Re: [SOLVED] [newbie] need help with minimal installation problem

thanks , dd netinstall.iso finally boot

my bad , i was actually using netinstall version of ascii not the minimal install

it's not that it won't boot , but i automated grub to force start mx linux  (grub.conf : grub_delay:0) or i didn't use conv=sync when dd , the culprit is one of the two .

and setnet.sh won't run , bash unknown command

Last edited by masterpeace (2019-08-21 09:56:22)

Offline

#4 2019-08-21 13:18:28

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,229  

Re: [SOLVED] [newbie] need help with minimal installation problem

setnet.sh is in the live isos, not the installer isos.

I never use conv=sync when I dd a usb stick, so I don't think that was the problem. Sounds like the classic problem of "Computers don't do what you want; they do what you tell them to do."

Glad you got it working.

Offline

#5 2019-08-21 13:59:36

masterpeace
Member
Registered: 2019-08-20
Posts: 9  

Re: [SOLVED] [newbie] need help with minimal installation problem

it turns out both are the culprit . i red freeBSD handbook which practically giving the potential problem and why ...

my flash drive are 18 yo usb2 4gb , while my hard drive is Crucial M4 SSD , output per flops write are having stark contrast , that's why conv=sync need to be turned on for safety reason .

and uefi grub are practically gives you booting options

dear admins and mods , please mark this as solved and thanks

Offline

Board footer