The officially official Devuan Forum!

You are not logged in.

#1 2018-05-11 09:58:08

opknow
Member
Registered: 2018-03-19
Posts: 4  

no wifi working

Hi guys, after installation I've got no wifi working.

When I start wicd it doesn't see wifi around the pc. Can you help me to figure it out how to solve this problem?

Offline

#2 2018-05-11 12:14:56

siva
Member
Registered: 2018-01-25
Posts: 167  
Website

Re: no wifi working

If you're using wicd, make sure your wifi interface is the same wireless interface in its settings.

You can list your network devices with ifconfig -a as root.
You can find your network card with lspci -vv | grep -i Network as root.  For some devices, you may need proprietary/nonfree software.

Offline

#3 2018-05-11 12:18:01

Panopticon
Member
Registered: 2018-01-27
Posts: 119  

Re: no wifi working

what does...

iwconfig

show

Offline

#4 2018-05-13 11:46:22

14158
Member
Registered: 2018-05-12
Posts: 2  

Re: no wifi working

I had this issue, as advised check what the interfaces are named with sudo ifconfig -a.  Then update the Wicd preferences accordingly. smile

Not sure if I should log this as a bug?

Offline

#5 2018-05-15 21:51:07

opknow
Member
Registered: 2018-03-19
Posts: 4  

Re: no wifi working

Hi there. Thank you for your answer. Here all the informations you asked me.

with root user

# ifconfig -a
wlan0     Link encap:Ethernet  HWaddr 74:de:2b:07:a9:be 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

# lspci -vv | grep -i Network
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

# iwconfig
wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

What do you suggest???

Offline

#6 2018-05-16 02:13:07

0xf4b10
Member
Registered: 2018-05-12
Posts: 30  

Re: no wifi working

I have neither ifconfig nor iwconfig installed in my system. What package should I install to add them?

Offline

#7 2018-05-16 11:36:21

Panopticon
Member
Registered: 2018-01-27
Posts: 119  

Re: no wifi working

opknow wrote:

Hi there. Thank you for your answer. Here all the informations you asked me.

with root user

# ifconfig -a
wlan0     Link encap:Ethernet  HWaddr 74:de:2b:07:a9:be 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

# lspci -vv | grep -i Network
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

# iwconfig
wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

What do you suggest???

Have a look at this link, may help you to manage your wifi from the command line.

https://www.blackmoreops.com/2014/09/18 … -in-linux/

Last edited by Panopticon (2018-05-16 11:46:41)

Offline

#8 2018-05-16 11:53:24

Panopticon
Member
Registered: 2018-01-27
Posts: 119  

Re: no wifi working

0xf4b10 wrote:

I have neither ifconfig nor iwconfig installed in my system. What package should I install to add them?

You need the iw package and net-tools i think.

Offline

Board footer