The officially official Devuan Forum!

You are not logged in.

#1 2020-09-29 18:01:32

uther
Member
Registered: 2019-05-16
Posts: 47  

[SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

After recent update I cannot run Synaptic (launcher and whisker menu) and open encrypted drives (thunar) anymore.
Im running Beowulf Xfce flavour. I can run Synaptic with sudo, and open crypts manually with cryptsetup luksOpen.

When opening encrypted drive I'm getting:

 failed to mount "_my-drive-here_ Encrypted" Not authorized to perform operation.

Appreciate any help.

Last edited by uther (2020-09-29 18:39:56)

Offline

#2 2020-09-29 18:06:21

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: [SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

Do you have any polkit authentication agents running?

pgrep -a polkit

EDIT: if this happened after an update then we should probably also see your sources:

apt policy

Last edited by Head_on_a_Stick (2020-09-29 18:07:16)


Black Lives Matter

Offline

#3 2020-09-29 18:14:47

uther
Member
Registered: 2019-05-16
Posts: 47  

Re: [SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

I have policykit

~$ pgrep -a polkit
5210 /usr/lib/policykit-1/polkitd --no-debug

and no pinned packages:

~$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 100 http://deb.devuan.org/merged beowulf-backports/contrib i386 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=contrib,b=i386
     origin deb.devuan.org
 100 http://deb.devuan.org/merged beowulf-backports/contrib amd64 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=contrib,b=amd64
     origin deb.devuan.org
 100 http://deb.devuan.org/merged beowulf-backports/non-free i386 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=non-free,b=i386
     origin deb.devuan.org
 100 http://deb.devuan.org/merged beowulf-backports/non-free amd64 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=non-free,b=amd64
     origin deb.devuan.org
 100 http://deb.devuan.org/merged beowulf-backports/main i386 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=main,b=i386
     origin deb.devuan.org
 100 http://deb.devuan.org/merged beowulf-backports/main amd64 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/non-free i386 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=non-free,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/non-free amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/main i386 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=main,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/non-free i386 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=non-free,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/non-free amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/main i386 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=main,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/contrib i386 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=contrib,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/contrib amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=contrib,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/non-free i386 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=non-free,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/non-free amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/main i386 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=main,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/main amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
Pinned packages:

Last edited by uther (2020-09-29 18:15:20)

Offline

#4 2020-09-29 18:24:40

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: [SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

uther wrote:

I have policykit

~$ pgrep -a polkit
5210 /usr/lib/policykit-1/polkitd --no-debug

But you don't have a graphical authentication agent running so Synaptic can't ask for a password if you launch it from the menu.

Try this (run the first command as root and the second as your normal user):

# apt install policykit-1-gnome
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

Does Synaptic launch from the menu now?

uther wrote:
 100 http://deb.devuan.org/merged beowulf-backports/main amd64 Packages
     release v=3.0.0,o=Devuan Backports,a=stable-backports,n=beowulf-backports,l=Devuan Backports,c=main,b=amd64
     origin deb.devuan.org

What have you installed from backports?

aptitude search '?narrow(?installed, ?archive(stable-backports))'

Black Lives Matter

Offline

#5 2020-09-29 18:39:37

uther
Member
Registered: 2019-05-16
Posts: 47  

Re: [SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

Head_on_a_Stick wrote:

But you don't have a graphical authentication agent running so Synaptic can't ask for a password if you launch it from the menu.

I already have policykit-1-gnome installed.
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 & have resolved the issue. Thanks.

From backports I have installed only newest kernels 5.4 and 5.6.

Offline

#6 2020-09-29 18:48:31

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: [SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

uther wrote:

/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 & have resolved the issue

That only starts the agent once.

If the package is installed then Xfce should autostart it via /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop so check for ~/.config/autostart/polkit-gnome-authentication-agent-1.desktop — that might be overriding it.

EDIT: and your kernels are outdated, you should install the metapackge:

# apt install linux-image-amd64/beowulf-backports

Last edited by Head_on_a_Stick (2020-09-29 18:53:39)


Black Lives Matter

Offline

#7 2020-09-29 19:00:08

uther
Member
Registered: 2019-05-16
Posts: 47  

Re: [SOLVED] Cannot run Synaptic & mount drives after update (Beowulf)

/etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop is in place and contains:

Exec=/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

There's no autostart/polkit-gnome-authentication-agent-1.desktop in ~/.config/autostart

ED: I've updated the kernel and now everything seems to be ok.

Last edited by uther (2020-09-29 19:40:06)

Offline

Board footer