The officially official Devuan Forum!

You are not logged in.

#1 2020-08-07 07:58:45

larsH
Member
Registered: 2020-05-05
Posts: 125  

Do not use pulseaudio

Dont use pulseaudio

In most situations you do not need pulseaudio. Just use alsa instead. This will reduce latency and overhead.

Alsa is enabled by default. Volume and audio device can be choosen and adjusted in a terminal using the command "alsamixer".
If you want to adjust with a gui install volumeicon-alsa from a terminal with "apt install volumeicon-alsa" as root. Add it to your desktop startup (howto depend on the enviroment). But it can also be started from a terminal using the command "volumeicon" Right click the voulmeicon to configure preferences.

And that should be about it.

Offline

#2 2020-08-07 20:49:07

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 958  
Website

Re: Do not use pulseaudio

For those who have laptops with HDMI outputs see this guide for setting the non-HDMI output as the default:

https://wiki.archlinux.org/index.php/Ad … sound_card


Black Lives Matter

Offline

#3 2020-08-08 13:52:09

Geoff 42
Member
Registered: 2016-12-15
Posts: 366  

Re: Do not use pulseaudio

With 2 devices sharing the same kernel module, you can disable the one which you are not using. You use the enable parameter, where 0=disable and 1=enable. You could set the entry in /etc/modprobe.d/alsa-base.conf to :-

# Disable the HDMI card which shows up first, but enable PCH
options snd-hda-intel enable=0,1

https://dev1galaxy.org/viewtopic.php?pid=339#p339

Geoff

Offline

#4 2020-08-21 11:43:33

jobbautista9
Member
From: Philippines
Registered: 2020-07-11
Posts: 19  
Website

Re: Do not use pulseaudio

And if the software you use depends on PA and they don't use ALSA, try wrapping the program with apulse, which is available in Devuan since oldstable ASCII. I use it for Seamonkey, where the official build wasn't compiled with support for ALSA.

Last edited by jobbautista9 (2020-08-21 11:44:14)

Offline

#5 2020-08-26 11:46:00

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 133  
Website

Re: Do not use pulseaudio

You can also use KDE without pulseaudio. Screenshots here was taken on a Beowulf 64 bits box with KDE.

I use KDE with VLC sound engine. By default, KDE try to use pulseaudio, but pure ALSA is also available in GUI configuration.

Go to K, Preferences, System Preferences, Hardware, Audio and Video. You may need to check Show advanced devices: (click to full size):

kdeaudio-mini.png

If you (like me) dont have pulseaudio installed, clicking the Test button when pulse is selected will show an error on console:

main audio output error: no suitable audio output module
main decoder error: failed to create audio output
vlcpulse audio output error: PulseAudio server connection failure: Connection refused

Dragging and dropping or with the Prefer button, put the option Default to first position:
kdeaudio-alsa.png

Then, Apply Device List to all the categories (YMMV).

Now, you can listen audio even on Dolphin:
dolphin-play.png

Offline

Board footer