The officially official Devuan Forum!

You are not logged in.

#1 2020-04-20 22:40:24

PengouinPdt
Member
From: France
Registered: 2020-04-20
Posts: 15  
Website

[Ceres] kernel 5.5.0-2: sound problem

Hi

I run Devuan Ceres on amd64 architecture, with Xfce as DE.

$ uname -a
Linux *** 5.5.0-2-amd64 #1 SMP Debian 5.5.17-1 (2020-04-15) x86_64 GNU/Linux

With the kernel 5.4.0-4, I have not any specific problem; but with the kernels 5.5.0-(1|2), I have this trouble: no sound with firefox (or videoconf, as zoom), egual for VLC.
If I download a video, or one music, I have not sound on the file!
Terrible!
(and, yes, the sound volume is open, at audible level).

But, If I use Audacious, I can hear the music!

I known, it's weird.

---

PS: FYI, I used since severals years Debian Sid, or *Buntu liked… (or OpenBSD).

Last edited by PengouinPdt (2020-04-23 14:16:32)

Offline

#2 2020-04-21 13:35:25

aus9
Member
Registered: 2020-03-24
Posts: 37  

Re: [Ceres] kernel 5.5.0-2: sound problem

Hi

Not using that variant but until you get a better reply....maybe firefox run from a terminal might show some errors?

If none seen....and if you don't mind a little bit of logging into sites
delete the
.cache/mozilla
.mozilla

in case stale files are interfering?

Offline

#3 2020-04-21 14:31:00

xinomilo
Member
Registered: 2017-07-02
Posts: 117  

Re: [Ceres] kernel 5.5.0-2: sound problem

no problem here with MATE DE. you can also check ~/.xsession-errors file for related messages, and also try to run
$ apulse firefox , to see if that works...

lots of related messages in this forum to look more info : https://dev1galaxy.org/search.php?search_id=392925050

Offline

#4 2020-04-23 14:15:32

PengouinPdt
Member
From: France
Registered: 2020-04-20
Posts: 15  
Website

Re: [Ceres] kernel 5.5.0-2: sound problem

OK, I purged .cache/mozilla/firefox.

I Installed apulse. Always no sound!

$ apulse firefox
[apulse] [error] do_connect_pcm: can't get initial hw parameters for playback device "default". Error code 1 (Operation not permitted)
[apulse] [error] do_connect_pcm: failed to open ALSA device. Apulse does no resampling or format conversion, leaving that task to ALSA plugins. Ensure that selected device is capable of playing a particular sample format at a particular rate. They have to be supported by either hardware directly, or by "plug" and "dmix" ALSA plugins which will perform required conversions on CPU.
[Child 3677, MediaDecoderStateMachine #1] WARNING: 7f14f5e89160 OpenCubeb() failed to init cubeb: file /build/firefox-0xX3lf/firefox-75.0/dom/media/AudioStream.cpp, line 328
[Child 3677, MediaDecoderStateMachine #1] WARNING: Decoder=7f14f5ef2800 [OnMediaSinkAudioError]: file /build/firefox-0xX3lf/firefox-75.0/dom/media/MediaDecoderStateMachine.cpp, line 3758

With apulse, video on firefox runs, but always without sound!

With VLC:

[0000556633e77470] vlcpulse audio output error: stream connection failure: Oops.
[0000556633e77470] main audio output error: module not functional
[00007fc2cd008b10] main decoder error: failed to create audio output
[apulse] [error] do_connect_pcm: can't open playback device "default". Error code -5 (Erreur d'entrée/sortie)
[apulse] [error] do_connect_pcm: failed to open ALSA device. Apulse does no resampling or format conversion, leaving that task to ALSA plugins. Ensure that selected device is capable of playing a particular sample format at a particular rate. They have to be supported by either hardware directly, or by "plug" and "dmix" ALSA plugins which will perform required conversions on CPU.
[0000556633e77470] vlcpulse audio output error: stream connection failure: Oops.
[0000556633e77470] main audio output error: module not functional
[00007fc2cd008b10] main decoder error: failed to create audio output
[00007fc2d0004680] glconv_vaapi_x11 gl error: vaAcquireBufferHandle: invalid VABufferID
[00007fc2d0004680] glconv_vaapi_x11 gl error: vaAcquireBufferHandle: invalid VABufferID
[00007fc2d0004680] glconv_vaapi_x11 gl error: vaAcquireBufferHandle: invalid VABufferID
[00007fc2d0004680] glconv_vaapi_x11 gl error: vaAcquireBufferHandle: invalid VABufferID
[00007fc2d0004680] glconv_vaapi_x11 gl error: vaAcquireBufferHandle: invalid VABufferID
[00007fc2cc00a5a0] filesystem stream error: read error: Cannot allocate memory
[00007fc2cc00a5a0] filesystem stream error: read error: Cannot allocate memory
[apulse] [error] do_connect_pcm: can't open playback device "default". Error code -5 (Erreur d'entrée/sortie)
[apulse] [error] do_connect_pcm: failed to open ALSA device. Apulse does no resampling or format conversion, leaving that task to ALSA plugins. Ensure that selected device is capable of playing a particular sample format at a particular rate. They have to be supported by either hardware directly, or by "plug" and "dmix" ALSA plugins which will perform required conversions on CPU.
[0000556633e77470] vlcpulse audio output error: stream connection failure: Oops.
[0000556633e77470] main audio output error: module not functional
[00007fc2cd008b10] main decoder error: failed to create audio output
[h264 @ 0x7fc2ccf94500] get_buffer() failed
[h264 @ 0x7fc2ccf94500] thread_get_buffer() failed
[h264 @ 0x7fc2ccf94500] decode_slice_header error
[h264 @ 0x7fc2ccf94500] no frame!
[h264 @ 0x7fc2ccfa3fc0] get_buffer() failed
[h264 @ 0x7fc2ccfa3fc0] thread_get_buffer() failed
[h264 @ 0x7fc2ccfa3fc0] decode_slice_header error
[h264 @ 0x7fc2ccfa3fc0] no frame!
[00007fc2d40c6ea0] filesystem stream error: read error: Cannot allocate memory
[00007fc2d40c9520] cache_read stream error: cannot pre fill buffer
(...)

@xinomilo: you link seems to be fault:

Désolé, aucun résultat n'a été trouvé pour votre recherche

----

And I repeat, with kernel 5.4.0-x, this run without no problem; sounds and video files are OK!
All run correctly (Firefox, VLC, Zoom, and others)!

Last edited by PengouinPdt (2020-04-23 14:54:24)

Offline

#5 2020-04-25 01:34:55

aus9
Member
Registered: 2020-03-24
Posts: 37  

Re: [Ceres] kernel 5.5.0-2: sound problem

Hi

sorry for late reply.

vlc tends to use "default" as the default audio device on next boot up.
If vlc was using pulseaudio then that is what default is....ditto if you used alsa...that is what default is.
Can you try

vlc -> Tools -> Preferences -> Select Audio TAB  -> pulldown output and choose Alsa
pulldown device and choose the analog device....I am not sure what your choices are but mine have alsa, surround sound and hdmi
click save
and retest sound

Offline

#6 2020-05-06 18:51:15

PengouinPdt
Member
From: France
Registered: 2020-04-20
Posts: 15  
Website

Re: [Ceres] kernel 5.5.0-2: sound problem

Just FYI: With the new kernel Linux 5.6.0-1-amd64 #1 SMP Debian 5.6.7-1 (2020-04-29) x86_64 GNU/Linux, it seems run correctly!

Amazing!?!

Offline

Board footer