The officially official Devuan Forum!

You are not logged in.

#1 2017-06-10 15:38:45

Kiergan
Member
Registered: 2017-05-31
Posts: 3  

Setting up Webmin - hangs, any tips, help?

Hi,

I want to install Webmin (1.840) like I do on all my boxes but the setup hangs after
.
.
.
** Initializing cache.
Setting up webmin (1.840) .....
nothing more after that.

Most likely it expects systemd, because I did not see this line show up during the installation process, where it does show up when I install it on Debian 8.8.

I know that Webmin used to install fine on Wheezy, and probably still does, so it should be not too hard to make this work.(?)
But I do not know all that much about Linux, but sysadmin for windows for many years does mean I can read and follow instructions.

Anyone able to give some tips or help?
That would be very much appreciated.

I really would like to be able to change all my boxes to Devuan in the near future.

Offline

#2 2017-06-10 20:56:05

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 65  

Re: Setting up Webmin - hangs, any tips, help?

Yea, this caused me all kinds of frustrations almost two years ago when I first started using devuan.  I think the problem is that webmin does not support devuan (yet?) as an acceptable installation.  However, it can be installed but not as easy as with a simple command(s).  I explain it as simply as I can in this article:
Install webmin

I have used webmin for over a couple years on devuan.  It works fine, however, after installing webmin, you may need to configure some program paths in the modules configurations.

Edit:  You will have to first uninstall webmin completely before following the directions contained in the link above.

Last edited by nixer (2017-06-10 21:01:56)

Online

Board footer