The officially official Devuan Forum!

You are not logged in.

#1 2020-04-12 06:17:48

toru
Member
Registered: 2020-04-12
Posts: 15  

Problem with installing tin of all things during 3.0 beta installation

Here's the error log:

Apr 11 05:54:58 in-target: Setting up nvidia-driver (418.74-1) ...^M
Apr 11 05:54:58 in-target: Processing triggers for menu (2.1.47+b1) ...^M
Apr 11 05:55:00 in-target: Processing triggers for dbus (1.12.16-1+devuan2) ...^M
Apr 11 05:55:00 in-target: Processing triggers for dictionaries-common (1.28.1) ...^M
Apr 11 05:55:03 in-target: aspell-autobuildhash: processing: en [en-common].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en-variant_0].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en-variant_1].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en-variant_2].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en-w_accents-only].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en-wo_accents-only].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en_AU-variant_0].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en_AU-variant_1].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en_AU-w_accents-only].^M
Apr 11 05:55:05 in-target: aspell-autobuildhash: processing: en [en_AU-wo_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_CA-variant_0].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_CA-variant_1].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_CA-w_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_CA-wo_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_GB-ise-w_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_GB-ise-wo_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_GB-ize-w_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_GB-ize-wo_accents-only].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_GB-variant_0].^M
Apr 11 05:55:06 in-target: aspell-autobuildhash: processing: en [en_GB-variant_1].^M
Apr 11 05:55:07 in-target: aspell-autobuildhash: processing: en [en_US-w_accents-only].^M
Apr 11 05:55:07 in-target: aspell-autobuildhash: processing: en [en_US-wo_accents-only].^M
Apr 11 05:55:08 in-target: Processing triggers for ca-certificates (20190110) ...^M
Apr 11 05:55:08 in-target: Updating certificates in /etc/ssl/certs...^M
Apr 11 05:55:11 in-target: 0 added, 0 removed; done.^M
Apr 11 05:55:11 in-target: Running hooks in /etc/ca-certificates/update.d...^M
Apr 11 05:55:11 in-target: ^M
Apr 11 05:55:13 in-target: done.^M
Apr 11 05:55:13 in-target: done.^M
Apr 11 05:55:13 in-target: Processing triggers for libvlc-bin:amd64 (3.0.8-0+deb10u1) ...^M
Apr 11 05:55:16 in-target: Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.38.1+dfsg-1) ...^M
Apr 11 05:55:16 in-target: Processing triggers for libc-bin (2.28-10) ...^M
Apr 11 05:55:17 in-target: Processing triggers for initramfs-tools (0.133+deb10u1) ...^M
Apr 11 05:55:17 in-target: update-initramfs: Generating /boot/initrd.img-4.19.0-8-amd64^M
Apr 11 05:55:36 in-target: Processing triggers for update-glx (1.0.0) ...^M
Apr 11 05:55:37 in-target: Processing triggers for glx-alternative-nvidia (1.0.0) ...^M
Apr 11 05:55:37 in-target: update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode^M
Apr 11 05:55:37 in-target: Processing triggers for glx-alternative-mesa (1.0.0) ...^M
Apr 11 05:55:37 in-target: Processing triggers for libc-bin (2.28-10) ...^M
Apr 11 05:55:38 in-target: Processing triggers for initramfs-tools (0.133+deb10u1) ...^M
Apr 11 05:55:38 in-target: update-initramfs: Generating /boot/initrd.img-4.19.0-8-amd64^M
Apr 11 05:55:52 in-target: Errors were encountered while processing:^M
Apr 11 05:55:52 in-target:  tin^M
Apr 11 05:55:53 in-target: E
Apr 11 05:55:53 in-target: : Sub-process /usr/bin/dpkg returned an error code (1)
Apr 11 05:55:53 in-target: tasksel: apt-get failed (100)
Apr 11 05:55:53 in-target: Setting up tin (1:2.4.3-1) ...
Apr 11 05:55:54 in-target: hostname: Name or service not known
Apr 11 05:55:54 in-target: dpkg: error processing package tin (--configure):
Apr 11 05:55:54 in-target:  installed tin package post-installation script subprocess returned error exit status 1
Apr 11 05:55:54 in-target: Errors were encountered while processing:
Apr 11 05:55:54 in-target:  tin
Apr 11 05:55:54 main-menu[490]: (process:10523): dpkg-divert: warning: diverting file '/sbin/start-stop-daemon' from an Essential package with rename is dangerous, use --no-rename
Apr 11 05:55:54 main-menu[490]: (process:10523): dpkg-divert: warning: diverting file '/sbin/start-stop-daemon' from an Essential package with rename is dangerous, use --no-rename
Apr 11 05:55:54 main-menu[490]: (process:10523): dpkg-divert: warning: diverting file '/sbin/start-stop-daemon' from an Essential package with rename is dangerous, use --no-rename
Apr 11 05:55:54 main-menu[490]: WARNING **: Configuring 'pkgsel' failed with error code 1
Apr 11 05:55:54 main-menu[490]: WARNING **: Menu item 'pkgsel' failed.

Based on the error log, I think it could be that what happened is that because I didn't set up networking during the install (I had no internet access at the time), and tin wasn't ready to handle that, this happened.  But I'm not so sure that that's what's going on.  If it is, it still seems like something that I should report to the people maintaining this distro.  But would someone shed some light on this?

I appreciate the work at maintaining this distro, I appreciate this distro, and for over a year now it has been my distro of choice.  And thanks for any help I may get.

Last edited by toru (2020-04-12 06:20:50)

Offline

#2 2020-04-12 07:33:05

aus9
Member
Registered: 2020-03-24
Posts: 37  

Re: Problem with installing tin of all things during 3.0 beta installation

I am not in the dev team but can I make some suggestions

1) depending on whether you use sudo or su -, use root powers to

apt update
apt dist-upgrade

and see what happens

2) report what happens with root powers when you run

update-initramfs -u

I show mine
update-initramfs: Generating /boot/initrd.img-4.19.0-8-amd64
I: The initramfs will attempt to resume from /dev/sda2
I: (UUID=string deleted)
I: Set the RESUME variable to override this.
live-boot: core filesystems devices utils udev blockdev dns.

Offline

#3 2020-04-12 08:25:37

toru
Member
Registered: 2020-04-12
Posts: 15  

Re: Problem with installing tin of all things during 3.0 beta installation

Ohhh, no that installation of Beowulf never completed.  It couldn't complete because tin was not installed properly.  I didn't install a bootloader either.

I guess it is probably true that I COULD try booting the incomplete install using some other hard drive's bootloader, though...  If it would help, I'll try that...  Soon or so.  Thanks.

Last edited by toru (2020-04-12 08:26:12)

Offline

#4 2020-04-12 15:58:37

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,503  

Re: Problem with installing tin of all things during 3.0 beta installation

What iso did you use? Lack of network is not the issue. I just installed from the desktop installer iso (dvd) without a mirror, included Console Productivity to get tin, and it installed fine.

You could boot the installer media into Rescue mode and (re)install the bootloader.

Offline

#5 2020-04-17 10:23:15

toru
Member
Registered: 2020-04-12
Posts: 15  

Re: Problem with installing tin of all things during 3.0 beta installation

I used "devuan_beowulf_3.0.0_beta_amd64_desktop.iso" dated 2020-Mar-13 06:06, it seems.

Thanks for letting me know that tin is part of Console Productivity.  To be honest I selected that option this time not knowing what it did, but wanting to find out.  This means that if I need to install devuan beowulf and this issue would otherwise get in my way, I can now just deselect this option and perhaps it will work.

I looked it up just now and found this:
"In addition, there are options for “Console productivity” with hundreds of CLI and TUI utils, as well as a minimal base system ideal for servers."
I am not so clear on what this means.

From what you said, you did something similar to me.

Rescue mode, apparently I missed this option.  My bad for being obtuse.  I installed the system on expert mode, yet I missed something like this.

I am going to go boot the system and see what I get from the commands the previous person gave.

I apologize for the wait time that I created before posting.

Last edited by toru (2020-04-17 10:24:21)

Offline

#6 2020-04-17 10:38:35

toru
Member
Registered: 2020-04-12
Posts: 15  

Re: Problem with installing tin of all things during 3.0 beta installation

I think it said something like 'gave up waiting for root file system device' and went into a shell, not completing the boot to begin with.  The shell I was given said initramfs I think and had very limited functionality - it did not even have "shutdown."

Apparently the system was not even able to generate a syslog.

Seeing as the installation was only interrupted late into the Select and Install Software step, I thought surely the OS would at least boot properly, and I'm not sure why this didn't.

It isn't that big a deal though.  If I successfully finish installing Beowulf, I imagine it would at least boot properly...

Offline

Board footer