The officially official Devuan Forum!

You are not logged in.

#1 2020-02-14 11:08:01

stecco
Member
Registered: 2020-01-24
Posts: 14  

SOLVED - Enable tapping on touchpad

I followed this

https://wiki.debian.org/SynapticsTouchp … n_touchpad

In Devuan ASCII there is already a 40-libinput.conf file:

~$ cat  /usr/share/X11/xorg.conf.d/40-libinput.conf
# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
	Option "Tapping" "True"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

and seems that the tapping option is active. However I tried to change Option "Tapping" "True" to Option "Tapping" "on" but it still doesn't work. Any suggest?

Last edited by stecco (2020-02-15 17:07:16)

Offline

#2 2020-02-14 18:51:23

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 502  
Website

Re: SOLVED - Enable tapping on touchpad

No you didn't. That guide advises to create a new file at /etc/X11/xorg.conf.d/40-libinput.conf with the suggested content. But you need to run the commands as root for them to work.

Or with sudo:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo tee /etc/X11/xorg.conf.d/40-libinput.conf <<END
Section "InputClass"
   Identifier "libinput touchpad catchall"
   MatchIsTouchpad "on"
   MatchDevicePath "/dev/input/event*"
   Driver "libinput"
   Option "Tapping" "on"
EndSection
END

You've added your configuration to the pointer section rather than the touchpad section, which is why it doesn't work. And using /usr/share/X11/xorg.conf.d/40-libinput.conf means your changes will be over-written if the xserver-xorg-input-libinput package is upgraded.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#3 2020-02-15 17:06:37

stecco
Member
Registered: 2020-01-24
Posts: 14  

Re: SOLVED - Enable tapping on touchpad

Sorry Head_on_a_Stick you are totally right, my mistake. Now the tapping works perfectly.

Offline

Board footer