The officially official Devuan Forum!

You are not logged in.

#1 2020-02-11 15:31:17

stecco
Member
Registered: 2020-01-24
Posts: 14  

SOLVED - Wi-Fi oddity

Every time I turn on my laptop, there is no internet connection.

I have to [Switch On Wi-Fi] pressing the button

Screenshot-2020-02-11-15-35-01.png

then I have to [Refresh]

Screenshot-2020-02-11-15-35-55.png

Only after this i can select my ESSID and connect to my network.

It's the first time I have a problem like this one.

Probably this issue is related rfkill, this is the situation when I tun on my laptop:

~# rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no

And this after the [Switch On Wi-Fi] and [Refresh] procedure

~# rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Obviously I already tried

~# rfkill unblock all

and this worked too, but I have to do it every time I turn on my laptop... Super annoynig.

Last edited by stecco (2020-02-14 10:55:34)

Offline

#2 2020-02-11 17:02:21

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 688  
Website

Re: SOLVED - Wi-Fi oddity

stecco wrote:

Obviously I already tried

~# rfkill unblock all

and this worked too, but I have to do it every time I turn on my laptop... Super annoynig.

What is the status of the rfkill kernel module?

cat /sys/module/rfkill/parameters/default_state

It should be "1", if it's "0" then change that by creating a file at /etc/modprobe.d/rfkill.conf with this content:

options rfkill default_state=1

"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#3 2020-02-11 19:21:23

stecco
Member
Registered: 2020-01-24
Posts: 14  

Re: SOLVED - Wi-Fi oddity

~$ cat /sys/module/rfkill/parameters/default_state
1

It's 1

Offline

#4 2020-02-11 20:04:46

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 688  
Website

Re: SOLVED - Wi-Fi oddity

Good.

You can add the rfkill command to /etc/rc.local to get it to run automatically on boot. Or make a custom service to run it if you want more control.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#5 2020-02-12 00:03:35

stecco
Member
Registered: 2020-01-24
Posts: 14  

Re: SOLVED - Wi-Fi oddity

I never edited rc.local nor created custom services before. Can you tell me how to do it or at least where I can find any good documentation to do that?

Offline

#6 2020-02-12 05:52:15

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 688  
Website

Re: SOLVED - Wi-Fi oddity

stecco wrote:

Can you tell me how to do it

Just add your rfkill command on a single line at the end of the file at /etc/rc.local


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#7 2020-02-14 10:55:09

stecco
Member
Registered: 2020-01-24
Posts: 14  

Re: SOLVED - Wi-Fi oddity

Thank you Head_on_a_Stick now finally everything works.

Offline

Board footer