The officially official Devuan Forum!

You are not logged in.

#1 2020-02-01 18:10:38

uther
Member
Registered: 2019-05-16
Posts: 32  

[SOLVED] ASCII -> Beowulf xfce migration on AMD gpu machine xorg error

Migration from ASCII -> Beowulf performed on fresh install throws xorg error after reboot. This happens only on systems with AMD graphics cards.
Tried several different approaches including updating kernel to 4.19.0-6, 5.3 and 5.4 backports before apt full-upgrade - same effect.

In the log I can see two errors. One is related to systemd, and the rest to AMD GPU. I've tried to solve this by installing elogind, and missing amdgpu related packages, and it succeded on a laptop with the following:

apt update
apt full-upgrade
apt --fix-broken install 
apt install firmware-amd-graphics
apt install elogind
apt install reinstall xserver-xorg-video-ati xserver-xorg-core
dpkg reconfigure xserver-xorg

But this doesn't work on second machine with different AMD GPU:

[  1787.824] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[  1787.826] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[  1787.827] Current Operating System: Linux user 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
[  1787.827] Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.0-11-amd64 root=/dev/mapper/user--vg-root ro quiet
[  1787.829] Build Date: 05 March 2019  08:11:12PM
[  1787.830] xorg-server 2:1.20.4-1 (https://www.debian.org/support) 
[  1787.830] Current version of pixman: 0.36.0
[  1787.832] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  1787.832] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1787.835] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 30 20:33:13 2020
[  1787.836] (==) Using config file: "/etc/X11/xorg.conf"
[  1787.837] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1787.837] (==) ServerLayout "X.org Configured"
[  1787.837] (**) |-->Screen "Screen0" (0)
[  1787.837] (**) |   |-->Monitor "Monitor0"
[  1787.838] (**) |   |-->Device "Card0"
[  1787.838] (**) |-->Screen "Screen1" (1)
[  1787.838] (**) |   |-->Monitor "Monitor1"
[  1787.838] (**) |   |-->Device "Card1"
[  1787.838] (**) |-->Screen "Screen2" (2)
[  1787.838] (**) |   |-->Monitor "Monitor2"
[  1787.838] (**) |   |-->Device "Card2"
[  1787.838] (**) |-->Screen "Screen3" (3)
[  1787.838] (**) |   |-->Monitor "Monitor3"
[  1787.838] (**) |   |-->Device "Card3"
[  1787.838] (**) |-->Input Device "Mouse0"
[  1787.838] (**) |-->Input Device "Keyboard0"
[  1787.838] (==) Automatically adding devices
[  1787.838] (==) Automatically enabling devices
[  1787.838] (==) Automatically adding GPU devices
[  1787.838] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1787.838] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1787.838] 	Entry deleted from font path.
[  1787.838] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1787.838] 	Entry deleted from font path.
[  1787.838] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[  1787.838] (**) ModulePath set to "/usr/lib/xorg/modules"
[  1787.838] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1787.838] (WW) Disabling Mouse0
[  1787.838] (WW) Disabling Keyboard0
[  1787.838] (II) Loader magic: 0x558bb041de20
[  1787.838] (II) Module ABI versions:
[  1787.838] 	X.Org ANSI C Emulation: 0.4
[  1787.838] 	X.Org Video Driver: 24.0
[  1787.838] 	X.Org XInput driver : 24.1
[  1787.838] 	X.Org Server Extension : 10.0
[  1787.839] (++) using VT number 1

[  1787.839] (EE) systemd-logind: failed to get session: The name org.freedesktop.login1 was not provided by any .service files
[  1787.847] (--) PCI:*(3@0:0:0) 1002:66af:1002:081e rev 193, Mem @ 0xd0000000/268435456, 0xe0000000/2097152, 0xe1d00000/524288, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[  1787.847] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  1787.847] (II) LoadModule: "glx"
[  1787.847] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1787.848] (II) Module glx: vendor="X.Org Foundation"
[  1787.848] 	compiled for 1.20.4, module version = 1.0.0
[  1787.848] 	ABI class: X.Org Server Extension, version 10.0
[  1787.848] (II) LoadModule: "amdgpu"
[  1787.848] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[  1787.848] (II) Module amdgpu: vendor="X.Org Foundation"
[  1787.848] 	compiled for 1.20.3, module version = 18.1.99
[  1787.848] 	Module class: X.Org Video Driver
[  1787.848] 	ABI class: X.Org Video Driver, version 24.0
[  1787.848] (II) AMDGPU: Driver for AMD Radeon:
	All GPUs supported by the amdgpu kernel driver
[  1787.848] (II) AMDGPU(0): [KMS] drm report modesetting isn't supported.
[  1787.848] (II) AMDGPU(1): [KMS] drm report modesetting isn't supported.
[  1787.848] (II) AMDGPU(2): [KMS] drm report modesetting isn't supported.
[  1787.848] (II) AMDGPU(3): [KMS] drm report modesetting isn't supported.
[  1787.848] (EE) Screen 0 deleted because of no matching config section.
[  1787.848] (II) UnloadModule: "amdgpu"
[  1787.848] (EE) Screen 0 deleted because of no matching config section.
[  1787.848] (II) UnloadModule: "amdgpu"
[  1787.848] (EE) Screen 0 deleted because of no matching config section.
[  1787.848] (II) UnloadModule: "amdgpu"
[  1787.848] (EE) Screen 0 deleted because of no matching config section.
[  1787.848] (II) UnloadModule: "amdgpu"
[  1787.848] (EE) Device(s) detected, but none match those in the config file.
[  1787.848] (EE) 
Fatal server error:
[  1787.848] (EE) no screens found(EE) 
[  1787.848] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  1787.848] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1787.848] (EE) 
[  1787.856] (EE) Server terminated with error (1). Closing log file.

Please forgive me my brute-force approach. Never had to troubleshoot xorg before smile

Last edited by uther (2020-02-02 11:10:47)

Offline

#2 2020-02-01 19:05:57

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: [SOLVED] ASCII -> Beowulf xfce migration on AMD gpu machine xorg error

uther wrote:
[  1787.836] (==) Using config file: "/etc/X11/xorg.conf"

^ Remove that file and let X auto-configure.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#3 2020-02-01 23:23:20

uther
Member
Registered: 2019-05-16
Posts: 32  

Re: [SOLVED] ASCII -> Beowulf xfce migration on AMD gpu machine xorg error

Thanks Head_on_a_Stick. I've performed another clean install & upgrade. Unfortunately there was no such file before and after apt full-uprade.
X -configure gives me pretty empty /root/xorg.conf.new:

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	Screen      2  "Screen2" RightOf "Screen1"
	Screen      3  "Screen3" RightOf "Screen2"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor2"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Monitor"
	Identifier   "Monitor3"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "SubPixelOrder"      	# [<str>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI3"               	# [<bool>]
        #Option     "DRI"                	# <i>
        #Option     "ShadowPrimary"      	# [<bool>]
        #Option     "TearFree"           	# [<bool>]
        #Option     "DeleteUnusedDP12Displays" 	# [<bool>]
        #Option     "VariableRefresh"    	# [<bool>]
	Identifier  "Card0"
	Driver      "amdgpu"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "SubPixelOrder"      	# [<str>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI3"               	# [<bool>]
        #Option     "DRI"                	# <i>
        #Option     "ShadowPrimary"      	# [<bool>]
        #Option     "TearFree"           	# [<bool>]
        #Option     "DeleteUnusedDP12Displays" 	# [<bool>]
        #Option     "VariableRefresh"    	# [<bool>]
	Identifier  "Card1"
	Driver      "amdgpu"
	BusID       "PCI:2:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "SubPixelOrder"      	# [<str>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI3"               	# [<bool>]
        #Option     "DRI"                	# <i>
        #Option     "ShadowPrimary"      	# [<bool>]
        #Option     "TearFree"           	# [<bool>]
        #Option     "DeleteUnusedDP12Displays" 	# [<bool>]
        #Option     "VariableRefresh"    	# [<bool>]
	Identifier  "Card2"
	Driver      "amdgpu"
	BusID       "PCI:3:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "SubPixelOrder"      	# [<str>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI3"               	# [<bool>]
        #Option     "DRI"                	# <i>
        #Option     "ShadowPrimary"      	# [<bool>]
        #Option     "TearFree"           	# [<bool>]
        #Option     "DeleteUnusedDP12Displays" 	# [<bool>]
        #Option     "VariableRefresh"    	# [<bool>]
	Identifier  "Card3"
	Driver      "amdgpu"
	BusID       "PCI:3:0:1"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen2"
	Device     "Card2"
	Monitor    "Monitor2"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen3"
	Device     "Card3"
	Monitor    "Monitor3"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

When I try to run it with X -config /root/xorg.conf.new I'm getting:

[   544.109] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[   544.112] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[   544.113] Current Operating System: Linux user 4.19.0-0.bpo.6-rt-amd64 #1 SMP PREEMPT RT Debian 4.19.67-2+deb10u2~bpo9+1 (2019-11-12) x86_64
[   544.113] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19.0-0.bpo.6-rt-amd64 root=/dev/mapper/user--vg-root ro quiet
[   544.114] Build Date: 05 March 2019  08:11:12PM
[   544.115] xorg-server 2:1.20.4-1 (https://www.debian.org/support) 
[   544.115] Current version of pixman: 0.36.0
[   544.116] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   544.116] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   544.119] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb  1 23:54:08 2020
[   544.119] (++) Using config file: "/root/xorg.conf.new"
[   544.120] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   544.120] (==) ServerLayout "X.org Configured"
[   544.120] (**) |-->Screen "Screen0" (0)
[   544.120] (**) |   |-->Monitor "Monitor0"
[   544.120] (**) |   |-->Device "Card0"
[   544.120] (**) |-->Screen "Screen1" (1)
[   544.120] (**) |   |-->Monitor "Monitor1"
[   544.120] (**) |   |-->Device "Card1"
[   544.120] (**) |-->Screen "Screen2" (2)
[   544.120] (**) |   |-->Monitor "Monitor2"
[   544.121] (**) |   |-->Device "Card2"
[   544.121] (**) |-->Screen "Screen3" (3)
[   544.121] (**) |   |-->Monitor "Monitor3"
[   544.121] (**) |   |-->Device "Card3"
[   544.121] (**) |-->Input Device "Mouse0"
[   544.121] (**) |-->Input Device "Keyboard0"
[   544.121] (==) Automatically adding devices
[   544.121] (==) Automatically enabling devices
[   544.121] (==) Automatically adding GPU devices
[   544.121] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   544.121] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   544.121] 	Entry deleted from font path.
[   544.121] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   544.121] 	Entry deleted from font path.
[   544.121] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[   544.121] (**) ModulePath set to "/usr/lib/xorg/modules"
[   544.121] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   544.121] (WW) Disabling Mouse0
[   544.121] (WW) Disabling Keyboard0
[   544.121] (II) Loader magic: 0x5574c7c6be20
[   544.121] (II) Module ABI versions:
[   544.121] 	X.Org ANSI C Emulation: 0.4
[   544.121] 	X.Org Video Driver: 24.0
[   544.121] 	X.Org XInput driver : 24.1
[   544.121] 	X.Org Server Extension : 10.0
[   544.122] (--) using VT number 7

[   544.122] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   544.133] (--) PCI:*(3@0:0:0) 1002:66af:1002:081e rev 193, Mem @ 0xd0000000/268435456, 0xe0000000/2097152, 0xe1d00000/524288, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[   544.133] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   544.133] (II) LoadModule: "glx"
[   544.133] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   544.134] (II) Module glx: vendor="X.Org Foundation"
[   544.134] 	compiled for 1.20.4, module version = 1.0.0
[   544.134] 	ABI class: X.Org Server Extension, version 10.0
[   544.134] (II) LoadModule: "amdgpu"
[   544.134] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[   544.134] (II) Module amdgpu: vendor="X.Org Foundation"
[   544.134] 	compiled for 1.20.3, module version = 18.1.99
[   544.134] 	Module class: X.Org Video Driver
[   544.134] 	ABI class: X.Org Video Driver, version 24.0
[   544.134] (II) AMDGPU: Driver for AMD Radeon:
	All GPUs supported by the amdgpu kernel driver
[   544.138] (II) AMDGPU(0): [KMS] drm report modesetting isn't supported.
[   544.138] (II) AMDGPU(1): [KMS] drm report modesetting isn't supported.
[   544.139] (II) AMDGPU(2): [KMS] drm report modesetting isn't supported.
[   544.139] (II) AMDGPU(3): [KMS] drm report modesetting isn't supported.
[   544.139] (EE) Screen 0 deleted because of no matching config section.
[   544.139] (II) UnloadModule: "amdgpu"
[   544.139] (EE) Screen 0 deleted because of no matching config section.
[   544.139] (II) UnloadModule: "amdgpu"
[   544.139] (EE) Screen 0 deleted because of no matching config section.
[   544.139] (II) UnloadModule: "amdgpu"
[   544.139] (EE) Screen 0 deleted because of no matching config section.
[   544.139] (II) UnloadModule: "amdgpu"
[   544.139] (EE) Device(s) detected, but none match those in the config file.
[   544.139] (EE) 
Fatal server error:
[   544.139] (EE) no screens found(EE) 
[   544.139] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   544.139] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   544.139] (EE) 
[   544.154] (EE) Server terminated with error (1). Closing log file.

Offline

#4 2020-02-02 00:17:04

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: [SOLVED] ASCII -> Beowulf xfce migration on AMD gpu machine xorg error

uther wrote:

X -configure

Don't use that, it is obsolete.

Try again with no X.Org configuration files at all (except those supplied by packages and stored under /usr/share/X11/xorg.conf.d/).

And you have installed the non-free firmware required by your video cards, right?

EDIT: and make sure there isn't a nomodeset kernel command line parameter applied, AMD cards won't work without kernel modesetting.

Last edited by Head_on_a_Stick (2020-02-02 00:18:28)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#5 2020-02-02 11:09:53

uther
Member
Registered: 2019-05-16
Posts: 32  

Re: [SOLVED] ASCII -> Beowulf xfce migration on AMD gpu machine xorg error

Head_on_a_Stick wrote:

Try again with no X.Org configuration files at all (except those supplied by packages and stored under /usr/share/X11/xorg.conf.d/).

It worked! Thanks again.

Offline

Board footer