The officially official Devuan Forum!

You are not logged in.

#1 2020-01-25 14:30:20

asgalon
Member
Registered: 2020-01-18
Posts: 1  

upgrading from ascii to beowulf, libpolkit-qt5-1-1 stuck (solved)

Hi, after upgrading from ascii to beowulf, I had libpolkit-qt5-1-1 stuck at version 0.112.0-05 and the XFCE session buttons for shutdown and reboot were greyed out, which has been puzzling me for two weeks now. Apparently during the upgrade process I got consolekit reinstalled and elogind probably  removed, and the libpolkit-qt-1-1 packages on hold for dependency conflicts, which for some reason or other looked very difficult to fix in aptitude. Simply installing elogind, which eliminates consolekit, solved everything. libpolkit-qt5-1-1 is a dependency of libkfm_auth5, which in my case was an indirect dependency of digikam.
Not sure how that got tangled up during the upgrade, like so often I forgot to start script on the shell before starting the process. Anyway, I have been searching for solutions and came up quite empty, so maybe this helps someone...

Offline

#2 2020-01-25 14:47:33

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 767  
Website

Re: upgrading from ascii to beowulf, libpolkit-qt5-1-1 stuck (solved)

See also https://dev1galaxy.org/viewtopic.php?pid=19567#p19567

tl;dr: libpolkit-qt5-1-1 has a dependency on libpam-systemd, which doesn't exist in Devuan.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#3 2020-06-28 23:47:22

bugb
Member
Registered: 2020-06-28
Posts: 2  

Re: upgrading from ascii to beowulf, libpolkit-qt5-1-1 stuck (solved)

Reading this again, it's not the same problem I have but I guess it's related. Since the upgrade Synaptic shows libpolkit-qt5-1-1 and libpolkit-qt-1-1 can be upgraded. However, when I go to upgrade them, it says three things need to be removed which include lvm2. Shutdown is gone from the main menu. Any guidance here please?

Offline

#4 2020-06-29 19:34:45

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 767  
Website

Re: upgrading from ascii to beowulf, libpolkit-qt5-1-1 stuck (solved)

Did you try aptitude? Synaptic is useless for this sort of thing.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#5 2020-06-30 03:07:35

bugb
Member
Registered: 2020-06-28
Posts: 2  

Re: upgrading from ascii to beowulf, libpolkit-qt5-1-1 stuck (solved)

Okay, I got it. My first post was basically trying to fix the problem OP had before it had happened. When I upgraded packages with aptitude it held back both libpolkit packages. Then I just installed elogind. Shut Down is in the main menu now. The whole thing just made me nervous. The fact that, using synaptic, to upgrade the libpolkit packages lvm2 needed to be removed. There was a long list of stuff it wanted to remove to install elogind.

I did not know about aptitude. It looks interesting. Thank you for your help.

Offline

Board footer