The officially official Devuan Forum!

You are not logged in.

#1 2020-01-09 10:39:46

Geoff 42
Member
Registered: 2016-12-15
Posts: 296  

Migrating from ASCII LXDE to Beowulf LXQt

I have a laptop running Beowulf and Lxdm/LXQt and I want to migrate my desktop from ASCII and LXDE/Lxdm to the same as the laptop, as it seems that LXQt works a bit more smoothly with the policykit set-ups available. I do have a few other things running under ASCII (including Postgresql, Postfix), so want to be a bit careful.

The plan was to move over to LXQt from LXDE, whilst still under ASCII and then ensure that the policykit stuff was set up correctly.

I currently have the following installed :-

elogind
libelogind0
libpam-elogind

consolekit
libck-connector0
libpolkit-backend-consolekit-1-0
libpolkit-gobject-consolekit-1-0

This is working with LXDE/Lxdm. It also seems to work ok with LXQt/Lxdm.

Moving to LXQt works, but it did take quite a bit of fiddling to get it running as I like it. I use spacefm instead of pcmanfm, which also looks after the desktop wallpaper. To get this running I went into Preferences>LXQt settings>Session settings

Under Basic Settings, I turned off Desktop, which is the module for pcmanfm, with the other modules all selected.
Under Autostart LXQt Autostart I added spacefm with the command

spacefm --desktop

Under Global Autostart I have turned off :-

Network
PulseAudio
Wicd
Power Manager

(Power Manager is the xfce one - the LXQt one is set in Basic settings)

My desktop has wired ether, so I am not using the network managers,

In order to configure the Panel, you can right click on the panel and select Configure Panel.

Setting up the Quick launch widget, involves dragging the desired programs from the start menu and dropping them on the Quick launch widget.

The wallpaper is set up by running spacefm and going to View>preferences>Desktop.

At this point, if I run lxqt-sudo rxvt -rv& it produces this warning (but still runs) :-

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "en_GB:en",
    LC_ALL = (unset),
    LC_MEASUREMENT = "en_NZ.UTF-8",
    LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").

I have used LC_MEASUREMENT = "en_NZ.UTF-8" in order to get metric measurements.
This warning does not appear under LXDE, but instead reports (and still works) :-

QXcbConnection: XCB error: 3 (BadWindow), sequence: 651, resource id: 16779311, major code: 40 (TranslateCoords), minor code: 0

Using Synaptic, if I try and mark libpolkit-backend-elogind-1-0 for installation it reports that it will also install libpolkit-gobject-elogind-1-0, while removing :-

consolekit
libpolkit-backend-consolekit-1-0
libpolkit-gobject-consolekit-1-0
lxde etc.
slim

I did the installation with :-

apt update
apt install libpolkit-backend-elogind-1-0

which then carried out the same things as Synaptic indicated. /var/log/apt/history.log reports :-

Start-Date: 2020-01-08  16:38:59
Commandline: apt install libpolkit-backend-elogind-1-0
Requested-By: ggibbs (1026)
Install: libpolkit-backend-elogind-1-0:amd64 (0.105-25+devuan0~bpo2+1), libpolkit-gobject-elogind-1-0:amd64 (0.105-25+devuan0~bpo2+1, automatic)
Remove: lxde-core:amd64 (9), consolekit:amd64 (0.4.6-6), slim:amd64 (1.3.6-5.1+devuan2), lxsession-logout:amd64 (0.5.3-2), libpolkit-backend-consolekit-1-0:amd64 (0.105-25+devuan0~bpo2+1), lxde:amd64 (9), lxsession:amd64 (0.5.3-2), openbox-lxde-session:amd64 (0.99.2-3), libpolkit-gobject-consolekit-1-0:amd64 (0.105-25+devuan0~bpo2+1)
End-Date: 2020-01-08  16:39:14

I have rebooted the machine and everything seems to work nicely. There are a couple of pop-ups which appear.
One is at login, when it reports that it is unable to bind the keys Control+Alt+D.
Another appears at shutdown but it disappears very quickly as the machine does indeed shutdown and I am unable to see what it says!

/var/log/messages reports :-

Jan  8 19:12:48 fluorine shutdown[4290]: shutting down for system halt
Jan  8 19:12:49 fluorine kernel: [ 2533.514734] lxqt-runner[3859]: segfault at 20 ip 00007fc12ecf9ea4 sp 00007ffd77a10790 error 6 in libQt5Core.so.5.7.1[7fc12ec54000+4be000]
Jan  8 19:12:49 fluorine kernel: [ 2533.514746] Code: 66 0f 1f 44 00 00 55 53 ba 01 00 00 00 48 83 ec 28 64 48 8b 04 25 28 00 00 00 48 89 44 24 18 31 c0 48 c7 44 24 08 00 00 00 00 <f0> 48 0f b1 17 0f 94 c2 74 05 48 89 44 24 08 84 d2 48 8b 5c 24 08

/var/log/auth.log  reports :-

Jan  8 18:31:15 fluorine polkitd(authority=local): Registered Authentication Agent for unix-session:1 (system bus name :1.12 [lxqt-policykit-agent], object path /org/lxqt/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
...
Jan  8 19:12:50 fluorine polkitd(authority=local): Unregistered Authentication Agent for unix-session:1 (system bus name :1.12, object path /org/lxqt/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8) (disconnected from bus)

The machine is currently running ASCII well with LXdm/LXQt and elogind. I will do some checking before I look at the upgrade to Beowulf itself...

Geoff

Offline

#2 2020-01-09 16:28:16

Geoff 42
Member
Registered: 2016-12-15
Posts: 296  

Re: Migrating from ASCII LXDE to Beowulf LXQt

I have managed to read some of the pop-up on shutdown. It seems to be a message about Dbus, which may well be correct, if it gets shutdown before I am completely logged out.

Geoff

Offline

#3 2020-01-10 07:16:36

Geoff 42
Member
Registered: 2016-12-15
Posts: 296  

Re: Migrating from ASCII LXDE to Beowulf LXQt

While LXQt is running nicely under ASCII, the other point to mention is that it also stops nicely, in that you can shutdown via the leave options in the menu. I am running OpenRC. Under ASCII, SysV init is still used but control is passed to openrc to start all of the other processes.

On my laptop, under Beowulf, OpenRC ships with a replacement for SysV init, and I am using this replacement. I cannot recall whether this is how it is installed, or whether I had to configure it to do that. Anyway, this affects how the system id shut down. If you just run shutdown, OpenRC seems to notice that things are stopping and seems to restart them. There is a replacement /usr/bin/openrc-shutdown which works correctly. There is just the question of how you run it from the GUI. I have hacked up a very crude pop-up with xmessage, which doesn't look very good, but does work. I am just checking what I did, as it was some time ago!

Geoff

Offline

#4 2020-01-10 08:10:59

Geoff 42
Member
Registered: 2016-12-15
Posts: 296  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Fortunately, someone has documented what was necessary to get openrc-init working correctly :-

https://dev1galaxy.org/viewtopic.php?id=2788

I must now check whether this info needs updating. ;-)

Geoff

Offline

#5 2020-01-11 17:50:31

Geoff 42
Member
Registered: 2016-12-15
Posts: 296  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Reviewing what I did earlier at I think that simply running OpenRC under Beowulf should be fairly straightforward, whereby it still uses SysV init to get things started, but uses OpenRC to start up services and daemons.

Using openrc-init to replace SysV init completely is a bit more complicated, not helped by a bug in version 0.40 which doesn't sequence things correctly. This has been fixed by version 0.41.2, although this does not appear to be available via Deian/Devuan.

It is possible to compile v 0.41.2 and move in openrc-init, as detailed at :-

https://dev1galaxy.org/viewtopic.php?pid=15539#p15539

It is also necessary to use openrc-shutdown instead of shutdown.

I notice that openrc has moved on to version 0.42.1. I have not yet tried this and, indeed, have only tried openrc-init from 0.41.2. If Devuan is getting OpenRC from Debian, then I wonder how quickly it is likely to get updated. Might we need to get it directly from the authors?

Geoff

Offline

#6 2020-01-18 09:55:48

Geoff 42
Member
Registered: 2016-12-15
Posts: 296  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Postgresql

As I have a small Postgresql database on my desktop machine, I wanted to check that this would be ok when I upgrade. I also use LibreOffice Base for adding new info to the database using SDBC.

I installed Postgresql on my Beowulf laptop, along with libreoffice-sdbc-postgresql.
On the ASCII desktop, I dumped the database as user "postgres" as given in the man page with :-

pg_dumpall -c > db.out

The "-c" adds commands to clean out anything in the new database before adding the dumped data.

On the Beowulf laptop, as user postgres, I restored this data with :-

psql -f db.out postgres

This worked and having also copied over the .odb file I tried accessing the database from LibreOffice Base, which also "just worked".

This has given me confidence that should there be any problems with the upgrade, that I have a work-a-round.

Geoff

Offline

Board footer