The officially official Devuan Forum!

You are not logged in.

#1 2020-01-09 10:39:46

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Migrating from ASCII LXDE to Beowulf LXQt

I have a laptop running Beowulf and Lxdm/LXQt and I want to migrate my desktop from ASCII and LXDE/Lxdm to the same as the laptop, as it seems that LXQt works a bit more smoothly with the policykit set-ups available. I do have a few other things running under ASCII (including Postgresql, Postfix), so want to be a bit careful.

The plan was to move over to LXQt from LXDE, whilst still under ASCII and then ensure that the policykit stuff was set up correctly.

I currently have the following installed :-

elogind
libelogind0
libpam-elogind

consolekit
libck-connector0
libpolkit-backend-consolekit-1-0
libpolkit-gobject-consolekit-1-0

This is working with LXDE/Lxdm. It also seems to work ok with LXQt/Lxdm.

Moving to LXQt works, but it did take quite a bit of fiddling to get it running as I like it. I use spacefm instead of pcmanfm, which also looks after the desktop wallpaper. To get this running I went into Preferences>LXQt settings>Session settings

Under Basic Settings, I turned off Desktop, which is the module for pcmanfm, with the other modules all selected.
Under Autostart LXQt Autostart I added spacefm with the command

spacefm --desktop

Under Global Autostart I have turned off :-

Network
PulseAudio
Wicd
Power Manager

(Power Manager is the xfce one - the LXQt one is set in Basic settings)

My desktop has wired ether, so I am not using the network managers,

In order to configure the Panel, you can right click on the panel and select Configure Panel.

Setting up the Quick launch widget, involves dragging the desired programs from the start menu and dropping them on the Quick launch widget.

The wallpaper is set up by running spacefm and going to View>preferences>Desktop.

At this point, if I run lxqt-sudo rxvt -rv& it produces this warning (but still runs) :-

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "en_GB:en",
    LC_ALL = (unset),
    LC_MEASUREMENT = "en_NZ.UTF-8",
    LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").

I have used LC_MEASUREMENT = "en_NZ.UTF-8" in order to get metric measurements.
This warning does not appear under LXDE, but instead reports (and still works) :-

QXcbConnection: XCB error: 3 (BadWindow), sequence: 651, resource id: 16779311, major code: 40 (TranslateCoords), minor code: 0

Using Synaptic, if I try and mark libpolkit-backend-elogind-1-0 for installation it reports that it will also install libpolkit-gobject-elogind-1-0, while removing :-

consolekit
libpolkit-backend-consolekit-1-0
libpolkit-gobject-consolekit-1-0
lxde etc.
slim

I did the installation with :-

apt update
apt install libpolkit-backend-elogind-1-0

which then carried out the same things as Synaptic indicated. /var/log/apt/history.log reports :-

Start-Date: 2020-01-08  16:38:59
Commandline: apt install libpolkit-backend-elogind-1-0
Requested-By: ggibbs (1026)
Install: libpolkit-backend-elogind-1-0:amd64 (0.105-25+devuan0~bpo2+1), libpolkit-gobject-elogind-1-0:amd64 (0.105-25+devuan0~bpo2+1, automatic)
Remove: lxde-core:amd64 (9), consolekit:amd64 (0.4.6-6), slim:amd64 (1.3.6-5.1+devuan2), lxsession-logout:amd64 (0.5.3-2), libpolkit-backend-consolekit-1-0:amd64 (0.105-25+devuan0~bpo2+1), lxde:amd64 (9), lxsession:amd64 (0.5.3-2), openbox-lxde-session:amd64 (0.99.2-3), libpolkit-gobject-consolekit-1-0:amd64 (0.105-25+devuan0~bpo2+1)
End-Date: 2020-01-08  16:39:14

I have rebooted the machine and everything seems to work nicely. There are a couple of pop-ups which appear.
One is at login, when it reports that it is unable to bind the keys Control+Alt+D.
Another appears at shutdown but it disappears very quickly as the machine does indeed shutdown and I am unable to see what it says!

/var/log/messages reports :-

Jan  8 19:12:48 fluorine shutdown[4290]: shutting down for system halt
Jan  8 19:12:49 fluorine kernel: [ 2533.514734] lxqt-runner[3859]: segfault at 20 ip 00007fc12ecf9ea4 sp 00007ffd77a10790 error 6 in libQt5Core.so.5.7.1[7fc12ec54000+4be000]
Jan  8 19:12:49 fluorine kernel: [ 2533.514746] Code: 66 0f 1f 44 00 00 55 53 ba 01 00 00 00 48 83 ec 28 64 48 8b 04 25 28 00 00 00 48 89 44 24 18 31 c0 48 c7 44 24 08 00 00 00 00 <f0> 48 0f b1 17 0f 94 c2 74 05 48 89 44 24 08 84 d2 48 8b 5c 24 08

/var/log/auth.log  reports :-

Jan  8 18:31:15 fluorine polkitd(authority=local): Registered Authentication Agent for unix-session:1 (system bus name :1.12 [lxqt-policykit-agent], object path /org/lxqt/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
...
Jan  8 19:12:50 fluorine polkitd(authority=local): Unregistered Authentication Agent for unix-session:1 (system bus name :1.12, object path /org/lxqt/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8) (disconnected from bus)

The machine is currently running ASCII well with LXdm/LXQt and elogind. I will do some checking before I look at the upgrade to Beowulf itself...

Geoff

Offline

#2 2020-01-09 16:28:16

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

I have managed to read some of the pop-up on shutdown. It seems to be a message about Dbus, which may well be correct, if it gets shutdown before I am completely logged out.

Geoff

Offline

#3 2020-01-10 07:16:36

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

While LXQt is running nicely under ASCII, the other point to mention is that it also stops nicely, in that you can shutdown via the leave options in the menu. I am running OpenRC. Under ASCII, SysV init is still used but control is passed to openrc to start all of the other processes.

On my laptop, under Beowulf, OpenRC ships with a replacement for SysV init, and I am using this replacement. I cannot recall whether this is how it is installed, or whether I had to configure it to do that. Anyway, this affects how the system id shut down. If you just run shutdown, OpenRC seems to notice that things are stopping and seems to restart them. There is a replacement /usr/bin/openrc-shutdown which works correctly. There is just the question of how you run it from the GUI. I have hacked up a very crude pop-up with xmessage, which doesn't look very good, but does work. I am just checking what I did, as it was some time ago!

Geoff

Offline

#4 2020-01-10 08:10:59

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Fortunately, someone has documented what was necessary to get openrc-init working correctly :-

https://dev1galaxy.org/viewtopic.php?id=2788

I must now check whether this info needs updating. ;-)

Geoff

Offline

#5 2020-01-11 17:50:31

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Reviewing what I did earlier at I think that simply running OpenRC under Beowulf should be fairly straightforward, whereby it still uses SysV init to get things started, but uses OpenRC to start up services and daemons.

Using openrc-init to replace SysV init completely is a bit more complicated, not helped by a bug in version 0.40 which doesn't sequence things correctly. This has been fixed by version 0.41.2, although this does not appear to be available via Deian/Devuan.

It is possible to compile v 0.41.2 and move in openrc-init, as detailed at :-

https://dev1galaxy.org/viewtopic.php?pid=15539#p15539

It is also necessary to use openrc-shutdown instead of shutdown.

I notice that openrc has moved on to version 0.42.1. I have not yet tried this and, indeed, have only tried openrc-init from 0.41.2. If Devuan is getting OpenRC from Debian, then I wonder how quickly it is likely to get updated. Might we need to get it directly from the authors?

Geoff

Offline

#6 2020-01-18 09:55:48

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Postgresql

As I have a small Postgresql database on my desktop machine, I wanted to check that this would be ok when I upgrade. I also use LibreOffice Base for adding new info to the database using SDBC.

I installed Postgresql on my Beowulf laptop, along with libreoffice-sdbc-postgresql.
On the ASCII desktop, I dumped the database as user "postgres" as given in the man page with :-

pg_dumpall -c > db.out

The "-c" adds commands to clean out anything in the new database before adding the dumped data.

On the Beowulf laptop, as user postgres, I restored this data with :-

psql -f db.out postgres

This worked and having also copied over the .odb file I tried accessing the database from LibreOffice Base, which also "just worked".

This has given me confidence that should there be any problems with the upgrade, that I have a work-a-round.

Geoff

Offline

#7 2020-01-24 16:33:43

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Doing the upgrade

I had a review of my earlier efforts :-
https://dev1galaxy.org/viewtopic.php?id=2752

I updated /etc/apt/sources.list replacing ascii with beowulf and commented out entries apart from the main one and updates and security.

deb http://deb.devuan.org/merged/ beowulf main contrib non-free
deb http://deb.devuan.org/merged/ beowulf-updates main contrib non-free
deb http://deb.devuan.org/merged/ beowulf-security main contrib non-free
# deb http://deb.devuan.org/merged/ beowulf-backports main contrib non-free
# deb http://deb.devuan.org/devuan/ beowulf-proposed main contrib non-free
# deb http://deb.devuan.org/merged/ beowulf-proposed-updates non-free contrib main 

# deb https://pkgmaster.devuan.org/devuan/ beowulf-proposed-backports main contrib non-free
# deb https://pkgmaster.devuan.org/devuan/ beowulf-proposed-security main contrib non-free

I then tried the upgrade :-

apt update
apt list --upgradable
apt full-upgrade

This stopped for lack of space.

1804 upgraded, 394 newly installed, 31 to remove and 3 not upgraded.
Need to get 3,782 MB of archives.
After this operation, 2,242 MB of additional disk space will be used.
E: You don't have enough free space in /var/cache/apt/archives/.

I have /var on a rotating disc and hadn't cleaned up! I needed :-

apt-get autoclean

Which gave me 7.4G on /var

apt full-upgrade

This then proceeded, but produced quite a lot of warnings, but I carried on anyway.

Unpacking proceeds...

Selecting previously unselected package emacs-gtk.
Preparing to unpack .../34-emacs-gtk_1%3a26.1+1-3.2+deb10u1_amd64.deb ...
Unpacking emacs-gtk (1:26.1+1-3.2+deb10u1) ...
Errors were encountered while processing:
/tmp/apt-dpkg-install-aisgOf/01-libjsp-api-java_2.3.4-2_all.deb
/tmp/apt-dpkg-install-aisgOf/02-libel-api-java_3.0.0-2_all.deb
/tmp/apt-dpkg-install-aisgOf/03-libwebsocket-api-java_1.1-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

so I tried fix broken:-

apt --fix-broken install

this proceeds until :-

Processing triggers for initramfs-tools (0.133+deb10u1) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-0.bpo.4-amd64
W: Possible missing firmware /lib/firmware/i915/bxt_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_dmc_ver1_27.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cnl_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_39.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver9_29.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_ver9_33.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_huc_ver02_00_1810.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_huc_ver01_07_1398.bin for module i915
live-boot: core filesystems devices utils udev wget blockdev dns.
Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.38.1+dfsg-1) ...
Errors were encountered while processing:
openrc
initscripts
E: Sub-process /usr/bin/dpkg returned an error code (1)

apt --fix-broken install

* Caching service dependencies ...
Segmentation fault
dpkg: error processing package openrc (--configure):
subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of initscripts:
initscripts depends on sysv-rc | file-rc | openrc; however:
  Package sysv-rc is not installed.
  Package file-rc is not installed.
  Package openrc is not configured yet.

dpkg: error processing package initscripts (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
openrc
initscripts
E: Sub-process /usr/bin/dpkg returned an error code (1)

It appears that rc-update has installed the runlevels, but openrc is reported as not configured yet.

I ran synaptic and forced the version of upower to 0.99.10-1 and also fix broken packages.

apt full-upgrade

then proceeds to 97%

Errors were encountered while processing:
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

apt --fix-broken install

live-boot: core filesystems devices utils udev blockdev dns.
pigz: abort: write error on <stdout> (No space left on device)
E: mkinitramfs failure cpio 141 pigz 28
update-initramfs: failed for /boot/initrd.img-4.19.0-6-amd64 with 1.
dpkg: error processing package initramfs-tools (--configure):
installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

So it looked like /boot was out of space, so I used synaptic to remove kernel 3.10.

apt --fix-broken install

The following packages have been kept back:
  elogind libelogind0 libpam-elogind
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

So, using synaptic I told it to upgrade elogind and it says that it will remove :-

libsystemd0and some i386 stuff, inc. wine

I let it do this and then

apt full-upgrade

now only reports stuff that can be removed by apt autoremove and seems to have completed the upgrade. I then wanted to check that Postgresql was ok.

Postgresql

Following the upgrade message about postgresql I tried :-

su - postgres
reindexdb --all
pg_lsclusters 

Ver Cluster Port Status Owner    Data directory               Log file
9.6 main    5432 online postgres /var/lib/postgresql/9.6/main /var/log/postgresql/postgresql-9.6-main.log
11  main    5433 online postgres /var/lib/postgresql/11/main  /var/log/postgresql/postgresql-11-main.log

pg_upgradecluster 9.6 main
Error: target cluster 11/main already exists

I went back over what I did last time and did this :-

pg_dropcluster --stop 11 main
pg_lsclusters

Ver Cluster Port Status Owner    Data directory               Log file
9.6 main    5432 online postgres /var/lib/postgresql/9.6/main /var/log/postgresql/postgresql-9.6-main.log

pg_upgradecluster 9.6 main
pg_lsclusters 

Ver Cluster Port Status Owner    Data directory               Log file
9.6 main    5433 down   postgres /var/lib/postgresql/9.6/main /var/log/postgresql/postgresql-9.6-main.log
11  main    5432 online postgres /var/lib/postgresql/11/main  /var/log/postgresql/postgresql-11-main.log

This appeared to be correct so as me :-

psql --no-align --pset=footer=off --file=events_view.sql

(Where the .sql file is my report generating sql) and it produces the correct data.
LibreOffice Base also connects correctly. So, I am happy that part of the upgrade is ok.

Other stuff

running emacs produces :-

(emacs:18729): dconf-CRITICAL **: 18:49:30.167: unable to create directory '/run/user/1026/dconf': Permission denied.  dconf will not work properly.

but it does run.

I could run synaptic from the menu and authorise myself.

Claws-mail still works, but the fancy html viewer has gone.
In its place you can load the Dillo viewer under configuration>plugins
I can't see the liteHTML viewer... it is in Ceres.

https://dev1galaxy.org/viewtopic.php?id=3119

Chromium does not want to run. It needs the sandbox :-

apt install chromium-sandbox

VNC seems to work.

lxqt-sudo works.

Can I logout and back in?
Yes, but the login was very slow. The windowing environment eventually came up but there was no panel.
I could switch to tty1 with ctrl-alt-f1 and had to :-

apt install lxqt-panel

I was then able to get the panel running with Openbox.
I then tried to reboot but had to get a root window and run

/sbin/shutdown -r now

After the reboot, I was able to log in with no delay and the panel came up as expected. Also the errors about /run/user had gone away.

Following the reboot, I was able to shut the machine down via the lxqt-panel.

Also, despite some warning during the upgrade about Grub can't load initrd for Xen after upgrade to Buster, I was also able to boot up under the Xen hypervisor. I need to check a message about the cpu security features with Xen.

All of the basic stuff seems to be working nicely.

Geoff

edited to correct the sequence of Postgresql commands

Last edited by Geoff 42 (2020-02-04 09:51:27)

Offline

#8 2020-01-26 16:40:34

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

What should I have done

Make sure that there is enough disc space!

If you have /var as a separate partition you may need to tidy the apt cache :-

apt-get autoclean

If /boot is a separate partition you may need to remove a few old kernels.

Apt is reasonably resiliant and does check the disk space and will not run if there is not enough, although grub does not spot the lack of space in /boot until the upgrade is under way.

Wine and i386

There do seem to be difficulties with Wine and i386 on an amd64 installation.

If you do not need it, remove it. If you do need it, study this :-

https://dev1galaxy.org/viewtopic.php?id=2987

upower

I think that there is no alternative to manually forcing the version of upower as the old version has "1:" in front of the version number, which makes it look newer that the real new one! It therefore looks like a downgrade, but this is what you should accept.

Postgresql

I have included the path to the Postgresql commands in my .profile and this needed to be updated for the new version so that .profile includes the lines :-

if [ -d "/usr/lib/postgresql/11/bin" ] ; then
    PATH="/usr/lib/postgresql/11/bin:$PATH"
fi

Geoff

Offline

#9 2020-01-31 08:46:14

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Postgresql

The section about setting the path for Postgresql is unnecessary. There are a set of wrapper scripts in /usr/bin which sort out the version for you, so that you do not need to add anything special to your path.

Geoff

Offline

#10 2020-02-05 10:20:26

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

Postgresql

After the upgrade I tidied up the old version of Postgresql using Synaptic, removing :-

postgresql-9.6
postgresql-client-9.6
postgresql-contrib-9.6

This produced an error message, but when I repeated it to capture the message, it just worked!

pg_lsclusters 

Ver Cluster Port Status Owner    Data directory              Log file
11  main    5432 down   postgres /var/lib/postgresql/11/main /var/log/postgresql/postgresql-11-main.log

as root :-

/etc/init.d/postgresql status

11/main (port 5432): down

/etc/init.d/postgresql start

[ ok ] Starting PostgreSQL 11 database server: main.

then as me :-

pg_lsclusters

Ver Cluster Port Status Owner    Data directory              Log file
11  main    5432 online postgres /var/lib/postgresql/11/main /var/log/postgresql/postgresql-11-main.log

Geoff

Offline

#11 2020-02-10 16:38:07

Geoff 42
Member
Registered: 2016-12-15
Posts: 311  

Re: Migrating from ASCII LXDE to Beowulf LXQt

VLC

I had downloaded a couple of programs from the BBC with get_iplayer and them tried viewing them with VLC and the video did not work. If I fiddled with the settings, VLC seemed to hang. I have now tried viewing with Kodi and these programs display correctly. I believe that VLC was working correctly before I upgraded to Beowulf.

Geoff

Offline

Board footer