The officially official Devuan Forum!

You are not logged in.

#1 2019-11-21 20:53:30

kapqa
Member
Registered: 2019-01-02
Posts: 64  

(building handbrake) error with pkg-config

Hello ,

i try to build Handbrake from source on Devuan Ascii.

the following error occurs during ./config :

ERROR: minimum required pkg-config version is 0.29.1 and /usr/bin/pkg-config is 0.29



however

sudo apt install pkg-config
Reading package lists... Done
Building dependency tree       
Reading state information... Done
pkg-config is already the newest version (0.29-4+b1).

Online

#2 2019-11-22 20:21:22

bgstack15
Member
Registered: 2018-02-04
Posts: 83  

Re: (building handbrake) error with pkg-config

Ah, the way package version tends to work is the application upstream chooses a version string. In this case, the upstream version number is "0.29" without quotes. The package has its own versioning, which is "4+b1" which means it is the fourth attempt to package this application version, with the additional value "+b1" which could mean anything you want it to mean. I see lots of "+devuan2.1" and similar at the end of the package version.
So, you put the application version and package version together with a dash, to get "0.29-4+b1" which unfortunately is lower than the application version "0.29.1".
The Handbrake upstream must follow the upstream pkg-config more aggressively than Devuan (probably Debian) does. Perhaps they base their dpkg on Ubuntu which uses a higher version of pkg-config, or something, at this very moment.
Turns out pkg-config is a freedesktop.org thing. (That explains a few things...) The current version as of this post is 0.29.2


This space intentionally left blank.

Offline

Board footer